]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/4.12: common-pc*: enable X2APIC by default
authorBruce Ashfield <bruce.ashfield@windriver.com>
Thu, 21 Dec 2017 15:49:19 +0000 (10:49 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 6 Jan 2018 10:11:42 +0000 (10:11 +0000)
Enabling CONFIG_X86_X2APIC=y by default for common-pc* (and hence
qemux86*) to work around interrupt delivery issues when running on some
host kernels.

There's little overhead with this, and no impact to non x2apic
platforms, so we enable it for all builds.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 3382ed4925fdc0854dbfa5b29dd5fdc1e0c1e38a)
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
meta/recipes-kernel/linux/linux-yocto_4.12.bb

index 267f730c60e29ac7cca872524459ed38aa53c5f8..7fe078b17a407df732eadf27eae7aaa3a378a024 100644 (file)
@@ -12,7 +12,7 @@ python () {
 }
 
 SRCREV_machine ?= "8f6a2f93758166ef40e56f907a067801fee88d75"
-SRCREV_meta ?= "0eb9d6eb80a2bc3c42a351b747c319ef40df08db"
+SRCREV_meta ?= "b66a4f9730339b3c0c4af1db03dd26da71e419d5"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"
index 79fa38ba49a6be90f60b4642e4bafc4025ca976b..784efc07f42fe36661fdac95cff68ed78e43fa8e 100644 (file)
@@ -10,7 +10,7 @@ KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine ?= "79394be8305b3c3ba2d6711ae48e08bf015fbae9"
-SRCREV_meta ?= "0eb9d6eb80a2bc3c42a351b747c319ef40df08db"
+SRCREV_meta ?= "b66a4f9730339b3c0c4af1db03dd26da71e419d5"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index 42672b78d3af26a2dddacfb6f7b149ecd099684a..771c8b262c16e2d123cc7e87a31132298340f945 100644 (file)
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "79394be8305b3c3ba2d6711ae48e08bf015fbae9"
 SRCREV_machine_qemux86-64 ?= "79394be8305b3c3ba2d6711ae48e08bf015fbae9"
 SRCREV_machine_qemumips64 ?= "8c0a56e5a553ac3a985949ae8d0fc35d54779756"
 SRCREV_machine ?= "79394be8305b3c3ba2d6711ae48e08bf015fbae9"
-SRCREV_meta ?= "0eb9d6eb80a2bc3c42a351b747c319ef40df08db"
+SRCREV_meta ?= "b66a4f9730339b3c0c4af1db03dd26da71e419d5"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;name=machine;branch=${KBRANCH}; \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"