]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add clutter, clutter-cairo, clutter-gst, aaina and table, excluded from world builds...
authorRichard Purdie <richard@openedhand.com>
Tue, 10 Jul 2007 14:06:27 +0000 (14:06 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 10 Jul 2007 14:06:27 +0000 (14:06 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2143 311d38ba-8fff-0310-9ca6-ca027cbcb966

16 files changed:
meta/conf/distro/poky.conf
meta/packages/clutter/aaina.inc [new file with mode: 0644]
meta/packages/clutter/aaina_svn.bb [new file with mode: 0644]
meta/packages/clutter/clutter-cairo.inc [new file with mode: 0644]
meta/packages/clutter/clutter-cairo/enable_examples.patch [new file with mode: 0644]
meta/packages/clutter/clutter-cairo_svn.bb [new file with mode: 0644]
meta/packages/clutter/clutter-fpu.inc [new file with mode: 0644]
meta/packages/clutter/clutter-gst.inc [new file with mode: 0644]
meta/packages/clutter/clutter-gst/autofoo.patch [new file with mode: 0644]
meta/packages/clutter/clutter-gst_svn.bb [new file with mode: 0644]
meta/packages/clutter/clutter.inc [new file with mode: 0644]
meta/packages/clutter/clutter/enable_tests.patch [new file with mode: 0644]
meta/packages/clutter/clutter_svn.bb [new file with mode: 0644]
meta/packages/clutter/table.inc [new file with mode: 0644]
meta/packages/clutter/table/fixes.patch [new file with mode: 0644]
meta/packages/clutter/table_svn.bb [new file with mode: 0644]

index d7e7d8b16ab3f1b82be083828a54eabeeba35cfe..00d53360a3251ce93c94b7990cc934dc53e1d1aa 100644 (file)
@@ -119,7 +119,7 @@ SRCDATE_libsyncml = "20070529"
 SRCDATE_matchbox-applet-light = "20070529"
 SRCDATE_fstests = "20070529"
 SRCDATE_abiword ?= "20070130"
-SRCDATE_xvideo-tests ?= "20070623"
+SRCDATE_xvideo-tests ?= "20070702"
 
 #
 # Preferred Versions:
@@ -231,3 +231,9 @@ EXCLUDE_FROM_WORLD_pn-syncml-client = "1"
 # temporary
 EXCLUDE_FROM_WORLD_pn-lirc = "1"
 EXCLUDE_FROM_WORLD_pn-lirc-modules = "1"
+# clutter needs some kind of gl to build, not yet added
+EXCLUDE_FROM_WORLD_clutter = "1"
+EXCLUDE_FROM_WORLD_clutter-cairo = "1"
+EXCLUDE_FROM_WORLD_clutter-gst = "1"
+EXCLUDE_FROM_WORLD_aaina = "1"
+EXCLUDE_FROM_WORLD_table = "1"
\ No newline at end of file
diff --git a/meta/packages/clutter/aaina.inc b/meta/packages/clutter/aaina.inc
new file mode 100644 (file)
index 0000000..fbef34f
--- /dev/null
@@ -0,0 +1,12 @@
+DESCRIPTION = "Aaina Clutter Demo"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "GPL"
+
+DEPENDS = "clutter libxml2 gtk+ neon"
+
+inherit autotools pkgconfig
+
+do_stage () {
+        autotools_stage_all
+}
+
diff --git a/meta/packages/clutter/aaina_svn.bb b/meta/packages/clutter/aaina_svn.bb
new file mode 100644 (file)
index 0000000..d6e81b1
--- /dev/null
@@ -0,0 +1,8 @@
+require aaina.inc
+
+PV = "0.3.0+svn${SRCDATE}"
+PR = "r1"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk/toys;module=aaina;proto=http"
+
+S = "${WORKDIR}/aaina"
diff --git a/meta/packages/clutter/clutter-cairo.inc b/meta/packages/clutter/clutter-cairo.inc
new file mode 100644 (file)
index 0000000..1095a7e
--- /dev/null
@@ -0,0 +1,15 @@
+DESCRIPTION = "Clutter Cairo"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPL"
+
+DEPENDS = "clutter cairo"
+
+PACKAGES =+ "${PN}-examples"
+FILES_${PN}-examples = "${bindir}/flowers ${bindir}/clock"
+
+inherit autotools pkgconfig
+
+do_stage () {
+        autotools_stage_all
+}
+
diff --git a/meta/packages/clutter/clutter-cairo/enable_examples.patch b/meta/packages/clutter/clutter-cairo/enable_examples.patch
new file mode 100644 (file)
index 0000000..c1cddf6
--- /dev/null
@@ -0,0 +1,28 @@
+---
+ examples/Makefile.am |    2 +-
+ examples/flowers.c   |    2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+Index: clutter-cairo/examples/Makefile.am
+===================================================================
+--- clutter-cairo.orig/examples/Makefile.am    2007-07-10 00:25:03.000000000 +0100
++++ clutter-cairo/examples/Makefile.am 2007-07-10 12:06:49.000000000 +0100
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = clock flowers
++bin_PROGRAMS = clock flowers
+ INCLUDES = -I$(top_srcdir)/ @GCC_FLAGS@ @DEPS_CFLAGS@
+ LDFLAGS = @DEPS_LIBS@ $(top_builddir)/libclutter-cairo-@CLUTTER_CAIRO_MAJORMINOR@.la 
+Index: clutter-cairo/examples/flowers.c
+===================================================================
+--- clutter-cairo.orig/examples/flowers.c      2007-07-10 12:30:44.000000000 +0100
++++ clutter-cairo/examples/flowers.c   2007-07-10 12:30:51.000000000 +0100
+@@ -11,7 +11,7 @@
+ #define PETAL_MIN 20
+ #define PETAL_VAR 40
+-#define N_FLOWERS 40 /* reduce if you have a small card */
++#define N_FLOWERS 8 /* reduce if you have a small card */
+ typedef struct Flower
+ {
diff --git a/meta/packages/clutter/clutter-cairo_svn.bb b/meta/packages/clutter/clutter-cairo_svn.bb
new file mode 100644 (file)
index 0000000..c4becfd
--- /dev/null
@@ -0,0 +1,11 @@
+require clutter-cairo.inc
+
+PV = "0.3.0+svn${SRCDATE}"
+PR = "r2"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk;module=${PN};proto=http \
+           file://enable_examples.patch;patch=1"
+
+S = "${WORKDIR}/${PN}"
+
+
diff --git a/meta/packages/clutter/clutter-fpu.inc b/meta/packages/clutter/clutter-fpu.inc
new file mode 100644 (file)
index 0000000..21a16fe
--- /dev/null
@@ -0,0 +1,6 @@
+
+def get_clutter_fpu_setting(bb, d):
+       if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+               return "--without-fpu"
+       return ""
+
diff --git a/meta/packages/clutter/clutter-gst.inc b/meta/packages/clutter/clutter-gst.inc
new file mode 100644 (file)
index 0000000..caaa755
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Clutter GStreamer"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPL"
+
+DEPENDS = "clutter gstreamer gst-plugins-base"
+
+PACKAGES =+ "${PN}-examples"
+FILES_${PN}-examples = "${bindir}/video-player ${bindir}/video-sink ${bindir}/audio"
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+        touch ${S}/gtk-doc.make
+}
+
+do_stage () {
+        autotools_stage_all
+}
+
diff --git a/meta/packages/clutter/clutter-gst/autofoo.patch b/meta/packages/clutter/clutter-gst/autofoo.patch
new file mode 100644 (file)
index 0000000..f5b8ef7
--- /dev/null
@@ -0,0 +1,45 @@
+---
+ configure.ac              |    2 +-
+ doc/reference/Makefile.am |    2 +-
+ examples/Makefile.am      |   14 +++++++-------
+ 3 files changed, 9 insertions(+), 9 deletions(-)
+
+Index: clutter-gst/examples/Makefile.am
+===================================================================
+--- clutter-gst.orig/examples/Makefile.am      2007-07-10 13:01:28.000000000 +0100
++++ clutter-gst/examples/Makefile.am   2007-07-10 13:07:33.000000000 +0100
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = video-player video-sink audio
++bin_PROGRAMS = video-player video-sink audio
+ INCLUDES = -I$(top_srcdir)/
+@@ -9,12 +9,12 @@ video_player_LDFLAGS = \
+     $(GST_LIBS)   \
+     $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la 
+-video_cube_SOURCES = video-cube.c
+-video_cube_CFLAGS = $(CLUTTER_GST_CFLAGS) $(GST_CFLAGS)
+-video_cube_LDFLAGS = \
+-    $(CLUTTER_LIBS) \
+-    $(GST_LIBS)   \
+-    $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la 
++#video_cube_SOURCES = video-cube.c
++#video_cube_CFLAGS = $(CLUTTER_GST_CFLAGS) $(GST_CFLAGS)
++#video_cube_LDFLAGS = \
++#    $(CLUTTER_LIBS) \
++#    $(GST_LIBS)   \
++#    $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la 
+ video_sink_SOURCES = video-sink.c
+ video_sink_CFLAGS = $(CLUTTER_GST_CFLAGS) $(GST_CFLAGS)
+Index: clutter-gst/doc/reference/Makefile.am
+===================================================================
+--- clutter-gst.orig/doc/reference/Makefile.am 2007-07-10 13:01:17.000000000 +0100
++++ clutter-gst/doc/reference/Makefile.am      2007-07-10 13:02:50.000000000 +0100
+@@ -77,4 +77,4 @@ include $(top_srcdir)/gtk-doc.make
+ # Other files to distribute
+ # e.g. EXTRA_DIST += version.xml.in
+-EXTRA_DIST += version.xml.in
++EXTRA_DIST = version.xml.in
diff --git a/meta/packages/clutter/clutter-gst_svn.bb b/meta/packages/clutter/clutter-gst_svn.bb
new file mode 100644 (file)
index 0000000..1bffee0
--- /dev/null
@@ -0,0 +1,11 @@
+require clutter-gst.inc
+
+PV = "0.3.0+svn${SRCDATE}"
+PR = "r3"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk;module=${PN};proto=http \
+           file://autofoo.patch;patch=1"
+
+S = "${WORKDIR}/${PN}"
+
+
diff --git a/meta/packages/clutter/clutter.inc b/meta/packages/clutter/clutter.inc
new file mode 100644 (file)
index 0000000..b5648c4
--- /dev/null
@@ -0,0 +1,27 @@
+DESCRIPTION = "Clutter graphics library"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPL"
+
+STDDEPENDS = "virtual/libx11 gtk-doc pango glib-2.0 libxfixes"
+BASE_CONF = "--disable-gtk-doc ${@get_clutter_fpu_setting(bb, d)}"
+
+DEPENDS = "${STDDEPENDS}"
+EXTRA_OECONF = "${BASE_CONF}"
+
+inherit autotools pkgconfig
+
+#check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
+require clutter-fpu.inc
+
+#Fix up some weirdness in the docs
+do_configure_prepend() {
+       touch ${S}/gtk-doc.make
+        sed -i s:doc/reference/Makefile::g ${S}/configure.ac
+        sed -i s:doc::g ${S}/Makefile.am
+}
+
+do_stage () {
+       cp ${S}/clutter.pc ${S}/clutter-0.3.pc
+        autotools_stage_all
+}
+
diff --git a/meta/packages/clutter/clutter/enable_tests.patch b/meta/packages/clutter/clutter/enable_tests.patch
new file mode 100644 (file)
index 0000000..06c2c4e
--- /dev/null
@@ -0,0 +1,52 @@
+---
+ tests/Makefile.am   |    7 ++++++-
+ tests/test-actors.c |    2 +-
+ tests/test-text.c   |    2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter/tests/Makefile.am
+===================================================================
+--- clutter.orig/tests/Makefile.am     2007-07-09 13:51:59.000000000 +0100
++++ clutter/tests/Makefile.am  2007-07-09 19:14:47.000000000 +0100
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+                   test-actors test-behave test-text test-entry test-project \
+                 test-boxes test-perspective
+@@ -19,4 +19,9 @@ test_project_SOURCES   = test-project.c
+ test_boxes_SOURCES     = test-boxes.c
+ test_perspective_SOURCES = test-perspective.c
++test_textdir           = $(pkgdatadir)
++test_text_DATA         = test-text.c
++test_actorsdir         = $(pkgdatadir)
++test_actors_DATA       = redhand.png
++
+ EXTRA_DIST = redhand.png
+Index: clutter/tests/test-actors.c
+===================================================================
+--- clutter.orig/tests/test-actors.c   2007-07-09 19:17:50.000000000 +0100
++++ clutter/tests/test-actors.c        2007-07-09 19:18:10.000000000 +0100
+@@ -146,7 +146,7 @@ main (int argc, char *argv[])
+   stage = clutter_stage_get_default ();
+   clutter_actor_set_size (stage, 800, 600);
+-  pixbuf = gdk_pixbuf_new_from_file ("redhand.png", NULL);
++  pixbuf = gdk_pixbuf_new_from_file ("/usr/share/clutter/redhand.png", NULL);
+   if (!pixbuf)
+     g_error("pixbuf load failed");
+Index: clutter/tests/test-text.c
+===================================================================
+--- clutter.orig/tests/test-text.c     2007-07-09 19:17:57.000000000 +0100
++++ clutter/tests/test-text.c  2007-07-09 19:18:47.000000000 +0100
+@@ -27,7 +27,7 @@ main (int argc, char *argv[])
+   stage = clutter_stage_get_default ();
+-  if (!g_file_get_contents ("test-text.c", &text, &size, NULL)) 
++  if (!g_file_get_contents ("/usr/share/clutter/test-text.c", &text, &size, NULL))
+     g_error("g_file_get_contents() of test-text.c failed");
+   clutter_actor_set_size (stage, 800, 600);
diff --git a/meta/packages/clutter/clutter_svn.bb b/meta/packages/clutter/clutter_svn.bb
new file mode 100644 (file)
index 0000000..ced1a17
--- /dev/null
@@ -0,0 +1,11 @@
+require clutter.inc
+
+PV = "0.3.0+svn${SRCDATE}"
+PR = "r7"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk;module=clutter;proto=http \
+          file://enable_tests.patch;patch=1 "
+
+S = "${WORKDIR}/clutter"
+
+
diff --git a/meta/packages/clutter/table.inc b/meta/packages/clutter/table.inc
new file mode 100644 (file)
index 0000000..6ee1672
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "Table Clutter Demo"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPL"
+
+DEPENDS = "clutter-gst gnome-vfs"
+
+inherit autotools pkgconfig
+
+do_install() {
+       install -d ${D}${bindir}
+       install -m 0755 ${S}/table ${D}${bindir}/table
+}
+
+#do_stage () {
+#        autotools_stage_all
+#}
+
diff --git a/meta/packages/clutter/table/fixes.patch b/meta/packages/clutter/table/fixes.patch
new file mode 100644 (file)
index 0000000..a7cdc43
--- /dev/null
@@ -0,0 +1,14 @@
+Index: table/Makefile
+===================================================================
+--- table.orig/Makefile        2007-07-10 13:24:18.000000000 +0100
++++ table/Makefile     2007-07-10 13:28:10.000000000 +0100
+@@ -8,7 +8,7 @@ all: table
+ table: table.o clutter-dominatrix.o clutter-video-player.o
+-      $(CC) -g -Wall $(CFLAGS) -o $@ table.o clutter-dominatrix.o clutter-video-player.o $(LIBS)
++      $(CC) -g -Wall $(CFLAGS) $(LDFLAGS) -o $@ table.o clutter-dominatrix.o clutter-video-player.o $(LIBS)
+ clean:
+       rm -fr *.o table
+\ No newline at end of file
diff --git a/meta/packages/clutter/table_svn.bb b/meta/packages/clutter/table_svn.bb
new file mode 100644 (file)
index 0000000..d0dc86c
--- /dev/null
@@ -0,0 +1,11 @@
+require table.inc
+
+PV = "0.3.0+svn${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk/toys;module=table;proto=http \
+           file://fixes.patch;patch=1"
+
+S = "${WORKDIR}/table"
+
+