]> code.ossystems Code Review - openembedded-core.git/commitdiff
shadow-native: use 'users' group by default
authorOtavio Salvador <otavio@ossystems.com.br>
Mon, 23 Jul 2012 17:37:16 +0000 (14:37 -0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 26 Jul 2012 13:39:47 +0000 (14:39 +0100)
The rootfs has 'users' group at number 100 and without this fix it
would assign to a non-existent group and if a group with gid as 1000
is created later it would own all files for users created.

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb

index 1e071f1bed5ff806878060c15a432f1a60b3f18c..cd5605f81ccb93aa8dde90aa06b0f587a4e2c9b9 100644 (file)
@@ -7,7 +7,7 @@ LICENSE = "BSD | Artistic-1.0"
 LIC_FILES_CHKSUM = "file://COPYING;md5=08c553a87d4e51bbed50b20e0adcaede \
                     file://src/passwd.c;firstline=8;endline=30;md5=2899a045e90511d0e043b85a7db7e2fe"
 
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "http://pkg-shadow.alioth.debian.org/releases/${BPN}-${PV}.tar.bz2 \
            file://shadow.automake-1.11.patch \
@@ -46,4 +46,7 @@ do_install_append() {
        # Now we don't have a mail system. Disable mail creation for now.
        sed -i 's:/bin/bash:/bin/sh:g' ${D}${sysconfdir}/default/useradd
        sed -i '/^CREATE_MAIL_SPOOL/ s:^:#:' ${D}${sysconfdir}/default/useradd
+
+       # Use users group by default
+       sed -i 's,^GROUP=1000,GROUP=100,g' ${D}${sysconfdir}/default/useradd
 }