]> code.ossystems Code Review - openembedded-core.git/commitdiff
tcltk: Fix for ${B} != ${S}
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 8 Mar 2013 11:37:23 +0000 (11:37 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 21:25:53 +0000 (21:25 +0000)
This change allows ${B} != ${S} builds to work since otherwise
gnu-configise is executed in the wrong places and various source
paths aren't correct.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/tcltk/tcl_8.5.13.bb

index 27a9ef66c12cc23cc9c07ea580af9e6dbb817dc2..01fe36dc97261ca19993980f27f18d597832de30 100644 (file)
@@ -34,12 +34,12 @@ DEPENDS_class-native = ""
 EXTRA_OECONF = "--enable-threads --disable-rpath"
 
 do_configure() {
-       gnu-configize
+       ( cd ${S}; gnu-configize )
        oe_runconf
 }
 
 do_compile_prepend() {
-       echo > ../compat/fixstrtod.c
+       echo > ${S}/../compat/fixstrtod.c
 }
 
 do_install() {
@@ -52,7 +52,7 @@ do_install() {
        install -d ${D}${bindir_crossscripts}
        install -m 0755 tclConfig.sh ${D}${bindir_crossscripts}
        cd ..
-       for dir in compat generic unix
+       for dir in ${S}/../compat ${S}/../generic ${S}/../unix
        do
                install -d ${D}${includedir}/tcl${PV}/$dir
                install -m 0644 $dir/*.h ${D}${includedir}/tcl${PV}/$dir/