]> code.ossystems Code Review - openembedded-core.git/commitdiff
tar_1.17: eliminate a patch by setting CFLAGS instead
authorScott Garman <sgarman@zenlinux.com>
Mon, 16 Aug 2010 21:45:29 +0000 (14:45 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 27 Aug 2010 12:04:38 +0000 (13:04 +0100)
Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/packages/tar/tar-1.17/gcc43build.patch [deleted file]
meta/packages/tar/tar_1.17.bb

diff --git a/meta/packages/tar/tar-1.17/gcc43build.patch b/meta/packages/tar/tar-1.17/gcc43build.patch
deleted file mode 100644 (file)
index cc5f0e1..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-# Fix errors when built with gcc 4.3
-# Patch taken from Debian bug #452096
-
-diff -urN tar-1.17.orig/lib/argp-fmtstream.h tar-1.17/lib/argp-fmtstream.h
---- tar-1.17.orig/lib/argp-fmtstream.h 2006-01-11 12:24:05.000000000 -0800
-+++ tar-1.17/lib/argp-fmtstream.h      2010-07-22 22:36:12.000000000 -0700
-@@ -198,7 +198,11 @@
- #endif
- #ifndef ARGP_FS_EI
--#define ARGP_FS_EI extern inline
-+ #if defined __GNUC_STDC_INLINE__
-+   #define ARGP_FS_EI extern inline __attribute__((__gnu_inline__))
-+ #else
-+   #define ARGP_FS_EI extern inline
-+ #endif
- #endif
- ARGP_FS_EI size_t
-diff -urN tar-1.17.orig/lib/argp.h tar-1.17/lib/argp.h
---- tar-1.17.orig/lib/argp.h   2007-03-30 00:09:11.000000000 -0700
-+++ tar-1.17/lib/argp.h        2010-07-22 22:38:44.000000000 -0700
-@@ -580,7 +580,11 @@
- # endif
- # ifndef ARGP_EI
--#  define ARGP_EI extern __inline__
-+#  if defined __GNUC_STDC_INLINE__
-+#    define ARGP_EI extern __inline__ __attribute__((__gnu_inline__))
-+#  else
-+#    define ARGP_EI extern __inline__
-+#  endif
- # endif
- ARGP_EI void
index be7454209155bba31dea31fb2729e5a401816976..729aecc9843bcc8ede5e997c58e874038beee3fd 100644 (file)
@@ -5,9 +5,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
 
 PR = "r0"
 
-SRC_URI += "file://m4extensions.patch \
-    file://gcc43build.patch \
-    "
+SRC_URI += "file://m4extensions.patch"
 
 SRC_URI[md5sum] = "c6c4f1c075dbf0f75c29737faa58f290"
 SRC_URI[sha256sum] = "19f9021dda51a16295e4706e80870e71f87107675e51c176a491eba0fc4ca492"
+
+# Required to build with gcc 4.3 and later:
+CFLAGS += "-fgnu89-inline"