]> code.ossystems Code Review - openembedded-core.git/commitdiff
libcap-ng: update to 0.7.9
authorYi Zhao <yi.zhao@windriver.com>
Wed, 21 Mar 2018 08:36:24 +0000 (16:36 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 1 May 2018 13:23:18 +0000 (14:23 +0100)
Rebase python.patch.

Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/libcap-ng/libcap-ng/python.patch
meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb [moved from meta/recipes-support/libcap-ng/libcap-ng_0.7.8.bb with 89% similarity]

index 59591eb469370c20291b73129a5b59e899169bfd..d60a0a39b66965c08553d7b57d0cedba398a5377 100644 (file)
@@ -1,4 +1,4 @@
-From b01bb2694f66cd981e6d61523433dc3eb5ed32f2 Mon Sep 17 00:00:00 2001
+From b4a354ae8d4f7c2ec3ec421c7d8a790cc57e77a9 Mon Sep 17 00:00:00 2001
 From: Li xin <lixin.fnst@cn.fujitsu.com>
 Date: Sat, 18 Jul 2015 23:03:30 +0900
 Subject: [PATCH] configure.ac - Avoid an incorrect check for python.
@@ -8,30 +8,32 @@ Upstream-Status: pending
 
 Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
 Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
 ---
- bindings/python/Makefile.am |  ++-
- configure.ac                | 15 ++-------------
- 2 files changed, 4 insertions(+), 14 deletions(-)
+ bindings/python/Makefile.am |  4 +++-
+ configure.ac                | 17 ++---------------
+ 2 files changed, 5 insertions(+), 16 deletions(-)
 
 diff --git a/bindings/python/Makefile.am b/bindings/python/Makefile.am
-index 82b9bb8..f9fe7a8 100644
+index 999b184..c8e49db 100644
 --- a/bindings/python/Makefile.am
 +++ b/bindings/python/Makefile.am
-@@ -23,7 +23,8 @@ SUBDIRS = test
+@@ -23,7 +23,9 @@
+ SUBDIRS = test
  CONFIG_CLEAN_FILES = *.loT *.rej *.orig
  AM_CFLAGS = -fPIC -DPIC
- PYLIBVER ?= python$(PYTHON_VERSION)
 -AM_CPPFLAGS = -I. -I$(top_builddir) -I@PYINCLUDEDIR@
++PYLIBVER ?= python$(PYTHON_VERSION)
 +PYINC ?= /usr/include/$(PYLIBVER)
 +AM_CPPFLAGS = -I. -I$(top_builddir) -I$(PYINC)
- LIBS = $(top_builddir)/src/libcap-ng.la
  SWIG_FLAGS = -python
  SWIG_INCLUDES = ${AM_CPPFLAGS}
+ pyexec_PYTHON = capng.py
 diff --git a/configure.ac b/configure.ac
-index 1d777d5..9d90f64 100644
+index 7f66179..079d026 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -123,19 +123,8 @@ if test x$use_python = xno ; then
+@@ -123,21 +123,8 @@ if test x$use_python = xno ; then
  else
  AC_MSG_RESULT(testing)
  AM_PATH_PYTHON
@@ -39,11 +41,13 @@ index 1d777d5..9d90f64 100644
 -if test -f ${PYINCLUDEDIR}/Python.h ; then
 -      python_found="yes"
 -      AC_SUBST(PYINCLUDEDIR)
+-      pybind_dir="python"
+-      AC_SUBST(pybind_dir)
 -      AC_MSG_NOTICE(Python bindings will be built)
 -else
 -      python_found="no"
 -      if test x$use_python = xyes ; then
--              AC_MSG_ERROR([Python explicitly required and python headers found])
+-              AC_MSG_ERROR([Python explicitly requested and python headers were not found])
 -      else
 -              AC_MSG_WARN("Python headers not found - python bindings will not be made")
 -      fi
@@ -54,5 +58,5 @@ index 1d777d5..9d90f64 100644
  AM_CONDITIONAL(HAVE_PYTHON, test ${python_found} = "yes")
  
 -- 
-1.8.4.2
+2.7.4
 
similarity index 89%
rename from meta/recipes-support/libcap-ng/libcap-ng_0.7.8.bb
rename to meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb
index 358319419d6db3e450fee6cd572a3ca1c742b7fa..aff6259db292bf5390fd89603a1ec541e695de75 100644 (file)
@@ -12,8 +12,8 @@ SRC_URI = "http://people.redhat.com/sgrubb/libcap-ng/libcap-ng-${PV}.tar.gz \
 
 inherit lib_package autotools python3native
 
-SRC_URI[md5sum] = "0dece96644bd798020e170fbf7663802"
-SRC_URI[sha256sum] = "c21af997445cd4107a55d386f955c5ea6f6e96ead693e9151277c0ab5f97d05f"
+SRC_URI[md5sum] = "2398d695508fab9ce33668c53a89b0e9"
+SRC_URI[sha256sum] = "4a1532bcf3731aade40936f6d6a586ed5a66ca4c7455e1338d1f6c3e09221328"
 
 DEPENDS += "swig-native python3"