]> code.ossystems Code Review - openembedded-core.git/commitdiff
default-versions.inc: drop python-related defaults
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Mon, 25 Apr 2016 12:59:23 +0000 (15:59 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 30 May 2016 21:47:14 +0000 (22:47 +0100)
There is only one version of python 2.x provided, so no need
to set a preferred version.
PYTHON_BASEVERSION is now set explicitly in python-dir.bbclass and
python3-dir.bbclass, so fix up a few recipes that relied on it being
set in default-versions.inc without inheriting python-dir.

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
meta/conf/distro/include/default-versions.inc
meta/recipes-devtools/rpm/rpm_5.4+cvs.bb
meta/recipes-devtools/rpm/rpm_5.4.16.bb
meta/recipes-kernel/lttng/lttng-tools_git.bb
meta/recipes-rt/rt-tests/hwlatdetect_0.96.bb

index a04ea718bd754bc4c184019e4bb817a7dd2791c7..cc8c533d4c019f3751c02a4c65759b167469042b 100644 (file)
@@ -2,11 +2,6 @@
 # Default preferred versions
 #
 
-# Force the python versions in one place
-PYTHON_BASEVERSION ?= "2.7"
-PREFERRED_VERSION_python ?= "2.7.11"
-PREFERRED_VERSION_python-native ?= "2.7.11"
-
 # Force the older version of liberation-fonts until we fix the fontforge issue
 PREFERRED_VERSION_liberation-fonts ?= "1.04"
 
index 0991f6d52abf3c307dea79c07697617f05042106..625d75e825cc283f80a70219b7fd2e511d62f19e 100644 (file)
@@ -156,7 +156,7 @@ SRC_URI_append_libc-musl = "\
 # to process certain package feeds.
 #SRC_URI += "file://rpm-debug-platform.patch"
 
-inherit autotools gettext
+inherit autotools gettext python-dir
 
 acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
 
index 7ebd5e9359bd82776b46931039affaad70290e10..3adb29c34751c223496a8e0866ab205858b7099e 100644 (file)
@@ -165,7 +165,7 @@ SRC_URI_append_libc-musl = "\
 
 UPSTREAM_CHECK_REGEX = "rpm-(?P<pver>(\d+[\.\-_]*)+)-.*$"
 
-inherit autotools gettext
+inherit autotools gettext python-dir
 
 acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
 
index 3ce4a9ee17f3447f7f4812f134cd884084b3fe76..8ef267c833114a612133646856fdff1355d611c2 100644 (file)
@@ -35,7 +35,7 @@ SRC_URI = "git://git.lttng.org/lttng-tools.git;branch=stable-2.7 \
 
 S = "${WORKDIR}/git"
 
-inherit autotools-brokensep ptest pkgconfig useradd
+inherit autotools-brokensep ptest pkgconfig useradd python-dir
 
 USERADD_PACKAGES = "${PN}"
 GROUPADD_PARAM_${PN} = "tracing"
index 962069e3dc71d044c143afe85eab8b883b8f77b5..025eb632325e1b3a90164264738817cc28a0a236 100644 (file)
@@ -6,6 +6,7 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 
 require rt-tests.inc
+inherit python-dir
 
 EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"