]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcc-runtime_4.5.1.bb: Fix ICE in gcc-runtime with -feliminate-dwarf2-dups
authorKhem Raj <raj.khem@gmail.com>
Fri, 18 Mar 2011 21:29:59 +0000 (14:29 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 23 Mar 2011 17:10:21 +0000 (17:10 +0000)
GCC 4.5 ends up in an ICE when compiling libstdc++ pre compiled header
so we eliminate -feliminate-dwarf2-dups for gcc-runtime

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb

index 9eb658b12c29697b8b17a6b199299106899299b0..9d4e158fb5fcc8adabbe337961814cea7ed557dd 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r4"
+PR = "r5"
 
 require gcc-${PV}.inc
 require gcc-configure-runtime.inc
@@ -9,3 +9,8 @@ SRC_URI_append = "file://fortran-cross-compile-hack.patch"
 ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
 
 EXTRA_OECONF += "--disable-libunwind-exceptions"
+
+# gcc 4.5 ends up in ICE when using -feliminate-dwarf2-dups in libstdc++
+# compiling pre compiled headers so we remove this option when compiling
+# to workaround it
+CXXFLAGS := "${@oe_filter_out('-feliminate-dwarf2-dups', '${CXXFLAGS}', d)}"