]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-libc-headers-yocto: disable device tree generation
authorBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 14 Feb 2011 19:07:38 +0000 (14:07 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 15 Feb 2011 19:23:59 +0000 (19:23 +0000)
Fixes [BUGID #719]

The common routines for handling a git based yocto kernel
are included from the lib headers recipe to checkout the
appropriate branch of the kernel for header generation.

linux-yocto.inc includes device tree installation rules
which typically apply to a kernel user of the include file,
but do not apply to a simple header generation. The fix is
to override the DTB variables in this recipe, which disable
the device tree installation rules.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb

index 0d5835401e58c8f800424239876f31da2d0a5215..736d60f7de1d880a80da7c9264c66b3bd22c28d9 100644 (file)
@@ -12,6 +12,10 @@ PR = "r2"
 SRCREV_FORMAT = "meta_machine"
 SRC_URI = "git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
 
+# force this to empty to prevent installation failures, we aren't
+# building a device tree as part of kern headers
+KERNEL_DEVICETREE=
+
 set_arch() {
        case ${TARGET_ARCH} in
                arm*)     ARCH=arm ;;