]> code.ossystems Code Review - openembedded-core.git/commitdiff
populate-volatile.sh: cleanup duplicated invocations and remove boot warning
authorKevin Tian <kevin.tian@intel.com>
Wed, 11 Aug 2010 05:34:54 +0000 (13:34 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 12 Aug 2010 14:39:24 +0000 (15:39 +0100)
For one, populate-volatile.sh is itself a rcS script which is invoked earlier
than package's own postinst method (last one in rcS). If package has already
installed their volatile files correctly, it doesn't make sense to update volatile
again in postinst since nothing is changed.

On the other hand, dbus/hal are special since their user/group are only created
in the target. If they pre-install volatiles like others, populate-volatile.sh
will report "undefined user" since at that time their user/group haven't been
created. The better way solving this is to generate their volatile in the fly
after user/group are created, and then update volatiles.

This fix [BUGID #121]

Signed-off-by: Kevin Tian <kevin.tian@intel.com>
14 files changed:
meta/packages/dbus/dbus-1.2.24/99_dbus [deleted file]
meta/packages/dbus/dbus.inc
meta/packages/dbus/dbus_1.2.24.bb
meta/packages/devicekit/devicekit_git.bb
meta/packages/fontconfig/fontconfig_2.8.0.bb
meta/packages/hal/files/99_hal [deleted file]
meta/packages/hal/hal.inc
meta/packages/hal/hal_0.5.14.bb
meta/packages/hal/hal_git.bb
meta/packages/networkmanager/networkmanager_svn.bb
meta/packages/pam/pam_1.1.1.bb
meta/packages/wpa-supplicant/wpa-supplicant-0.7.inc
meta/packages/wpa-supplicant/wpa-supplicant_0.7.2.bb
meta/packages/yum/yum_3.2.27.bb

diff --git a/meta/packages/dbus/dbus-1.2.24/99_dbus b/meta/packages/dbus/dbus-1.2.24/99_dbus
deleted file mode 100644 (file)
index 6821ae4..0000000
+++ /dev/null
@@ -1 +0,0 @@
-d messagebus messagebus 0755 /var/run/dbus none
index a085287fc43d9ebcf95694ae22f44549f734e252..90a38e66a98589bf39e9a72da7c8a1752db69869 100644 (file)
@@ -9,8 +9,7 @@ DEPENDS = "expat glib-2.0 virtual/libintl virtual/libx11 libsm"
 SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
            file://tmpdir.patch; \
            file://fix-install-daemon.patch; \
-           file://dbus-1.init \
-           file://99_dbus"
+           file://dbus-1.init"
 
 inherit autotools pkgconfig gettext update-rc.d
 
@@ -54,6 +53,10 @@ pkg_postinst_dbus() {
 
        grep -q netdev: /etc/group || addgroup netdev
        chmod u+s /usr/libexec/dbus-daemon-launch-helper
+
+       # add volatile after new user/grp are created
+       echo "d messagebus messagebus 0755 /var/run/dbus none" > /etc/default/volatiles/99_dbus
+       /etc/init.d/populate-volatile.sh update
 }
 
 EXTRA_OECONF_X = "--with-x"
@@ -70,9 +73,6 @@ EXTRA_OECONF = "--disable-tests \
 do_install() {
        autotools_do_install
 
-       install -d ${D}/etc/default/volatiles
-       install -m 0644 ${WORKDIR}/99_dbus ${D}/etc/default/volatiles/
-
        install -d ${D}${sysconfdir}/init.d
        install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
 }
index f331b140aaab49d9f6c2f8d20953bb6e45045c0d..8e3e329fdefdb46bc3b611cd41be95d9a3757e5d 100644 (file)
@@ -1,3 +1,3 @@
 include dbus.inc
 
-PR = "r0"
+PR = "r1"
index 06bcfd3f123cd3c7e121b2eb449a56d34009a2a8..74b639f6c118104393305bb2cad3855c8379b328 100644 (file)
@@ -5,7 +5,7 @@ SRC_URI = "git://anongit.freedesktop.org/DeviceKit/DeviceKit;protocol=git \
         file://volatile"
 
 PV = "002+git${SRCREV}"
-PR = "r1"
+PR = "r2"
 SRCREV = "014d168ba4bf40c9bae487bacff8bf2aa054b5f6"
 
 S = "${WORKDIR}/git"
@@ -25,8 +25,6 @@ pkg_postinst_devicekit () {
                exit 1
        fi
 
-       /etc/init.d/populate-volatile.sh update
-
        DBUSPID=`pidof dbus-daemon`
 
        if [ "x$DBUSPID" != "x" ]; then
index f83d72cddaf56c1412924e9c3a1d16ca030a4976..e0403ecb3c5fd8c5628ab8baba4b3a0b8222b6e7 100644 (file)
@@ -11,7 +11,7 @@ SECTION = "libs"
 
 DEPENDS = "expat freetype zlib"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
            file://fix-pkgconfig.patch \
@@ -73,17 +73,9 @@ do_configure_append () {
 
 }
 
-do_install () {
-       autotools_do_install
-}
-
 do_install_append() {
        install -d ${D}${sysconfdir}/default/volatiles
        install -m 0644 ${WORKDIR}/97_fontconfig ${D}${sysconfdir}/default/volatiles
        rmdir ${D}${localstatedir}/cache/fontconfig
        rmdir ${D}${localstatedir}/cache/
 }
-
-pkg_postinst_hal () {
-       /etc/init.d/populate-volatile.sh update
-}
diff --git a/meta/packages/hal/files/99_hal b/meta/packages/hal/files/99_hal
deleted file mode 100644 (file)
index c82da99..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-d root root 0700 /var/run/hald none
-d haldaemon haldaemon 0755 /var/cache/hald none
index 29ceadcfa6ed84851fa3888ecdcad1f31b25d636..839dfd0652d5a292759927a3586dac36c4602470 100644 (file)
@@ -10,7 +10,6 @@ DEPENDS = "virtual/kernel dbus-glib udev util-linux intltool intltool-native exp
 RDEPENDS += "udev hal-info"
 
 SRC_URI = "http://hal.freedesktop.org/releases/hal-${PV}.tar.gz \
-           file://99_hal \
            file://20hal"
 
 inherit autotools pkgconfig
@@ -37,8 +36,6 @@ PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'pci', '${MACHINE_ARCH}', '
 PACKAGE_ARCH_emenlow := "${PACKAGE_ARCH}"
 
 do_install_append() {
-       install -d ${D}/etc/default/volatiles
-       install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
         install -d ${D}/etc/dbus-1/event.d
         install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
 }
@@ -53,6 +50,9 @@ pkg_postinst_hal () {
        grep haldaemon /etc/group || addgroup haldaemon
        grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
 
+       # add volatile after new user/grp are created
+       echo "d root root 0700 /var/run/hald none" > /etc/default/volatiles/99_hal
+       echo "d haldaemon haldaemon 0755 /var/cache/hald none" >> /etc/default/volatiles/99_hal
        /etc/init.d/populate-volatile.sh update
 
        DBUSPID=`pidof dbus-daemon`
index 470934a43e319751f2deb14e2a1cca3a428cd9b8..a12be729cb403cff708b2df167959e50e78efd87 100644 (file)
@@ -1,6 +1,6 @@
 require hal.inc
 
-PR = "r1"
+PR = "r2"
 
 EXTRA_OECONF += "--with-linux-input-header=${STAGING_INCDIR}/linux/input.h"
 EXTRA_OEMAKE += "-e 'udevrulesdir=$(sysconfdir)/udev/rules.d'"
index d9205ec945cf9b111ae02cf7dbda743af7c6887d..baed472375356076c9b2aba17c7a5a21dfeed9ba 100644 (file)
@@ -1,7 +1,7 @@
 require hal.inc
 
 PV = "0.5.9.1+git${SRCDATE}"
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
         file://20hal \
index f60496db7017d79648b74b78e12f8ec629185ee6..40f04e497c87ada5d487cb4e815ea9a5a20ea442 100644 (file)
@@ -8,7 +8,7 @@ DEPENDS = "libnl dbus dbus-glib hal gconf-dbus wireless-tools ppp gnome-common p
 RDEPENDS = "hal wpa-supplicant iproute2 dhcp-client"
 
 PV = "0.7+svnr${SRCREV}"
-PR = "r9"
+PR = "r10"
 
 SRC_URI="svn://svn.gnome.org/svn/NetworkManager/;module=trunk;proto=http \
          file://no-restarts.diff;patch=1;pnum=0 \
@@ -38,13 +38,6 @@ do_install_append () {
        rmdir ${D}/var/run
 }
 
-pkg_postinst_${PN} () {
-        if [ "x$D" != "x" ]; then
-                exit 1
-        fi
-        /etc/init.d/populate-volatile.sh update
-}
-
 PACKAGES =+ "libnmutil libnmglib"
 
 FILES_libnmutil += "${libdir}/libnm-util.so.*"
index 7ef4d2d2510db1de72a4b07e616c4b8864e00a43..ad53a32f768542da94aafbd3166eca5e4b4975a2 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.kernel.org/pub/linux/libs/pam/"
 BUGTRACKER = "http://sourceforge.net/projects/pam/support"
 # PAM allows dual licensed under GPL and BSD
 LICENSE = "GPLv2+ | BSD"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-${PV}.tar.bz2 \
            file://disable_crossbinary.patch \
@@ -37,7 +37,3 @@ do_install() {
        install -d ${D}/etc/default/volatiles
        install -m 0644 ${WORKDIR}/99_pam ${D}/etc/default/volatiles
 }
-
-pkg_postinst_${PN} () {
-        /etc/init.d/populate-volatile.sh update
-}
index b1641061ff4fc2b59bf8b9ae9a6d3c455804f61c..78ce914c31f455e82400c64021e362904ec69c35 100644 (file)
@@ -67,8 +67,6 @@ pkg_postinst_wpa-supplicant () {
                exit 1
        fi
 
-       /etc/init.d/populate-volatile.sh update
-
        DBUSPID=`pidof dbus-daemon`
 
        if [ "x$DBUSPID" != "x" ]; then
index c6ebbaff4b9ef9088ee81dfd2f95b32cdefd38f6..d1f6c6d6c9eca1bd7af77ac87fd0b34dfdc7646c 100644 (file)
@@ -1,3 +1,3 @@
 require wpa-supplicant-0.7.inc
 
-PR = "r0"
+PR = "r1"
index aff44ca6feb9a14f836979dd8fd3b01274d9f236..acebc79ddedd90777ad633bdb92f119c131d44b0 100644 (file)
@@ -13,7 +13,7 @@ RDEPENDS = "python-rpm python-core python-iniparse python-urlgrabber \
            python-textutils python-fcntl python-email \
            yum-metadata-parser"
 
-PR = "r8"
+PR = "r9"
 
 SRC_URI = "http://yum.baseurl.org/download/3.2/yum-${PV}.tar.gz \
            file://paths.patch;apply=yes \
@@ -41,10 +41,6 @@ do_install_append () {
        install -m 0644 ${WORKDIR}/98_yum ${D}/etc/default/volatiles
 }
 
-pkg_postinst_yum () {
-       /etc/init.d/populate-volatile.sh update
-}
-
 FILES_${PN} += "${libdir}/python* ${datadir}/yum-cli"
 
 BBCLASSEXTEND = "native"