]> code.ossystems Code Review - openembedded-core.git/commitdiff
zlib 1.2.5: install pkgconfig file, needed for e.g. modern webkit
authorKoen Kooi <koen@dominion.thruhere.net>
Thu, 1 Dec 2011 16:04:49 +0000 (17:04 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 1 Dec 2011 16:53:56 +0000 (16:53 +0000)
Upstream has grown cmake support which would allow us to dump the OE autotools hack, but the cmakefile doesn't install the .pc file either and breaks with zlib-native

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/zlib/zlib_1.2.5.bb

index bca400ce4bf2f9cbab597cf5d5efd1f97d11c74b..b5756d9424b474229ccf3f02ba452bf587c96551 100644 (file)
@@ -7,12 +7,12 @@ LICENSE = "Zlib"
 LIC_FILES_CHKSUM = "file://zlib.h;beginline=4;endline=23;md5=084e9c30e4e6272c3b057b13c6467f3d"
 
 DEPENDS = "libtool-cross"
-PR = "r1"
+PR = "r3"
 
 SRC_URI = "http://www.zlib.net/${BPN}-${PV}.tar.bz2 \
            file://configure.ac \
            file://Makefile.am \
-          file://fix.inverted.LFS.logic.patch"
+           file://fix.inverted.LFS.logic.patch"
 
 SRC_URI[md5sum] = "be1e89810e66150f5b0327984d8625a0"
 SRC_URI[sha256sum] = "239aead2f22f16bfcfa6a6a5150dcbd6d6f2e4d1eaa8727b5769ea014120b307"
@@ -24,4 +24,18 @@ do_configure_prepend () {
        cp ${WORKDIR}/Makefile.am ${S}/
 }
 
+do_install_append () {
+       sed \
+               -e 's:@prefix@:${prefix}:' \
+               -e 's:@exec_prefix@:${exec_prefix}:' \
+               -e 's:@libdir@:${libdir}:' \
+               -e 's:@sharedlibdir@:${libdir}:' \
+               -e 's:@includedir@:${includedir}:' \
+               -e 's:@VERSION@:${PV}:' \
+               zlib.pc.in > zlib.pc
+
+       install -d ${D}${libdir}/pkgconfig
+       install -m 0644 zlib.pc ${D}${libdir}/pkgconfig/
+}
+
 BBCLASSEXTEND = "native nativesdk"