]> code.ossystems Code Review - openembedded-core.git/commitdiff
midori: fix build with GLib 2.44
authorRoss Burton <ross.burton@intel.com>
Tue, 19 May 2015 19:40:57 +0000 (20:40 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 May 2015 20:40:14 +0000 (21:40 +0100)
GLib 2.44 introduced a GListStore type which is ambiguous with GtkListStore when
using wildcard using statements.  Use the full type name to fix builds.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-sato/midori/midori/liststore.patch [new file with mode: 0644]
meta/recipes-sato/midori/midori_0.5.8.bb

diff --git a/meta/recipes-sato/midori/midori/liststore.patch b/meta/recipes-sato/midori/midori/liststore.patch
new file mode 100644 (file)
index 0000000..4e5d666
--- /dev/null
@@ -0,0 +1,29 @@
+GLib 2.44 has a GListStore type which is GLib.ListStore in Vala, resulting in an ambigous type and compile failure.
+
+Fix by using the full type name.
+
+Upstream-Status: Backport
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/extensions/history-list.vala b/extensions/history-list.vala
+index 3a864b1..f309c0c 100644
+--- a/extensions/history-list.vala
++++ b/extensions/history-list.vala
+@@ -319,7 +319,7 @@ namespace HistoryList {
+         }
+         private void create_widgets () {
+-            ListStore model;
++            Gtk.ListStore model;
+             TreeIter iter;
+             TreeIter? active_iter = null;
+@@ -331,7 +331,7 @@ namespace HistoryList {
+             var tab_closing_behavior = this.hl_manager.get_integer ("TabClosingBehavior");
+-            model = new ListStore (2, typeof (string), typeof (int));
++            model = new Gtk.ListStore (2, typeof (string), typeof (int));
+             model.append (out iter);
+             model.set (iter, TabClosingBehaviorModel.TEXT, _("Do nothing"),
index 5cc42cbc5082e05a463600635c5a327c2e526e3c..aa1b395b84b84870e2e0a70942bf334015cf21fe 100644 (file)
@@ -4,7 +4,9 @@ LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
 DEPENDS = "webkit-gtk libsoup-2.4 openssl python-native python-docutils-native librsvg-native libnotify libxscrnsaver"
 
-SRC_URI = "https://launchpad.net/midori/trunk/0.5.8/+download/${BPN}-${PV}.tar.bz2;subdir=${BPN}-${PV}"
+SRC_URI = "https://launchpad.net/midori/trunk/0.5.8/+download/${BPN}-${PV}.tar.bz2;subdir=${BPN}-${PV} \
+           file://liststore.patch"
+
 SRC_URI[md5sum] = "b89e25e74199d705e74767499a415976"
 SRC_URI[sha256sum] = "af19135fd4c4b04345df4d3592e7939c20f9b40eaca24550e6cb619751aa9381"