]> code.ossystems Code Review - openembedded-core.git/commitdiff
gdbm: fix ptest failure
authorChen Qi <Qi.Chen@windriver.com>
Tue, 30 Oct 2018 08:06:42 +0000 (16:06 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 Nov 2018 12:14:05 +0000 (12:14 +0000)
Some of gdbm's ptest cases require gdbmtool, which is packaged into
${PN}-bin. So extend the RDEPENDS_${PN}-ptest to include the package.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/gdbm/gdbm_1.18.bb

index 2d2016ddfa3bb5db9561b2c58cdba7aeeca0fa72..aad4300952cea0d12ad3aaaa7e9923d256d216b7 100644 (file)
@@ -31,7 +31,7 @@ do_install_append () {
     ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
 }
 
-RDEPENDS_${PN}-ptest += "diffutils"
+RDEPENDS_${PN}-ptest += "diffutils ${PN}-bin"
 
 do_compile_ptest() {
     oe_runmake -C tests buildtests