]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnupg_1.4.7: add package config libusb
authorKai Kang <kai.kang@windriver.com>
Thu, 16 Oct 2014 09:42:57 +0000 (17:42 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 18 Oct 2014 14:12:56 +0000 (16:12 +0200)
If build gnupg 1.4.7 after libusb-compat, it shows warning:

WARNING: QA Issue: gnupg rdepends on libusb-compat, but it isn't a build dependency? [build-deps]

Add package config libusb to fix it.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
meta/recipes-support/gnupg/gnupg_1.4.7.bb

index 7be56fd7b59a68357798448c00e38590abf35391..aef515d534f4eee99d05d987a1505d6b02fa615c 100644 (file)
@@ -99,3 +99,4 @@ FILES_${PN}-dbg += "${libexecdir}/${BPN}/.debug"
 
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[curl] = "--with-libcurl=${STAGING_LIBDIR},--without-libcurl,curl"
+PACKAGECONFIG[libusb] = "--with-libusb=${STAGING_LIBDIR},--without-libusb,libusb-compat"