]> code.ossystems Code Review - openembedded-core.git/commitdiff
boost: backport a regression fix for forgotten header
authorDmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
Mon, 15 May 2017 11:54:32 +0000 (14:54 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 30 May 2017 09:14:31 +0000 (10:14 +0100)
The v1.64 release has broken array serialization code with issues
reported in

https://svn.boost.org/trac/boost/ticket/12516
https://github.com/bmwcarit/meta-ros/issues/505

Backport the fix from boost::serialization's master.

Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/boost/boost/0001-correct-error-which-appeared-when-compiling-non-c-co.patch [new file with mode: 0644]
meta/recipes-support/boost/boost_1.64.0.bb

diff --git a/meta/recipes-support/boost/boost/0001-correct-error-which-appeared-when-compiling-non-c-co.patch b/meta/recipes-support/boost/boost/0001-correct-error-which-appeared-when-compiling-non-c-co.patch
new file mode 100644 (file)
index 0000000..2598d2b
--- /dev/null
@@ -0,0 +1,28 @@
+From 02fa5cee1b8d0321787113e2dc10b162c657f333 Mon Sep 17 00:00:00 2001
+From: Robert Ramey <ramey@rrsd.com>
+Date: Wed, 1 Feb 2017 16:43:59 -0800
+Subject: [PATCH] correct error which appeared when compiling non c++ compliant
+ code for arrays
+
+Upstream-Status: Backported [expected to be released in v1.65]
+
+---
+ boost/serialization/array.hpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/boost/serialization/array.hpp b/boost/serialization/array.hpp
+index 61708b3..612d1a6 100644
+--- a/boost/serialization/array.hpp
++++ b/boost/serialization/array.hpp
+@@ -23,6 +23,8 @@ namespace std{
+ } // namespace std
+ #endif
++#include <boost/serialization/array_wrapper.hpp>
++
+ #ifndef BOOST_NO_CXX11_HDR_ARRAY
+ #include <array>
+-- 
+2.9.3
+
index 119eb0af452cd6f7089b12290812f28559bec9ca..d1c20e1d066b0ab3809a565c2a3f81f122e94a8b 100644 (file)
@@ -9,4 +9,5 @@ SRC_URI += "\
     file://0001-Apply-boost-1.62.0-no-forced-flags.patch.patch \
     file://0003-Don-t-set-up-arch-instruction-set-flags-we-do-that-o.patch \
     file://0002-Don-t-set-up-m32-m64-we-do-that-ourselves.patch \
+    file://0001-correct-error-which-appeared-when-compiling-non-c-co.patch \
 "