create mode 100644 widget/src/headless/nsImageToPixbuf.cpp
create mode 100644 widget/src/headless/nsImageToPixbuf.h
-diff --git a/widget/src/headless/Makefile.in b/widget/src/headless/Makefile.in
-index c8727d9..cbdf900 100644
---- a/widget/src/headless/Makefile.in
-+++ b/widget/src/headless/Makefile.in
-@@ -95,6 +95,12 @@ CPPSRCS = \
+Index: offscreen/widget/src/headless/Makefile.in
+===================================================================
+--- offscreen.orig/widget/src/headless/Makefile.in 2009-05-16 18:23:25.000000000 +0100
++++ offscreen/widget/src/headless/Makefile.in 2009-06-12 14:14:05.000000000 +0100
+@@ -95,6 +95,12 @@
nsScreenManagerHeadless.cpp \
$(NULL)
# build our subdirs, too
SHARED_LIBRARY_LIBS = ../xpwidgets/libxpwidgets_s.a
-diff --git a/widget/src/headless/nsClipboard.cpp b/widget/src/headless/nsClipboard.cpp
-new file mode 100644
-index 0000000..72a37fc
---- /dev/null
-+++ b/widget/src/headless/nsClipboard.cpp
+Index: offscreen/widget/src/headless/nsClipboard.cpp
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ offscreen/widget/src/headless/nsClipboard.cpp 2009-06-12 14:14:05.000000000 +0100
@@ -0,0 +1,948 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/* vim:expandtab:shiftwidth=4:tabstop=4:
+ wait_for_retrieval(clipboard, &context);
+ return static_cast<gchar *>(context.data);
+}
-diff --git a/widget/src/headless/nsClipboard.h b/widget/src/headless/nsClipboard.h
-new file mode 100644
-index 0000000..dc690c0
---- /dev/null
-+++ b/widget/src/headless/nsClipboard.h
+Index: offscreen/widget/src/headless/nsClipboard.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ offscreen/widget/src/headless/nsClipboard.h 2009-06-12 14:14:05.000000000 +0100
@@ -0,0 +1,93 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/* vim:expandtab:shiftwidth=4:tabstop=4:
+};
+
+#endif /* __nsClipboard_h_ */
-diff --git a/widget/src/headless/nsIImageToPixbuf.h b/widget/src/headless/nsIImageToPixbuf.h
-new file mode 100644
-index 0000000..1c46015
---- /dev/null
-+++ b/widget/src/headless/nsIImageToPixbuf.h
+Index: offscreen/widget/src/headless/nsIImageToPixbuf.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ offscreen/widget/src/headless/nsIImageToPixbuf.h 2009-06-12 14:14:05.000000000 +0100
@@ -0,0 +1,62 @@
+/* ***** BEGIN LICENSE BLOCK *****
+ * Version: MPL 1.1/GPL 2.0/LGPL 2.1
+NS_DEFINE_STATIC_IID_ACCESSOR(nsIImageToPixbuf, NSIIMAGETOPIXBUF_IID)
+
+#endif
-diff --git a/widget/src/headless/nsImageToPixbuf.cpp b/widget/src/headless/nsImageToPixbuf.cpp
-new file mode 100644
-index 0000000..496815c
---- /dev/null
-+++ b/widget/src/headless/nsImageToPixbuf.cpp
+Index: offscreen/widget/src/headless/nsImageToPixbuf.cpp
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ offscreen/widget/src/headless/nsImageToPixbuf.cpp 2009-06-12 14:14:05.000000000 +0100
@@ -0,0 +1,196 @@
+/* vim:set sw=4 sts=4 et cin: */
+/* ***** BEGIN LICENSE BLOCK *****
+
+ return ImgSurfaceToPixbuf(imgSurface, aWidth, aHeight);
+}
-diff --git a/widget/src/headless/nsImageToPixbuf.h b/widget/src/headless/nsImageToPixbuf.h
-new file mode 100644
-index 0000000..0e3f516
---- /dev/null
-+++ b/widget/src/headless/nsImageToPixbuf.h
+Index: offscreen/widget/src/headless/nsImageToPixbuf.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ offscreen/widget/src/headless/nsImageToPixbuf.h 2009-06-12 14:14:05.000000000 +0100
@@ -0,0 +1,71 @@
+/* vim:set sw=4 sts=4 et cin: */
+/* ***** BEGIN LICENSE BLOCK *****
+ { 0x9e, 0x42, 0xb0, 0x5e, 0x5f, 0x06, 0x85, 0xb7 } }
+
+#endif
-diff --git a/widget/src/headless/nsWidgetFactory.cpp b/widget/src/headless/nsWidgetFactory.cpp
-index eb94333..a215988 100644
---- a/widget/src/headless/nsWidgetFactory.cpp
-+++ b/widget/src/headless/nsWidgetFactory.cpp
+Index: offscreen/widget/src/headless/nsWidgetFactory.cpp
+===================================================================
+--- offscreen.orig/widget/src/headless/nsWidgetFactory.cpp 2009-06-12 14:08:56.000000000 +0100
++++ offscreen/widget/src/headless/nsWidgetFactory.cpp 2009-06-12 14:15:24.000000000 +0100
@@ -46,6 +46,10 @@
#include "nsWindow.h"
#include "nsTransferable.h"
+#include "nsClipboardHelper.h"
+#include "nsClipboard.h"
+#endif
- //#include "nsFilePicker.h"
#include "nsSound.h"
#include "nsBidiKeyboard.h"
-@@ -74,6 +78,10 @@ NS_GENERIC_FACTORY_CONSTRUCTOR(nsLookAndFeel)
+ #include "nsScreenManagerHeadless.h"
+@@ -66,6 +70,10 @@
NS_GENERIC_FACTORY_CONSTRUCTOR(nsTransferable)
NS_GENERIC_FACTORY_CONSTRUCTOR(nsBidiKeyboard)
NS_GENERIC_FACTORY_CONSTRUCTOR(nsHTMLFormatConverter)
NS_GENERIC_FACTORY_CONSTRUCTOR(nsSound)
NS_GENERIC_FACTORY_CONSTRUCTOR(nsScreenManagerHeadless)
//NS_GENERIC_FACTORY_CONSTRUCTOR(nsImageToPixbuf)
-@@ -189,6 +197,16 @@ static const nsModuleComponentInfo components[] =
+@@ -142,6 +150,16 @@
NS_TRANSFERABLE_CID,
"@mozilla.org/widget/transferable;1",
nsTransferableConstructor },
{ "HTML Format Converter",
NS_HTMLFORMATCONVERTER_CID,
"@mozilla.org/widget/htmlformatconverter;1",
---
-1.6.0.4
-
Index: offscreen/configure.in
===================================================================
---- offscreen.orig/configure.in 2009-04-16 22:51:48.000000000 +0100
-+++ offscreen/configure.in 2009-04-16 23:07:48.000000000 +0100
+--- offscreen.orig/configure.in 2009-06-12 14:08:51.000000000 +0100
++++ offscreen/configure.in 2009-06-12 14:11:18.000000000 +0100
@@ -62,7 +62,6 @@
AC_PREREQ(2.13)
dnl Set the version number of the libs included with mozilla
dnl ========================================================
-@@ -136,6 +134,9 @@
+@@ -135,6 +133,9 @@
MSMANIFEST_TOOL=
dnl Set various checks
dnl ========================================================
MISSING_X=
-@@ -281,7 +282,7 @@
+@@ -285,7 +286,7 @@
;;
esac
echo "cross compiling from $host to $target"
cross_compiling=yes
-@@ -319,7 +320,7 @@
+@@ -323,7 +324,7 @@
AC_MSG_CHECKING([whether the host c compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
AC_TRY_COMPILE([], [return(0);],
AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CC cannot create executables.]) )
CC="$HOST_CXX"
-@@ -327,7 +328,7 @@
+@@ -331,7 +332,7 @@
AC_MSG_CHECKING([whether the host c++ compiler ($HOST_CXX $HOST_CXXFLAGS $HOST_LDFLAGS) works])
AC_TRY_COMPILE([], [return(0);],
AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CXX cannot create executables.]) )
CC=$_SAVE_CC
-@@ -348,7 +349,7 @@
+@@ -352,7 +353,7 @@
;;
esac
unset ac_cv_prog_CC
AC_PROG_CC
AC_CHECK_PROGS(CXX, $CXX "${target_alias}-g++" "${target}-g++", :)
-@@ -372,37 +373,6 @@
+@@ -376,37 +377,6 @@
AC_CHECK_PROGS(STRIP, $STRIP "${target_alias}-strip" "${target}-strip", :)
AC_CHECK_PROGS(WINDRES, $WINDRES "${target_alias}-windres" "${target}-windres", :)
AC_DEFINE(CROSS_COMPILE)
GNU_AS=
GNU_LD=
-@@ -1569,6 +1539,7 @@
+@@ -1606,6 +1576,7 @@
'
dnl test that the macros actually work:
AC_MSG_CHECKING(that static assertion macros used in autoconf tests work)
AC_CACHE_VAL(ac_cv_static_assertion_macros_work,
[AC_LANG_SAVE
-@@ -2730,9 +2701,13 @@
+@@ -2767,9 +2738,13 @@
AC_LANG_C
AC_HEADER_STDC
AC_C_CONST
AC_TYPE_SIZE_T
AC_STRUCT_ST_BLKSIZE
AC_MSG_CHECKING(for siginfo_t)
-@@ -3115,19 +3090,9 @@
+@@ -3152,19 +3127,9 @@
dnl We don't want to link against libm or libpthread on Darwin since
dnl they both are just symlinks to libSystem and explicitly linking
dnl against libSystem causes issues when debugging (see bug 299601).
_SAVE_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -D_GNU_SOURCE"
-@@ -6931,18 +6896,13 @@
+@@ -7007,18 +6972,13 @@
# Demangle only for debug or trace-malloc builds
MOZ_DEMANGLE_SYMBOLS=
dnl ========================================================
dnl =
-@@ -7454,10 +7414,7 @@
+@@ -7530,10 +7490,7 @@
dnl if no gtk/libIDL1 or gtk2/libIDL2 combination was found, fall back
dnl to either libIDL1 or libIDL2.
if test -z "$_LIBIDL_FOUND"; then
fi
dnl
dnl If we don't have a libIDL config program & not cross-compiling,
-@@ -7529,13 +7486,7 @@
+@@ -7605,13 +7562,7 @@
fi
if test -z "$SKIP_PATH_CHECKS"; then
fi
if test -z "${GLIB_GMODULE_LIBS}" -a -n "${GLIB_CONFIG}"; then
-@@ -8346,10 +8297,7 @@
+@@ -8457,10 +8408,7 @@
HAVE_WCRTOMB
"
)
# Save the defines header file before autoconf removes it.
-@@ -8408,31 +8356,11 @@
+@@ -8519,31 +8467,11 @@
dnl To add new Makefiles, edit allmakefiles.sh.
dnl allmakefiles.sh sets the variable, MAKEFILES.
. ${srcdir}/allmakefiles.sh
dnl Prevent the regeneration of cairo-features.h forcing rebuilds of gfx stuff
if test "$CAIRO_FEATURES_H"; then
if cmp -s $CAIRO_FEATURES_H "$CAIRO_FEATURES_H".orig; then
-@@ -8458,14 +8386,14 @@
+@@ -8569,14 +8497,14 @@
HOST_LDFLAGS="$_SUBDIR_HOST_LDFLAGS"
RC=
if test -z "$MOZ_DEBUG"; then
ac_configure_args="$ac_configure_args --disable-debug"
fi
-@@ -8481,8 +8409,7 @@
+@@ -8592,8 +8520,7 @@
if test -n "$USE_ARM_KUSER"; then
ac_configure_args="$ac_configure_args --with-arm-kuser"
fi
fi
if test -z "$MOZ_NATIVE_NSPR"; then
-@@ -8499,7 +8426,6 @@
+@@ -8610,7 +8537,6 @@
# Run the SpiderMonkey 'configure' script.
dist=$MOZ_BUILD_ROOT/dist
ac_configure_args="$ac_configure_args --enable-threadsafe"
if test -z "$MOZ_NATIVE_NSPR"; then
ac_configure_args="$ac_configure_args --with-nspr-cflags='$NSPR_CFLAGS'"
-@@ -8513,11 +8439,14 @@
- if test "$MOZ_MEMORY"; then
- ac_configure_args="$ac_configure_args --enable-jemalloc"
+@@ -8627,11 +8553,14 @@
+ export MOZ_MEMORY_LDFLAGS
+ fi
fi
-AC_OUTPUT_SUBDIRS(js/src)
-ac_configure_args="$_SUBDIR_CONFIG_ARGS"
if cmp -s config/autoconf.mk config/autoconf.mk.orig; then
Index: offscreen/js/src/configure.in
===================================================================
---- offscreen.orig/js/src/configure.in 2009-04-16 22:51:49.000000000 +0100
-+++ offscreen/js/src/configure.in 2009-04-16 23:06:42.000000000 +0100
+--- offscreen.orig/js/src/configure.in 2009-06-12 14:08:52.000000000 +0100
++++ offscreen/js/src/configure.in 2009-06-12 14:11:18.000000000 +0100
@@ -62,7 +62,6 @@
AC_PREREQ(2.13)
dnl Set the version number of the libs included with mozilla
dnl ========================================================
NSPR_VERSION=4
-@@ -114,6 +116,8 @@
+@@ -113,6 +115,8 @@
MSMANIFEST_TOOL=
dnl Set various checks
dnl ========================================================
MISSING_X=
-@@ -200,7 +204,7 @@
+@@ -198,7 +202,7 @@
if test "$COMPILE_ENVIRONMENT"; then
echo "cross compiling from $host to $target"
_SAVE_CC="$CC"
-@@ -237,7 +241,7 @@
+@@ -235,7 +239,7 @@
AC_MSG_CHECKING([whether the host c compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
AC_TRY_COMPILE([], [return(0);],
AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CC cannot create executables.]) )
CC="$HOST_CXX"
-@@ -245,7 +249,7 @@
+@@ -243,7 +247,7 @@
AC_MSG_CHECKING([whether the host c++ compiler ($HOST_CXX $HOST_CXXFLAGS $HOST_LDFLAGS) works])
AC_TRY_COMPILE([], [return(0);],
AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CXX cannot create executables.]) )
CC=$_SAVE_CC
-@@ -266,7 +270,7 @@
+@@ -298,7 +302,7 @@
;;
esac
unset ac_cv_prog_CC
AC_PROG_CC
AC_CHECK_PROGS(CXX, $CXX "${target_alias}-g++" "${target}-g++", :)
-@@ -296,37 +300,6 @@
+@@ -328,37 +332,6 @@
dnl able to run ppc code in a translated environment, making a cross
dnl compiler appear native. So we override that here.
cross_compiling=yes
GNU_AS=
GNU_LD=
-@@ -1435,6 +1408,8 @@
+@@ -1424,6 +1397,8 @@
fi # GNU_CC
fi # COMPILE_ENVIRONMENT
dnl =================================================================
dnl Set up and test static assertion macros used to avoid AC_TRY_RUN,
dnl which is bad when cross compiling.
-@@ -2565,9 +2540,13 @@
+@@ -2579,9 +2554,13 @@
AC_LANG_C
AC_HEADER_STDC
AC_C_CONST
AC_TYPE_SIZE_T
AC_STRUCT_ST_BLKSIZE
AC_MSG_CHECKING(for siginfo_t)
-@@ -2592,7 +2571,8 @@
+@@ -2606,7 +2585,8 @@
AC_CHECK_HEADER(stdint.h)
if test "$ac_cv_header_stdint_h" = yes; then
else
dnl We'll figure them out for ourselves. List more likely types
dnl earlier. If we ever really encounter a size for which none of
-@@ -2990,10 +2970,7 @@
+@@ -3004,10 +2984,7 @@
;;
*)
AC_CHECK_LIB(m, atan)
;;
esac
-@@ -3908,6 +3885,7 @@
+@@ -3903,6 +3880,7 @@
[ --with-nspr-libs=LIBS Pass LIBS to LD when linking code that uses NSPR.
See --with-nspr-cflags for more details.],
NSPR_LIBS=$withval)
AC_SUBST(NSPR_CFLAGS)
AC_SUBST(NSPR_LIBS)
-@@ -4542,18 +4520,11 @@
+@@ -4512,18 +4490,11 @@
# Demangle only for debug or trace-malloc builds
MOZ_DEMANGLE_SYMBOLS=
dnl ========================================================
dnl =
-@@ -5256,6 +5227,8 @@
+@@ -5231,6 +5202,8 @@
done
AC_SUBST(LIBS_PATH)
dnl ========================================================
dnl JavaScript shell
dnl ========================================================
-@@ -5396,3 +5369,4 @@
+@@ -5371,3 +5344,4 @@
# 'js-config' in Makefile.in.
AC_MSG_RESULT(invoking make to create js-config script)
$MAKE js-config
+
Index: offscreen/nsprpub/configure.in
===================================================================
---- offscreen.orig/nsprpub/configure.in 2009-04-16 18:09:00.000000000 +0100
-+++ offscreen/nsprpub/configure.in 2009-04-16 23:06:42.000000000 +0100
+--- offscreen.orig/nsprpub/configure.in 2009-06-12 14:08:54.000000000 +0100
++++ offscreen/nsprpub/configure.in 2009-06-12 14:11:18.000000000 +0100
@@ -42,7 +42,6 @@
AC_PREREQ(2.12)
AC_INIT(config/libc_r.h)
AC_CANONICAL_SYSTEM
dnl ========================================================
-@@ -400,7 +399,7 @@
+@@ -396,7 +395,7 @@
dnl ========================================================
dnl Checks for compilers.
dnl ========================================================
echo "cross compiling from $host to $target"
cross_compiling=yes
-@@ -427,7 +426,7 @@
+@@ -423,7 +422,7 @@
AC_MSG_CHECKING([whether the $host compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
AC_TRY_COMPILE([], [return(0);],
AC_MSG_ERROR([installation or configuration problem: $host compiler $HOST_CC cannot create executables.]) )
CC=$_SAVE_CC
-@@ -448,7 +447,7 @@
+@@ -444,7 +443,7 @@
;;
esac
unset ac_cv_prog_CC
AC_PROG_CC
if test -n "$USE_CPLUS"; then
-@@ -474,30 +473,6 @@
+@@ -470,30 +469,6 @@
AC_CHECK_PROGS(STRIP, $STRIP "${target_alias}-strip" "${target}-strip", echo)
AC_CHECK_PROGS(WINDRES, $WINDRES "${target_alias}-windres" "${target}-windres", echo)
if test "$GCC" = "yes"; then
GNU_CC=1
fi
-@@ -518,11 +493,8 @@
+@@ -514,11 +489,8 @@
;;
esac
dnl ========================================================
dnl Check for gcc -pipe support
-@@ -2249,10 +2221,7 @@
+@@ -2283,10 +2255,7 @@
*-darwin*|*-beos*)
;;
*)
esac
-@@ -2869,6 +2838,8 @@
+@@ -2904,6 +2873,8 @@
dnl pr/tests/w16gui/Makefile
dnl tools/Makefile
if test -z "$USE_PTHREADS" && test -z "$USE_BTHREADS"; then
MAKEFILES="$MAKEFILES pr/src/threads/combined/Makefile"
elif test -n "$USE_PTHREADS"; then
-@@ -2884,3 +2855,5 @@
+@@ -2919,3 +2890,5 @@
echo $MAKEFILES > unallmakefiles
AC_OUTPUT([$MAKEFILES], [chmod +x config/nspr-config])
+
+
-Index: offscreen/toolkit/toolkit-makefiles.sh
-===================================================================
---- offscreen.orig/toolkit/toolkit-makefiles.sh 2009-04-16 22:51:50.000000000 +0100
-+++ offscreen/toolkit/toolkit-makefiles.sh 2009-04-16 23:06:42.000000000 +0100
-@@ -628,7 +628,6 @@
- toolkit/crashreporter/client/Makefile
- toolkit/crashreporter/google-breakpad/src/client/Makefile
- toolkit/crashreporter/google-breakpad/src/client/mac/handler/Makefile
-- toolkit/crashreporter/google-breakpad/src/client/windows/Makefile
- toolkit/crashreporter/google-breakpad/src/client/windows/handler/Makefile
- toolkit/crashreporter/google-breakpad/src/client/windows/sender/Makefile
- toolkit/crashreporter/google-breakpad/src/common/Makefile
Index: offscreen/js/src/Makefile.in
===================================================================
---- offscreen.orig/js/src/Makefile.in 2009-04-16 18:07:56.000000000 +0100
-+++ offscreen/js/src/Makefile.in 2009-04-16 23:06:42.000000000 +0100
-@@ -507,20 +507,8 @@
+--- offscreen.orig/js/src/Makefile.in 2009-06-12 14:08:52.000000000 +0100
++++ offscreen/js/src/Makefile.in 2009-06-12 14:11:18.000000000 +0100
+@@ -514,20 +514,8 @@
export:: jsautocfg.h
# jscpucfg is a strange target
# Needs to be built with the host compiler but needs to include
-@@ -550,7 +538,7 @@
+@@ -557,7 +545,7 @@
echo no need to build jscpucfg $<
else
jscpucfg$(HOST_BIN_SUFFIX): jscpucfg.cpp Makefile.in
Index: offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp
===================================================================
---- offscreen.orig/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-04-16 18:08:00.000000000 +0100
-+++ offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-04-16 23:06:42.000000000 +0100
+--- offscreen.orig/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-06-12 14:08:52.000000000 +0100
++++ offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-06-12 14:11:18.000000000 +0100
@@ -47,6 +47,8 @@
#include <stdarg.h>
Index: offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp
===================================================================
--- offscreen.orig/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-04-16 18:08:00.000000000 +0100
-+++ offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-04-16 23:06:42.000000000 +0100
++++ offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-06-12 14:11:18.000000000 +0100
@@ -39,6 +39,8 @@
*
* ***** END LICENSE BLOCK ***** */
Index: offscreen/modules/lcms/include/icc34.h
===================================================================
--- offscreen.orig/modules/lcms/include/icc34.h 2009-04-16 18:08:47.000000000 +0100
-+++ offscreen/modules/lcms/include/icc34.h 2009-04-16 23:06:42.000000000 +0100
++++ offscreen/modules/lcms/include/icc34.h 2009-06-12 14:11:18.000000000 +0100
@@ -144,7 +144,7 @@
*/
Added the stupid check for autoconf by Marti Maria.
Index: offscreen/toolkit/mozapps/update/src/updater/Makefile.in
===================================================================
---- offscreen.orig/toolkit/mozapps/update/src/updater/Makefile.in 2009-04-16 18:09:35.000000000 +0100
-+++ offscreen/toolkit/mozapps/update/src/updater/Makefile.in 2009-04-16 23:06:42.000000000 +0100
-@@ -59,7 +59,7 @@
+--- offscreen.orig/toolkit/mozapps/update/src/updater/Makefile.in 2009-06-12 14:08:56.000000000 +0100
++++ offscreen/toolkit/mozapps/update/src/updater/Makefile.in 2009-06-12 14:11:18.000000000 +0100
+@@ -60,7 +60,7 @@
LIBS += \
$(DEPTH)/modules/libmar/src/$(LIB_PREFIX)mar.$(LIB_SUFFIX) \
Index: offscreen/xpcom/sample/program/Makefile.in
===================================================================
--- offscreen.orig/xpcom/sample/program/Makefile.in 2009-04-16 18:09:47.000000000 +0100
-+++ offscreen/xpcom/sample/program/Makefile.in 2009-04-16 23:06:42.000000000 +0100
++++ offscreen/xpcom/sample/program/Makefile.in 2009-06-12 14:11:18.000000000 +0100
@@ -57,7 +57,7 @@
# that the application be linked against the XPCOM dynamic library or the NSPR
# dynamic libraries.
Index: offscreen/xpcom/tools/registry/Makefile.in
===================================================================
--- offscreen.orig/xpcom/tools/registry/Makefile.in 2009-04-16 18:09:48.000000000 +0100
-+++ offscreen/xpcom/tools/registry/Makefile.in 2009-04-16 23:06:42.000000000 +0100
++++ offscreen/xpcom/tools/registry/Makefile.in 2009-06-12 14:11:18.000000000 +0100
@@ -54,7 +54,7 @@
SIMPLE_PROGRAMS = $(CPPSRCS:.cpp=$(BIN_SUFFIX))
# Need to link with CoreFoundation on Mac
Index: offscreen/xulrunner/app/Makefile.in
===================================================================
---- offscreen.orig/xulrunner/app/Makefile.in 2009-04-16 18:09:50.000000000 +0100
-+++ offscreen/xulrunner/app/Makefile.in 2009-04-16 23:06:42.000000000 +0100
-@@ -180,7 +180,7 @@
+--- offscreen.orig/xulrunner/app/Makefile.in 2009-06-12 14:08:56.000000000 +0100
++++ offscreen/xulrunner/app/Makefile.in 2009-06-12 14:11:18.000000000 +0100
+@@ -184,7 +184,7 @@
RCFLAGS += -DXULRUNNER_ICO=\"$(DIST)/branding/xulrunner.ico\" -DDOCUMENT_ICO=\"$(DIST)/branding/document.ico\"
endif
Index: offscreen/xulrunner/stub/Makefile.in
===================================================================
--- offscreen.orig/xulrunner/stub/Makefile.in 2009-04-16 18:09:50.000000000 +0100
-+++ offscreen/xulrunner/stub/Makefile.in 2009-04-16 23:06:42.000000000 +0100
++++ offscreen/xulrunner/stub/Makefile.in 2009-06-12 14:11:18.000000000 +0100
@@ -101,7 +101,7 @@
endif
endif
Index: offscreen/modules/plugin/test/testplugin/Makefile.in
===================================================================
---- offscreen.orig/modules/plugin/test/testplugin/Makefile.in 2009-04-16 18:08:56.000000000 +0100
-+++ offscreen/modules/plugin/test/testplugin/Makefile.in 2009-04-16 23:06:42.000000000 +0100
+--- offscreen.orig/modules/plugin/test/testplugin/Makefile.in 2009-06-12 14:08:54.000000000 +0100
++++ offscreen/modules/plugin/test/testplugin/Makefile.in 2009-06-12 14:11:18.000000000 +0100
@@ -63,9 +63,7 @@
CMMSRCS = nptest_macosx.mm
endif
CPPSRCS += nptest_gtk2.cpp
-endif
- ifeq ($(MOZ_WIDGET_TOOLKIT),qt)
- CPPSRCS += nptest_qt.cpp
-Index: offscreen/xulrunner/installer/libxul-unstable.pc.in
-===================================================================
---- offscreen.orig/xulrunner/installer/libxul-unstable.pc.in 2009-04-16 18:09:50.000000000 +0100
-+++ offscreen/xulrunner/installer/libxul-unstable.pc.in 2009-04-16 23:06:42.000000000 +0100
-@@ -8,5 +8,5 @@
- Description: The Mozilla Runtime and Embedding Engine (unstable API)
- Version: %MOZILLA_VERSION%
- Requires: %NSPR_NAME% >= %NSPR_VERSION%
--Libs: -L${sdkdir}/lib -lxpcomglue_s -lxul -lxpcom
-+Libs: -L${sdkdir}/lib -lxpcomglue_s -lxul -lxpcom -lsmime3 -lnss3 -lssl3 -lnssutil3 -L${sdkdir}/../xulrunner-1.9.2a1pre
- Cflags: -I${includedir}/${includetype} %WCHAR_CFLAGS%
+ ifeq ($(MOZ_WIDGET_TOOLKIT),os2)
+ CPPSRCS += nptest_os2.cpp
Index: offscreen/js/src/aclocal.m4
===================================================================
--- offscreen.orig/js/src/aclocal.m4 2009-04-16 18:07:56.000000000 +0100
-+++ offscreen/js/src/aclocal.m4 2009-04-16 23:06:42.000000000 +0100
++++ offscreen/js/src/aclocal.m4 2009-06-12 14:11:18.000000000 +0100
@@ -9,4 +9,3 @@
builtin(include, build/autoconf/moznbytetype.m4)dnl
builtin(include, build/autoconf/mozprog.m4)dnl