configure.in | 24 +++++++++---------------
2 files changed, 23 insertions(+), 27 deletions(-)
-Index: gmp-4.2.2/acinclude.m4
+Index: gmp-4.2.4/acinclude.m4
===================================================================
---- gmp-4.2.2.orig/acinclude.m4 2007-09-01 11:09:03.000000000 +0100
-+++ gmp-4.2.2/acinclude.m4 2008-04-30 17:19:16.000000000 +0100
+--- gmp-4.2.4.orig/acinclude.m4 2008-09-05 14:21:12.000000000 +0200
++++ gmp-4.2.4/acinclude.m4 2008-10-15 23:37:38.062976613 +0200
@@ -30,20 +30,20 @@
dnl conftest.exe - various DOS compilers
-define(X86_PATTERN,
+define([X86_PATTERN],
- [[i?86*-*-* | k[5-8]*-*-* | pentium*-*-* | athlon-*-* | viac3*-*-*]])
+ [[i?86*-*-* | k[5-8]*-*-* | pentium*-*-* | athlon-*-* | viac3*-*-* | geode*-*-*]])
@@ -62,7 +62,7 @@
if test $remove_from_list_i = [$2]; then :;
@@ -87,12 +87,12 @@
dnl ----------------------
- dnl Strip entries subdir from $path and $fat_path.
+ dnl Strip entries */subdir from $path and $fat_path.
-define(GMP_STRIP_PATH,
+define([GMP_STRIP_PATH],
[GMP_HEADER_GETVAL(__GNU_MP_VERSION,gmp-h.in)[]dnl
.GMP_HEADER_GETVAL(__GNU_MP_VERSION_MINOR,gmp-h.in)[]dnl
ifelse(m4_eval(GMP_HEADER_GETVAL(__GNU_MP_VERSION_PATCHLEVEL,gmp-h.in) > 0),1,
-@@ -1489,7 +1489,9 @@
+@@ -1506,7 +1506,9 @@
echo ["define(<CONFIG_TOP_SRCDIR>,<\`$tmp'>)"] >>$gmp_tmpconfigm4
# All CPUs use asm-defs.m4
])
-Index: gmp-4.2.2/configure.in
+Index: gmp-4.2.4/configure.in
===================================================================
---- gmp-4.2.2.orig/configure.in 2007-09-09 17:39:14.000000000 +0100
-+++ gmp-4.2.2/configure.in 2008-04-30 17:09:10.000000000 +0100
+--- gmp-4.2.4.orig/configure.in 2008-08-01 19:24:04.000000000 +0200
++++ gmp-4.2.4/configure.in 2008-10-15 23:35:03.466325346 +0200
@@ -29,12 +29,6 @@
AC_PREREQ(2.59)
AC_INIT(GNU MP, GMP_VERSION, gmp-bugs@swox.com, gmp)
# If --target is not used then $target_alias is empty, but if say
# "./configure athlon-pc-freebsd3.5" is used, then all three of
-@@ -275,7 +269,7 @@
+@@ -278,7 +272,7 @@
# After GMP specific searches and tests, the standard autoconf AC_PROG_CC is
# called. User selections of CC etc are respected.
#
# pre-testing, since they of course depend on AC_PROG_CC, and also some of
# them cache their results, which is not wanted.
#
-@@ -367,7 +361,7 @@
+@@ -370,7 +364,7 @@
# FIXME: We'd like to prefer an ANSI compiler, perhaps by preferring
# c89 over cc here. But note that on HP-UX c89 provides a castrated
# environment, and would want to be excluded somehow. Maybe
# we don't need to worry.
#
cclist="gcc cc"
-@@ -1518,7 +1512,7 @@
+@@ -1525,7 +1519,7 @@
CFLAGS_or_unset=${CFLAGS-'(unset)'}
CPPFLAGS_or_unset=${CPPFLAGS-'(unset)'}
User:
ABI=$ABI
CC=$CC
-@@ -1889,7 +1883,6 @@
+@@ -1896,7 +1890,6 @@
# The C compiler and preprocessor, put into ANSI mode if possible.
AC_PROG_CC
AC_PROG_CPP
GMP_H_ANSI
-@@ -1912,11 +1905,11 @@
+@@ -1919,11 +1912,11 @@
# The C++ compiler, if desired.
want_cxx=no
cxxflags_ac_prog_cxx=$CXXFLAGS
cxxflags_list=ac_prog_cxx
-@@ -2022,7 +2015,7 @@
+@@ -2029,7 +2022,7 @@
esac
Decided:
ABI=$ABI
CC=$CC
-@@ -3199,7 +3192,7 @@
+@@ -3208,7 +3201,7 @@
# FIXME: Upcoming version of autoconf/automake may not like broken lines.
# Right now automake isn't accepting the new AC_CONFIG_FILES scheme.
mpbsd/Makefile mpf/Makefile mpn/Makefile mpq/Makefile \
mpz/Makefile printf/Makefile scanf/Makefile cxx/Makefile \
tests/Makefile tests/devel/Makefile tests/mpbsd/Makefile \
-@@ -3208,4 +3201,5 @@
+@@ -3217,4 +3210,5 @@
tests/cxx/Makefile \
doc/Makefile tune/Makefile \
demos/Makefile demos/calc/Makefile demos/expr/Makefile \