]> code.ossystems Code Review - openembedded-core.git/commitdiff
qt-demo-init: Fix bug 999
authorXiaofeng Yan <xiaofeng.yan@windriver.com>
Wed, 31 Aug 2011 01:39:58 +0000 (09:39 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 31 Aug 2011 18:55:11 +0000 (19:55 +0100)
[YOCTO #999]
qt4e-demo-image needs qt-demo-init when starting qtdemoE.
qt-demo-init was pulled from Openembeded.

Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-qt/qt-demo/qt-demo-init/qtdemo-init [new file with mode: 0644]
meta/recipes-qt/qt-demo/qt-demo-init_0.1.bb [new file with mode: 0644]

diff --git a/meta/recipes-qt/qt-demo/qt-demo-init/qtdemo-init b/meta/recipes-qt/qt-demo/qt-demo-init/qtdemo-init
new file mode 100644 (file)
index 0000000..affb958
--- /dev/null
@@ -0,0 +1,55 @@
+#!/bin/sh
+
+set -e
+
+if [ -f /usr/bin/qtdemo ]; then
+       QTDEMO="qtdemo > /var/log/Xsession.log 2> &1"
+else
+       QTDEMO="qtdemoE -qws"
+fi
+
+case "$1" in
+  start)
+       echo "Starting qtdemo"
+       if [ -f /etc/profile.d/tslib.sh ]; then
+               source /etc/profile.d/tslib.sh
+       fi
+       if [ -e $TSLIB_TSDEVICE ]; then
+               if [ ! -f /etc/pointercal ]; then
+                       /usr/bin/ts_calibrate
+               fi
+               if [ $QTDEMO == qtdemo ]; then
+                       Xorg &
+                       export DISPLAY=:0
+                       $QTDEMO &
+               else
+                       QWS_MOUSE_PROTO=tslib:$TSLIB_TSDEVICE $QTDEMO &
+               fi
+       else
+               if [ $QTDEMO == qtdemo ]; then
+                       Xorg &
+                       export DISPLAY=:0
+               fi
+               $QTDEMO &
+       fi
+       ;;
+  stop)
+       echo "Stopping qtdemo"
+       if [ $QTDEMO == qtdemo ]; then
+               killall Xorg
+               killall qtdemo
+       else
+               killall qtdemoE
+       fi
+       ;;
+  restart)
+       $0 stop
+       $0 start
+       ;;
+  *)
+       echo "usage: $0 { start | stop | restart }" >&2
+       exit 1
+       ;;
+esac
+
+exit 0
diff --git a/meta/recipes-qt/qt-demo/qt-demo-init_0.1.bb b/meta/recipes-qt/qt-demo/qt-demo-init_0.1.bb
new file mode 100644 (file)
index 0000000..8d0dd19
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Init script for qtdemo"
+LICENSE = "MIT"
+SRC_URI = "file://qtdemo-init"
+PR = "r2"
+
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PACKAGE_ARCH = "all"
+
+do_install() {
+       install -d ${D}${sysconfdir}/init.d/
+       install -m 0755 ${WORKDIR}/qtdemo-init ${D}${sysconfdir}/init.d/qtdemo
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "qtdemo"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 19 0 1 6 ."