]> code.ossystems Code Review - openembedded-core.git/commitdiff
ruby: some ptest fixes
authorAndré Draszik <andre.draszik@jci.com>
Tue, 1 Oct 2019 14:29:56 +0000 (15:29 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 22 Oct 2019 07:48:16 +0000 (08:48 +0100)
* the (new?) ruby expects some additional compiled libraries
  to run, so we need to copy them as part of ptest.
  Fixes errors like:
  # ruby ./runner.rb ./-ext-/vm/test_at_exit.rb
  Run options:

  # Running tests:

  [1/1] TestVM#test_at_exit = 0.06 s
    1) Failure:
  TestVM#test_at_exit [/usr/lib/ruby/ptest/test/-ext-/vm/test_at_exit.rb:7]:

  1. [1/2] Assertion for "stdout"
     | <["begin", "end"]> expected but was
     | <[]>.

  2. [2/2] Assertion for "stderr"
     | <[]> expected but was
     | <["-:1:in `require': cannot load such file -- -test-/vm/at_exit (LoadError)",
     |  "\tfrom -:1:in `<main>'"]>.

* the 'erb' test can't find the erb binary, as we're not
  running this from within the build directory

Signed-off-by: André Draszik <andre.draszik@jci.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/ruby/ruby_2.6.4.bb

index 4554487c0a2822420bae4f48c69bc5e1f92340c9..fb202b8f1f38b465fb07e78f880ea21b0ccc2dca 100644 (file)
@@ -44,6 +44,14 @@ do_install_append_class-target () {
 
 do_install_ptest () {
     cp -rf ${S}/test ${D}${PTEST_PATH}/
+    # install test-binaries
+    find $(find ./.ext -path '*/-test-') -name '*.so' -print0 \
+        | tar --no-recursion --null -T - --no-same-owner --preserve-permissions -cf - \
+        | tar -C ${D}${libdir}/ruby/${SHRT_VER}.0/ --no-same-owner --preserve-permissions --strip-components=2 -xf -
+    # adjust path to not assume build directory layout
+    sed -e 's|File.expand_path(.*\.\./bin/erb[^)]*|File.expand_path("${bindir}/erb"|g' \
+        -i ${D}${PTEST_PATH}/test/erb/test_erb_command.rb
+
     cp -r ${S}/include ${D}/${libdir}/ruby/
     test_case_rb=`grep rubygems/test_case.rb ${B}/.installed.list`
     sed -i -e 's:../../../test/:../../../ptest/test/:g' ${D}/$test_case_rb
@@ -61,6 +69,9 @@ FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
 
 FILES_${PN} += "${datadir}/rubygems"
 
-FILES_${PN}-ptest_append_class-target += "${libdir}/ruby/include"
+FILES_${PN}-ptest_append_class-target = "\
+    ${libdir}/ruby/include \
+    ${libdir}/ruby/${SHRT_VER}.0/*/-test- \
+"
 
 BBCLASSEXTEND = "native"