]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: import pyrsistent from meta-python
authorBruce Ashfield <bruce.ashfield@gmail.com>
Wed, 24 Nov 2021 14:32:40 +0000 (09:32 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 26 Nov 2021 16:58:55 +0000 (16:58 +0000)
pyrsistent is a dependency of python3-jsonschema, which is being
imported to support kernel device tree validation.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
meta/recipes-devtools/python/python3-pyrsistent_0.18.0.bb [new file with mode: 0644]

diff --git a/meta/recipes-devtools/python/python3-pyrsistent_0.18.0.bb b/meta/recipes-devtools/python/python3-pyrsistent_0.18.0.bb
new file mode 100644 (file)
index 0000000..0b4d256
--- /dev/null
@@ -0,0 +1,14 @@
+SUMMARY = "Persistent/Immutable/Functional data structures for Python"
+HOMEPAGE = "https://github.com/tobgu/pyrsistent"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.mit;md5=a4b94c2b800b582a8d3925a9939cbf44"
+
+SRC_URI[sha256sum] = "773c781216f8c2900b42a7b638d5b517bb134ae1acbebe4d1e8f1f41ea60eb4b"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-numbers \
+"
+
+BBCLASSEXTEND = "native nativesdk"