]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: Fix failures of LSB python-runtime tests.
authorJingdong Lu <jingdong.lu@windriver.com>
Wed, 19 Jan 2011 09:04:43 +0000 (17:04 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 20 Jan 2011 21:37:02 +0000 (21:37 +0000)
Fix failues of LSB python-runtime tests.
test_largefile: add "ac_cv_sizeof_off_t=8" option explicitly into configure options in order to enable "LFS".
test_codecs, test_re, test_unicode: "--with-wctype-functions" will cause these tests failed, so remove it for LSB.
test_builtin, test_getargs: "sitecustomize.py" cause default encoding changed from "ascii" into "utf8" and it will cause these tests failed, so remove this file for LSB.

Signed-off-by: Jingdong Lu<jingdong.lu@windriver.com>
meta/recipes-devtools/python/python.inc
meta/recipes-devtools/python/python_2.6.6.bb

index 62a6ba158923eef702d110c8a94a17c3f415f66a..f78250769bca376354469bff274858ef305ae141 100644 (file)
@@ -22,4 +22,14 @@ EXTRA_OECONF = "\
   --enable-shared \
 "
 
+EXTRA_OECONF_poky-lsb = "\
+  --with-threads \
+  --with-pymalloc \
+  --with-cyclic-gc \
+  --without-cxx \
+  --with-signal-module \
+  --enable-shared \
+  ac_cv_sizeof_off_t=8 \
+"
+
 PARALLEL_MAKE = ""
index b33e0a9e87f6bb3e0f76fa6e7f3e3af51a630e60..ad0d7a956ad69f37fdda801f491a970713d71213 100644 (file)
@@ -1,8 +1,11 @@
 require python.inc
 DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib"
 DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=38fdd546420fab09ac6bd3d8a1c83eb6"
+
+DISTRO_SRC_URI ?= "file://sitecustomize.py"
+DISTRO_SRC_URI_poky-lsb = ""
 SRC_URI = "\
   http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
   file://01-use-proper-tools-for-cross-build.patch \
@@ -12,7 +15,7 @@ SRC_URI = "\
   file://05-enable-ctypes-cross-build.patch \
   file://06-avoid_usr_lib_termcap_path_in_linking.patch \
   file://99-ignore-optimization-flag.patch \
-  file://sitecustomize.py \
+  ${DISTRO_SRC_URI} \
 "
 
 SRC_URI[md5sum] = "cf4e6881bb84a7ce6089e4a307f71f14"
@@ -74,7 +77,9 @@ do_install() {
                BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
                DESTDIR=${D} LIBDIR=${libdir} install
 
-       install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
+       if [ -e ${WORKDIR}/sitecustomize.py ]; then
+               install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
+       fi
 
        # remove hardcoded ccache, see http://bugs.openembedded.net/show_bug.cgi?id=4144
        sed -i -e s,ccache,'$(CCACHE)', ${D}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile