]> code.ossystems Code Review - openembedded-core.git/commitdiff
gstreamer/lame: Better gcc 4.9 fix
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 12 May 2014 17:00:03 +0000 (18:00 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 15 May 2014 22:27:41 +0000 (23:27 +0100)
gstreamer/lame does runtime detection to enable/disable things like SSE code.
Unfortunately it is broken and will try and use this even with i586
compiler flags. This change forces it back to the approach with gcc 4.8
by disabling the problematic headers.

Its suboptimal but less so that the proposed previous forced enabling of
SSE on x86 everywhere.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bb
meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base.inc
meta/recipes-multimedia/lame/lame_3.99.5.bb

index 83b856b110f9787bef0ec587bbc0ac89130e089d..4a8a9947a7387082246a9d6714eb8f02eefd5d42 100644 (file)
@@ -33,3 +33,5 @@ do_configure_prepend() {
 }
 
 FILES_${PN} += "${datadir}/${BPN}"
+
+CACHED_CONFIGUREVARS_append_i586 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmmintrin_h=no"
index eb132775c6035f32ee1c39da368f0811610fe45b..972ff18160a0eebae3bc82707a16edb193424a55 100644 (file)
@@ -37,3 +37,4 @@ EXTRA_OECONF += " \
 
 FILES_${PN} += "${datadir}/gst-plugins-base"
 
+CACHED_CONFIGUREVARS_append_i586 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmmintrin_h=no"
index 907ff8f9d07d0b502aa1958605357553d1fb281a..695b7ca989ce604f41c015770c79d83f2716cdfd 100644 (file)
@@ -26,3 +26,5 @@ FILES_${PN} = "${bindir}/lame"
 FILES_libmp3lame = "${libdir}/libmp3lame.so.*"
 FILES_libmp3lame-dev = "${includedir} ${libdir}/*"
 FILES_${PN}-dev = ""
+
+CACHED_CONFIGUREVARS_append_i586 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmmintrin_h=no"