]> code.ossystems Code Review - openembedded-core.git/commitdiff
rust: fix upstream version checks
authorAlexander Kanavin <alex.kanavin@gmail.com>
Fri, 27 Aug 2021 12:24:36 +0000 (14:24 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 1 Sep 2021 13:05:41 +0000 (14:05 +0100)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rust/rust-source.inc
meta/recipes-example/rust-hello-world/rust-hello-world_git.bb

index 52502fb49f2615c6ab1915ad7473453c9c018873..1529ecfafe61b851432bc845cdbdc233069a2b30 100644 (file)
@@ -1,3 +1,6 @@
 SRC_URI += "https://static.rust-lang.org/dist/rustc-${PV}-src.tar.xz;name=rust"
 
 RUSTSRC = "${WORKDIR}/rustc-${PV}-src"
+
+UPSTREAM_CHECK_URI = "https://forge.rust-lang.org/infra/other-installation-methods.html"
+UPSTREAM_CHECK_REGEX = "rustc-(?P<pver>\d+(\.\d+)+)-src"
index c29eac34e5ec2fa4d2fc0b2e9557550a2a26974d..3ebd9cc661ee3a866ae71cddff334eecebfd24f4 100644 (file)
@@ -8,6 +8,8 @@ SRC_URI += "\
     file://0001-enable-LTO.patch \
     "
 
+UPSTREAM_CHECK_COMMITS = "1"
+
 SUMMARY = "Hello World by Cargo for Rust"
 HOMEPAGE = "https://github.com/meta-rust/rust-hello-world"
 LICENSE = "MIT | Apache-2.0"