]> code.ossystems Code Review - openembedded-core.git/commitdiff
wpa-supplicant: configured to work with libnl 3.2.14
authorMihai Prica <mihai.prica@intel.com>
Tue, 4 Dec 2012 16:50:30 +0000 (18:50 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Dec 2012 12:30:36 +0000 (12:30 +0000)
* Updated the configuration file for libnl-3
* Added python include dir path to configuration file

Signed-off-by: Mihai Prica <mihai.prica@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-connectivity/wpa-supplicant/wpa-supplicant-1.0.inc
meta/recipes-connectivity/wpa-supplicant/wpa-supplicant-1.0/defconfig-gnutls
meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_1.0.bb

index 485a2dd5dd95faceab82407320af9027040bd229..ff5cddcd06c1fcf517b953debd4f68d1920d01d9 100644 (file)
@@ -25,6 +25,7 @@ FILES_${PN} += "${datadir}/dbus-1/system-services/*"
 CONFFILES_${PN} += "${sysconfdir}/wpa_supplicant.conf"
 
 do_configure () {
+       echo "CFLAGS +=\"-I${STAGING_INCDIR}/libnl3\"" >> ${WORKDIR}/defconfig-gnutls
        install -m 0755 ${WORKDIR}/defconfig-gnutls .config
 }
 
index e03338fe09415d7d63030c967a9950bec1193309..e041b4d36f8b5f12657c142c7de4c0e584af3e8c 100644 (file)
@@ -81,7 +81,7 @@ CONFIG_DRIVER_HOSTAP=y
 CONFIG_DRIVER_WEXT=y
 
 # Driver interface for Linux drivers using the nl80211 kernel interface
-CONFIG_LIBNL20=y
+CONFIG_LIBNL32=y
 CONFIG_DRIVER_NL80211=y
 
 # Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
index 36ee25c7e06d5af0eddf7a074f1ee53bfc65ffcb..115007563e44da44fae1addd468826caed5e25b6 100644 (file)
@@ -1,6 +1,6 @@
 require wpa-supplicant-1.0.inc
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI[md5sum] = "8650f6aa23646ef634402552d0669640"
 SRC_URI[sha256sum] = "91d41d473a5aafa2e25dd6577ebda975c4d4a3188850a53e31feaf7c04482b9c"