]> code.ossystems Code Review - openembedded-core.git/commitdiff
glibc-initial: Install headers into staging, not cross
authorRichard Purdie <richard@openedhand.com>
Wed, 19 Sep 2007 13:02:25 +0000 (13:02 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 19 Sep 2007 13:02:25 +0000 (13:02 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2764 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/glibc/glibc-initial_2.4.bb
meta/packages/glibc/glibc-initial_2.5.bb
meta/packages/glibc/glibc-initial_csl-2005q3-2.bb

index ff458d328501112c73fc87f172b5c08115d9f534..861478f7d5c4848d66cba32b00c78d73d0064aa3 100644 (file)
@@ -32,14 +32,14 @@ do_compile () {
 }
 
 do_stage () {
-       oe_runmake cross-compiling=yes install_root=${CROSS_DIR}/${TARGET_SYS} prefix="" install-headers
+       oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers
 
        # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
        # so do them by hand.  We can tolerate an empty stubs.h for the moment.
        # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
-       mkdir -p ${CROSS_DIR}/${TARGET_SYS}/include/gnu
-       touch ${CROSS_DIR}/${TARGET_SYS}/include/gnu/stubs.h
-       cp ${S}/include/features.h ${CROSS_DIR}/${TARGET_SYS}/include/features.h
+       mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu
+       touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h
+       cp ${S}/include/features.h  ${STAGING_DIR}/${HOST_SYS}/include/features.h
 }
 
 do_install () {
index fb05c9e029754a7b66750c65001d50716a218e96..0323debbdd6b4acdf116e40d64e51e1516223d6d 100644 (file)
@@ -31,14 +31,14 @@ do_compile () {
 }
 
 do_stage () {
-       oe_runmake cross-compiling=yes install_root=${CROSS_DIR}/${TARGET_SYS} prefix="" install-headers
+       oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers
 
        # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
        # so do them by hand.  We can tolerate an empty stubs.h for the moment.
        # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
-       mkdir -p ${CROSS_DIR}/${TARGET_SYS}/include/gnu
-       touch ${CROSS_DIR}/${TARGET_SYS}/include/gnu/stubs.h
-       cp ${S}/include/features.h ${CROSS_DIR}/${TARGET_SYS}/include/features.h
+       mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu
+       touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h
+       cp ${S}/include/features.h ${STAGING_DIR}/${HOST_SYS}/include/features.h
 }
 
 do_install () {
index ff458d328501112c73fc87f172b5c08115d9f534..6fe67083ec2f389104508056dadbbf3b893df59f 100644 (file)
@@ -32,14 +32,14 @@ do_compile () {
 }
 
 do_stage () {
-       oe_runmake cross-compiling=yes install_root=${CROSS_DIR}/${TARGET_SYS} prefix="" install-headers
+       oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers
 
        # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
        # so do them by hand.  We can tolerate an empty stubs.h for the moment.
        # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
-       mkdir -p ${CROSS_DIR}/${TARGET_SYS}/include/gnu
-       touch ${CROSS_DIR}/${TARGET_SYS}/include/gnu/stubs.h
-       cp ${S}/include/features.h ${CROSS_DIR}/${TARGET_SYS}/include/features.h
+       mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu
+       touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h
+       cp ${S}/include/features.h ${STAGING_DIR}/${HOST_SYS}/include/features.h
 }
 
 do_install () {