]> code.ossystems Code Review - openembedded-core.git/commitdiff
libc-common: Apply Debian-naming to libc debug symbols too
authorMike Crowe <mac@mcrowe.com>
Tue, 20 Mar 2012 17:27:43 +0000 (17:27 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Mar 2012 19:17:35 +0000 (19:17 +0000)
Ensure that the eglibc-dbg package follows Debian naming too if
enabled. Retain backward compatibility with old libc-dbg naming.

Signed-off-by: Mike Crowe <mac@mcrowe.com>
meta/classes/libc-common.bbclass
meta/recipes-core/eglibc/eglibc_2.13.bb
meta/recipes-core/eglibc/eglibc_2.15.bb

index 962f205f818a300b15fecbb54eb1d79e2375d48e..9b91f0a1a6f48f3104fd418585136323f6717253 100644 (file)
@@ -27,4 +27,9 @@ python populate_packages_prepend () {
                bpn = d.getVar('BPN', True)
                d.setVar('PKG_'+bpn, 'libc6')
                d.setVar('PKG_'+bpn+'-dev', 'libc6-dev')
+               d.setVar('PKG_'+bpn+'-dbg', 'libc6-dbg')
+               # For backward compatibility with old -dbg package
+               d.setVar('RPROVIDES_' + bpn + '-dbg', 'libc-dbg')
+               d.setVar('RCONFLICTS_' + bpn + '-dbg', 'libc-dbg')
+               d.setVar('RREPLACES_' + bpn + '-dbg', 'libc-dbg')
 }
index e718a1f93e97599acfcdd2f52994769feac23a52..a4f59b62ce8be0dfe226e7bd67211da67b1f8635 100644 (file)
@@ -3,7 +3,7 @@ require eglibc.inc
 SRCREV = "15508"
 
 DEPENDS += "gperf-native"
-PR = "r20"
+PR = "r21"
 PR_append = "+svnr${SRCPV}"
 
 EGLIBC_BRANCH="eglibc-2_13"
index b4c1ea5a990425fa5d6bbca4e9551528da7d9f2e..3820f5aa096e2cf1f57a41da8aff32e336de243b 100644 (file)
@@ -3,6 +3,7 @@ require eglibc.inc
 SRCREV = "16540"
 
 DEPENDS += "gperf-native"
+PR = "r1"
 PR_append = "+svnr${SRCPV}"
 
 EGLIBC_BRANCH="eglibc-2_15"