]> code.ossystems Code Review - openembedded-core.git/commitdiff
wireless-tools: Upgrade 29 -> 30.pre9
authorKhem Raj <raj.khem@gmail.com>
Sat, 1 Feb 2014 08:51:17 +0000 (00:51 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 2 Feb 2014 22:34:34 +0000 (22:34 +0000)
This also fixes the underlinking problems that
are unearthed with newer binutils 2.24
where one of the wireless-tools libraries is asking
for symbols from libm but all the symbols it asks
for are unfortunately weak and they do not let new
linker convince enough to link libm even though -lm
is on cmdline since we are using --as-needed by default
in linker, which means we end up with errors like

| make: *** [iwconfig] Error 1
| libiw.so.30: undefined reference to `ceil'
| libiw.so.30: undefined reference to `pow'
| libiw.so.30: undefined reference to `log10'
| libiw.so.30: undefined reference to `floor'
| collect2: error: ld returned 1 exit status

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/wireless-tools/wireless-tools/man.patch
meta/recipes-connectivity/wireless-tools/wireless-tools_30.pre9.bb [moved from meta/recipes-connectivity/wireless-tools/wireless-tools_29.bb with 80% similarity]

index 8e16215ff6892da18f21b12b10f8b2fd8385f791..6a757dae7637076c11a156f0e97a77d7e0db7a7e 100644 (file)
@@ -1,15 +1,15 @@
 Upstream-Status: Inappropriate [configuration]
 
---- wireless_tools.26/Makefile.orig    2003-06-18 03:38:58.000000000 +0200
-+++ wireless_tools.26/Makefile 2004-07-03 23:35:29.000000000 +0200
-@@ -57,8 +57,8 @@
- # Install directories
- INSTALL_DIR= $(PREFIX)/sbin/
- INSTALL_LIB= $(PREFIX)/lib/
--INSTALL_INC= $(PREFIX)/include/
--INSTALL_MAN= $(PREFIX)/man/
-+INSTALL_INC= $(PREFIX)/usr/include/
-+INSTALL_MAN= $(PREFIX)/usr/share/man/
+Index: wireless_tools.30/Makefile
+===================================================================
+--- wireless_tools.30.orig/Makefile    2014-02-01 00:21:04.148463382 -0800
++++ wireless_tools.30/Makefile 2014-02-01 00:23:35.448072279 -0800
+@@ -76,7 +76,7 @@
+ INSTALL_DIR= $(PREFIX)/sbin
+ INSTALL_LIB= $(PREFIX)/lib
+ INSTALL_INC= $(PREFIX)/include
+-INSTALL_MAN= $(PREFIX)/man
++INSTALL_MAN= $(PREFIX)/share/man
  
- # Use local header if the version of wireless extensions is specified
- ifdef FORCE_WEXT_VERSION
+ # Various commands
+ RM = rm -f
similarity index 80%
rename from meta/recipes-connectivity/wireless-tools/wireless-tools_29.bb
rename to meta/recipes-connectivity/wireless-tools/wireless-tools_30.pre9.bb
index 3aef24ec4cae3f01be7a14ac6638b7d518cb4987..26ecdf3b408b14dd62205182f805b28caa7ae649 100644 (file)
@@ -7,19 +7,19 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
                        file://sample_enc.c;beginline=1;endline=4;md5=838372be07874260b566bae2f6ed33b6"
 SECTION = "base"
 PE = "1"
-PR = "r4"
 
-SRC_URI = "http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/wireless_tools.29.tar.gz \
-          file://remove.ldconfig.call.patch \
-          file://man.patch \
-          file://wireless-tools.if-pre-up \
-          file://zzz-wireless.if-pre-up \
-          file://avoid_strip.patch \
-          file://ldflags.patch"
+SRC_URI = "http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/wireless_tools.${PV}.tar.gz \
+           file://wireless-tools.if-pre-up \
+           file://zzz-wireless.if-pre-up \
+           file://remove.ldconfig.call.patch \
+           file://man.patch \
+           file://avoid_strip.patch \
+           file://ldflags.patch \
+          "
+SRC_URI[md5sum] = "ca91ba7c7eff9bfff6926b1a34a4697d"
+SRC_URI[sha256sum] = "abd9c5c98abf1fdd11892ac2f8a56737544fe101e1be27c6241a564948f34c63"
 
-SRC_URI[md5sum] = "e06c222e186f7cc013fd272d023710cb"
-SRC_URI[sha256sum] = "6fb80935fe208538131ce2c4178221bab1078a1656306bce8909c19887e2e5a1"
-S = "${WORKDIR}/wireless_tools.29"
+S = "${WORKDIR}/wireless_tools.30"
 
 CFLAGS =+ "-I${S}"
 EXTRA_OEMAKE = "-e 'BUILD_SHARED=y' \