]> code.ossystems Code Review - openembedded-core.git/commitdiff
classes/autotools_stage.bbclass: Add autotools_stage class to simplify recipes using...
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 26 Dec 2008 19:02:44 +0000 (19:02 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 30 Dec 2008 17:07:04 +0000 (17:07 +0000)
51 files changed:
meta/classes/autotools_stage.bbclass [new file with mode: 0644]
meta/packages/atk/atk.inc
meta/packages/avahi/avahi.inc
meta/packages/avahi/avahi_0.6.23.bb
meta/packages/beecrypt/beecrypt_3.1.0.bb
meta/packages/cairo/cairo.inc
meta/packages/claws-mail/claws-mail.inc
meta/packages/clutter/aaina.inc
meta/packages/clutter/clutter-box2d.inc
meta/packages/clutter/clutter-cairo.inc
meta/packages/clutter/clutter-gst.inc
meta/packages/clutter/clutter-gtk.inc
meta/packages/clutter/clutter-helix.inc
meta/packages/clutter/clutter.inc
meta/packages/clutter/table.inc
meta/packages/clutter/tidy.inc
meta/packages/connman/connman_git.bb
meta/packages/drm/libdrm_2.4.0.bb
meta/packages/drm/libdrm_git.bb
meta/packages/eds/eds-dbus_2.20.0.bb
meta/packages/eds/eds-dbus_svn.bb
meta/packages/file/file_4.18.bb
meta/packages/galago/libgalago_0.5.2.bb
meta/packages/gmp/gmp.inc
meta/packages/gnome/gnome-keyring_2.20.bb
meta/packages/gsm/gsmd.inc
meta/packages/gstreamer/gst-plugins.inc
meta/packages/gstreamer/gstreamer_0.10.20.bb
meta/packages/gupnp/gssdp_0.6.2.bb
meta/packages/gupnp/gupnp_0.12.2.bb
meta/packages/gypsy/gypsy.inc
meta/packages/gypsy/gypsy_0.6.bb
meta/packages/icu/icu-3.6.inc
meta/packages/icu/icu_3.6.bb
meta/packages/iso-codes/iso-codes_3.3.bb
meta/packages/libetpan/libetpan_0.54.bb
meta/packages/libexif/libexif_0.6.16.bb
meta/packages/libgcrypt/libgcrypt.inc
meta/packages/libgdbus/libgdbus_git.bb
meta/packages/wbxml/wbxml2_0.9.2.bb
meta/packages/webkit/webkit-gtk_svn.bb
meta/packages/wv/wv_1.2.0.bb
meta/packages/xcb/libpthread-stubs_0.1.bb
meta/packages/xcb/libxcb.inc
meta/packages/xkeyboard-config/xkeyboard-config_1.3.bb
meta/packages/xorg-app/xorg-app-common.inc
meta/packages/xorg-driver/xf86-driver-common.inc
meta/packages/xorg-lib/xorg-lib-common.inc
meta/packages/xorg-proto/xorg-proto-common.inc
meta/packages/xorg-util/xorg-util-common.inc
meta/packages/xorg-xserver/xserver-xf86-common.inc

diff --git a/meta/classes/autotools_stage.bbclass b/meta/classes/autotools_stage.bbclass
new file mode 100644 (file)
index 0000000..010117c
--- /dev/null
@@ -0,0 +1,5 @@
+inherit autotools
+
+do_stage () {
+       autotools_stage_all
+}
\ No newline at end of file
index 5f81cdf67e1e72f81bceef5812744dab4972abde..9256dfbac8bfc2848c3d1a3d95de8bb4b8ee0842 100644 (file)
@@ -5,10 +5,6 @@ LICENSE = "LGPL"
 
 DEPENDS = "glib-2.0 gtk-doc-native"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 EXTRA_OECONF = "--disable-glibtest"
-
-do_stage () {
-       autotools_stage_all
-}
index 419b787b5f318c17c0fbc6b726830c2eb5169051..8bc9f1b6106f9d01a55e6dbb5ad88af1c61ad990 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz \
         file://99avahi-autoipd \
         file://initscript.patch;patch=1"
 
-inherit autotools pkgconfig update-rc.d
+inherit autotools_stage pkgconfig update-rc.d
 
 EXTRA_OECONF = "--with-distro=debian \
              --with-avahi-priv-access-group=adm \
index 642b6b916cc292a1e81fbb0b9045e071732c79a5..87876ac6f2e1a2b45e64ec69423488b9bf2874ef 100644 (file)
@@ -6,7 +6,3 @@ PR = "r8"
 FILES_avahi-autoipd = "${sbindir}/avahi-autoipd \
                        ${sysconfdir}/avahi/avahi-autoipd.action \
                       ${sysconfdir}/dhcp3/*/avahi-autoipd"
-
-do_stage() {
-       autotools_stage_all
-}
index 947ca56689e5f6106ea8062ba69294bd11881aa5..78ff5cad292538d00259f9b9539029f4300b80db 100644 (file)
@@ -7,11 +7,7 @@ HOMEPAGE="http://sourceforge.net/projects/beecrypt"
 SRC_URI="${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz \
          file://x64fix.patch;patch=1"
 
-inherit autotools
+inherit autotools_stage
 acpaths=""
 
 EXTRA_OECONF="--with-arch=${TARGET_ARCH} --enable-shared --enable-static"
-
-do_stage () {
-       autotools_stage_all
-}
index 015e649e6477cfd7ffb63da6ba7290267cb7bf18..561823306390eca830040a3c3fe522fba825a277 100644 (file)
@@ -8,7 +8,7 @@ LICENSE = "MPL LGPL"
 require cairo-fpu.inc
 EXTRA_OECONF += "${@get_cairo_fpu_setting(bb, d)}"
 
-inherit autotools pkgconfig 
+inherit autotools_stage pkgconfig 
 
 do_stage () {
        autotools_stage_all
index be184f9022cab5403df9d979397f9631d9b9825c..fcd4a1dd7fcbc64a43bf0e8dfa0569f3289e6433 100644 (file)
@@ -39,7 +39,7 @@ EXTRA_OECONF = "--disable-aspell-test                 \
 
 CFLAGS += "-D_GNU_SOURCE"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 do_install_append() {
        install -d ${D}${datadir}/applications
@@ -48,10 +48,6 @@ do_install_append() {
        install -m 0644 claws-mail.png ${D}${datadir}/pixmaps/
 }
 
-do_stage () {
-       autotools_stage_all
-}
-
 #python populate_packages_prepend () {
 #      abiword_libdir = bb.data.expand('${libdir}/claws-mail/plugins', d)
 #
index 1baccc730c6b1d471a15d3070951bbc9c383f89f..29a0e0c0d6e2a70469acea33faa826561a371e4e 100644 (file)
@@ -4,9 +4,4 @@ LICENSE = "GPL"
 
 DEPENDS = "clutter-0.6 libxml2 gtk+ neon"
 
-inherit autotools pkgconfig
-
-do_stage () {
-        autotools_stage_all
-}
-
+inherit autotools_stage pkgconfig
index c5cd3283e26e8394ce8a9bb7332a271816ec45da..7e279a2a0451dc2e500549d11680f2d143c42cb9 100644 (file)
@@ -7,11 +7,7 @@ DEPENDS = "clutter-0.8"
 # The main clutter lib is machine specific so we need to be too
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-inherit autotools pkgconfig gtk-doc
-
-do_stage () {
-        autotools_stage_all
-}
+inherit autotools_stage pkgconfig gtk-doc
 
 do_install_append () {
        install -d ${D}${bindir}
index 3a94c35ad66e0a2315d0cfe96dfe8c188af9a6bb..2e6e3e5ee0af4cc4c1cd25c75586a97e897f5902 100644 (file)
@@ -9,9 +9,5 @@ FILESPATH = "${FILE_DIRNAME}/clutter-cairo"
 PACKAGES =+ "${PN}-examples"
 FILES_${PN}-examples = "${bindir}/flowers ${bindir}/clock"
 
-inherit autotools pkgconfig
-
-do_stage () {
-        autotools_stage_all
-}
+inherit autotools_stage pkgconfig
 
index ad921bd0c07ddc3da130ca01395867081060166e..c3a659767c3f36bbb9e9a514e9fa17a8a1f82e76 100644 (file)
@@ -9,9 +9,5 @@ FILESPATH = "${FILE_DIRNAME}/clutter-gst"
 PACKAGES =+ "${PN}-examples"
 FILES_${PN}-examples = "${bindir}/video-player ${bindir}/video-sink ${bindir}/audio"
 
-inherit autotools pkgconfig gtk-doc
-
-do_stage () {
-        autotools_stage_all
-}
+inherit autotools_stage pkgconfig gtk-doc
 
index 0545571b44ea5033b75df66701e0fb65e6b5e321..bbecee548c84bd643160115967b2195cf9fbac6f 100644 (file)
@@ -9,9 +9,5 @@ FILESPATH = "${FILE_DIRNAME}/clutter-gtk"
 PACKAGES =+ "${PN}-examples"
 FILES_${PN}-examples = "${bindir}/gtk-clutter-test ${bindir}/gtk-clutter-events ${bindir}/gtk-clutter-multistage"
 
-inherit autotools pkgconfig gtk-doc
-
-do_stage () {
-        autotools_stage_all
-}
+inherit autotools_stage pkgconfig gtk-doc
 
index 6e0612ad3a80a382c116b2ecc19f59597ccd5159..7b171856129d0c682dc4f93358c84dadd98ce0a1 100644 (file)
@@ -9,9 +9,5 @@ FILESPATH = "${FILE_DIRNAME}/clutter-helix"
 PACKAGES =+ "${PN}-examples"
 FILES_${PN}-examples = "${bindir}/video-player ${bindir}/audio-player"
 
-inherit autotools pkgconfig gtk-doc
-
-do_stage () {
-        autotools_stage_all
-}
+inherit autotools_stage pkgconfig gtk-doc
 
index 1caa1c74e952484d6c2f20b870779abb166f2b2f..7e9f99269ed92d0c99851e1122feeb552710b1a6 100644 (file)
@@ -45,7 +45,7 @@ PACKAGE_ARCH_menlow = "${MACHINE_ARCH}"
 
 FILESPATH = "${FILE_DIRNAME}/clutter"
 
-inherit autotools pkgconfig gtk-doc
+inherit autotools_stage pkgconfig gtk-doc
 
 PACKAGES =+ "clutter-examples"
 FILES_clutter-examples = "${bindir}/test-* ${pkgdatadir}/redhand.png"
@@ -58,7 +58,3 @@ do_configure_prepend() {
         sed -i s:doc/reference/Makefile::g ${S}/configure.ac
         sed -i s:doc::g ${S}/Makefile.am
 }
-
-do_stage () {
-        autotools_stage_all
-}
index b07b39dc1e62425f8b9f5237c070a17d922670d2..6a5b32ccdaaa63abc6678eb84517b531eb173c1d 100644 (file)
@@ -4,14 +4,10 @@ LICENSE = "LGPL"
 
 DEPENDS = "clutter-gst-0.6 gnome-vfs"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 do_install() {
        install -d ${D}${bindir}
        install -m 0755 ${S}/table ${D}${bindir}/table
 }
 
-#do_stage () {
-#        autotools_stage_all
-#}
-
index d1f11976cdae79ec1e7f04ed3652dfe5b4c0b0fb..14ec4ca9a8982c7db4afa7108fd34db7f463b724 100644 (file)
@@ -8,7 +8,7 @@ BASE_CONF = "--disable-gtk-doc"
 DEPENDS = "${STDDEPENDS}"
 EXTRA_OECONF = "${BASE_CONF}"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 PACKAGES =+ "tidy-examples"
 FILES_tidy-examples = "${bindir}/test-*"
@@ -18,7 +18,3 @@ do_configure_prepend() {
         sed -i s:docs/reference/Makefile::g ${S}/configure.ac
         sed -i s:docs::g ${S}/Makefile.am
 }
-
-do_stage () {
-        autotools_stage_all
-}
index e8ad21ef9866e973c832d55dd694d2044121b8ad..5175f45522b87f36d7f13fa6b643c5804abf6656 100644 (file)
@@ -18,7 +18,7 @@ SRC_URI  = "git://moblin.org/repos/projects/connman.git;protocol=http \
 INITSCRIPT_NAME = "connman"
 INITSCRIPT_PARAMS = "defaults 22"
 
-inherit autotools pkgconfig update-rc.d
+inherit autotools_stage pkgconfig update-rc.d
 
 do_install_append() {
     install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
@@ -42,7 +42,3 @@ python populate_packages_prepend() {
        plugin_name = bb.data.expand('${PN}-plugin-%s', d)
        do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='' )
 }
-
-do_stage() {
-    autotools_stage_all
-}
index d5e716014f5b077d9638d3e67a5ac261c52d1e70..29b3c4cbf8a90c712ee41cb93e258b76e02e74da 100644 (file)
@@ -4,8 +4,4 @@ SRC_URI = "http://dri.freedesktop.org/libdrm/libdrm-${PV}.tar.bz2"
 PROVIDES = "drm"
 DEPENDS = "libpthread-stubs"
 
-inherit autotools pkgconfig
-
-do_stage() {
-       autotools_stage_all
-}
+inherit autotools_stage pkgconfig
index 27d913c8d73e865824ebbbd23632e6b63e9dc91d..4765894b37ad462908805d917f959c41536015e0 100644 (file)
@@ -12,8 +12,4 @@ PV = "2.4.0+git${SRCREV}"
 
 LEAD_SONAME = "libdrm.so"
 
-inherit autotools pkgconfig
-
-do_stage() {
-       autotools_stage_all
-}
+inherit autotools_stage pkgconfig
index 424194fd19759bff79d4f87291703e1bb6f0b0c6..76694ce5a67a39ff3c2135cffc9f43c9e0629629 100644 (file)
@@ -11,7 +11,7 @@ SRC_URI = "http://ftp.gnome.org/pub/GNOME/mobile/2.23/2.23.92/sources/evolution-
 
 S = "${WORKDIR}/evolution-data-server-dbus-${PV}"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 # -ldb needs this on some platforms
 LDFLAGS += "-lpthread"
@@ -20,10 +20,6 @@ do_configure_append () {
         cp ${WORKDIR}/iconv-detect.h ${S}
 }
 
-do_stage () {
-        autotools_stage_all
-}
-
 EXTRA_OECONF = "--without-openldap --with-dbus --without-bug-buddy \
                 --with-soup --with-libdb=${STAGING_DIR_HOST}${layout_prefix} \
                 --disable-smime --disable-nss --disable-nntp --disable-gtk-doc"
index 81d9e83cfb7b938f6d41f768bfa6068c64539610..83b875bd432edde0df9306d7df580ee3ba27ddeb 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
 
 S = "${WORKDIR}/trunk"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 # -ldb needs this on some platforms
 LDFLAGS += "-lpthread"
@@ -22,10 +22,6 @@ do_configure_append () {
         cp ${WORKDIR}/iconv-detect.h ${S}
 }
 
-do_stage () {
-        autotools_stage_all
-}
-
 EXTRA_OECONF = "--without-openldap --with-dbus --without-bug-buddy \
                 --with-soup --with-libdb=${STAGING_DIR_HOST}${layout_prefix} \
                 --disable-smime --disable-nss --disable-nntp --disable-gtk-doc"
index a98c68009ea400098eb14b864c031e6c20630364..c26228a364ac5150f98bfb444fad6863f8332e4e 100644 (file)
@@ -9,14 +9,10 @@ SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
            file://filesystems"
 S = "${WORKDIR}/file-${PV}"
 
-inherit autotools
+inherit autotools_stage
 
 do_configure_prepend() {
        sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
        cp ${WORKDIR}/dump ${S}/magic/Magdir/
        cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
 }
-
-do_stage() {
-       autotools_stage_all
-}
index 167f044f627d3edd5cef5bf62c50ec6883bf1b5f..d4dd3aaba3deca60bd73504433c5d4fe9cdc7455 100644 (file)
@@ -7,10 +7,6 @@ SRC_URI =      "http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz
                  file://pkgconfig.patch;patch=1 "
 PR = "r1"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 EXTRA_OECONF = "--disable-tests --disable-check"
-
-do_stage() {
-       autotools_stage_all
-}
index 71ea128bc51722967e89aca705cb64e75e94e263..2f99c2f1fda87266584e32a92b8cd396c94301db 100644 (file)
@@ -7,12 +7,8 @@ SRC_URI = "ftp://ftp.gnu.org/gnu/gmp/gmp-${PV}.tar.bz2 \
           file://configure.patch;patch=1 \
           file://amd64.patch;patch=1"
 
-inherit autotools 
+inherit autotools_stage
 
 ARM_INSTRUCTION_SET = "arm"
 
 acpaths = ""
-
-do_stage () {
-       autotools_stage_all
-}
index c18d9f19f4ed088f51343c3fe4aa006d25b6e8a7..fb0f641a4220d75fec17d578fc6cb9d66865b1e4 100644 (file)
@@ -3,7 +3,7 @@ SECTION = "x11/gnome"
 
 PR = "r1"
 
-inherit autotools gnome pkgconfig
+inherit autotools_stage gnome pkgconfig
 
 DEPENDS = "gtk+ libgcrypt"
 
@@ -17,7 +17,3 @@ do_install_append () {
 }
 
 FILES_${PN} += "${datadir}/dbus-1/services"
-
-do_stage() {
-        autotools_stage_all
-}
index 5e59bd660c37a19545c4007eae3774731175dbea..6039d6133d12e9a421af9d9fb173109ca9bee8af 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gsm;proto=http \
            file://default"
 S = "${WORKDIR}/gsm"
 
-inherit autotools pkgconfig update-rc.d
+inherit autotools_stage pkgconfig update-rc.d
 # handle update-rc.d RDEPENDS manually, we don't need it on
 # anything but gsmd
 RDEPENDS_append = ""
@@ -21,10 +21,6 @@ RDEPENDS_append = ""
 INITSCRIPT_NAME = "gsmd"
 INITSCRIPT_PARAMS = "defaults 35"
 
-do_stage() {
-    autotools_stage_all
-}
-
 do_install_append() {
        install -d ${D}/${sysconfdir}/init.d
        install -m 0755 ${WORKDIR}/gsmd ${D}/${sysconfdir}/init.d/
index 85775391ea2956a6172b803edc0100f04459e194..94cb9310d7babb3bb6e6da074a8ec68593ef5f8a 100644 (file)
@@ -3,7 +3,7 @@ SECTION = "multimedia"
 PRIORITY = "optional"
 DEPENDS = "gstreamer"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2"
 
@@ -27,8 +27,4 @@ python populate_packages_prepend () {
        do_split_packages(d, gst_libdir, 'libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)', extra_depends=bb.data.expand('${PN}-dev',d))
 }
 
-do_stage() {
-       autotools_stage_all
-}
-
 ALLOW_EMPTY = "1"
index 32f6523b2a45d18c128acb9ce6817444fafcc942..512df0b4bd61bcb36c7e6f89bc4f78e82b58b21e 100644 (file)
@@ -7,7 +7,7 @@ HOMEPAGE = "http://www.gstreamer.net/"
 DEPENDS = "glib-2.0 gettext-native libxml2 bison-native flex-native"
 PR = "r1"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \
            file://gst-inspect-check-error.patch;patch=1 \
@@ -26,10 +26,6 @@ do_configure_prepend() {
 
 PARALLEL_MAKE = ""
 
-do_stage() {
-       autotools_stage_all
-}
-
 FILES_${PN} += " ${libdir}/gstreamer-0.10/*.so"
 FILES_${PN}-dev += " ${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
 FILES_${PN}-dbg += " ${libdir}/gstreamer-0.10/.debug/"
index 034d2f5fe3c318bacda8976e3e381952cc5c836e..09e12e2c63a7201e905c3849c98c807d35537b79 100644 (file)
@@ -3,12 +3,8 @@ DEPENDS = "glib-2.0 libsoup-2.4 libglade"
 
 SRC_URI = "http://gupnp.org/sources/${PN}/${PN}-${PV}.tar.gz"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 PACKAGES =+ "gssdp-tools"
 
 FILES_gssdp-tools = "${bindir}/gssdp* ${datadir}/gssdp/*.glade"
-
-do_stage() {
-       autotools_stage_all
-}
index e1a0206d907406ab2fd9aaa0f2ef376579fa13fc..2b615f0602ef527efd4c4779a63f39d1a7654528 100644 (file)
@@ -3,12 +3,7 @@ DEPENDS = "e2fsprogs gssdp libsoup-2.4 libxml2"
 
 SRC_URI = "http://gupnp.org/sources/${PN}/${PN}-${PV}.tar.gz"
 
-inherit autotools pkgconfig
-
-do_stage() {
-       autotools_stage_all
-}
-
+inherit autotools_stage pkgconfig
 
 FILES_${PN} = "${libdir}/*.so.*"
 FILES_${PN}-dev += "${bindir}/gupnp-binding-tool"
index 456d9fb6a5aca0774c8d665badd8920d992af24a..82978029c8123d9503489a62d79b415a1abedbfb 100644 (file)
@@ -3,7 +3,7 @@ LICENSE = "GPL"
 SECTION = "x11"
 DEPENDS = "glib-2.0 dbus bluez-libs dbus-glib"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 EXTRA_OECONF += "--with-distro=debian"
 
index 68a07ffcd715003757e2551b1b9b851abd57f8f3..4301e8275d430641d260e6c4c0360211f02aa6cc 100644 (file)
@@ -5,6 +5,6 @@ DEPENDS = "glib-2.0 dbus bluez-libs dbus-glib libxslt"
 
 SRC_URI = "http://gypsy.freedesktop.org/gypsy-releases/gypsy-${PV}.tar.gz" 
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 FILES_${PN} += "/usr/share/dbus-1/services/"
index 04fc8420abf6ad68825f01635605525e53004721..1c7eda21e21289260b000ae9860c1af0268b42ce 100644 (file)
@@ -7,7 +7,7 @@ S = "${WORKDIR}/icu/source"
 
 PARALLEL_MAKE = ""
 
-inherit autotools pkgconfig binconfig
+inherit autotools_stage pkgconfig binconfig
 
 do_configure() {
        libtoolize --force
index 5760ddb2bc2fd10175be389440830603f80811c1..5b341470ff8501b6ffe7331f4ce7a6daa8d06ef0 100644 (file)
@@ -34,8 +34,4 @@ FILES_libiculx = "${libdir}/libiculx.so.*"
 FILES_libicutu = "${libdir}/libicutu.so.*"
 FILES_libicuio = "${libdir}/libicuio.so.*"
 
-do_stage() {
-        autotools_stage_all
-}      
-
 
index 98425111d58c598e682dfff659412b5cc3b96fe0..50ea791926001e7b33c23e6415adab2b051b077a 100644 (file)
@@ -7,13 +7,8 @@ PACKAGE_ARCH = "all"
 
 SRC_URI = "ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/iso-codes-${PV}.tar.gz"
 
-inherit autotools
+inherit autotools_stage
 
 FILES_${PN}-dev="${datadir}/pkgconfig/iso-codes.pc"
 FILES_${PN}="${datadir}/xml/iso-codes/ \
              ${datadir}/iso-codes/"
-
-do_stage() {
-        autotools_stage_all
-}
-
index 7ad0f54f2ccbdc26a64e0f5ca8efb7619bd88a1d..6a20560c076e152e3af5e482ee6a3dd4a56c7c68 100644 (file)
@@ -9,15 +9,11 @@ PR = "r1"
 SRC_URI = "${SOURCEFORGE_MIRROR}/libetpan/libetpan-${PV}.tar.gz \
            file://cxx-is-here.patch;patch=1"
 
-inherit autotools pkgconfig gettext binconfig
+inherit autotools_stage pkgconfig gettext binconfig
 
 EXTRA_OECONF = "--without-openssl --with-gnutls --disable-db"
 
 PARALLEL_MAKE = ""
 
-do_stage() {
-       autotools_stage_all
-}
-
 FILES_${PN} = "${libdir}/lib*.so.*"
 FILES_${PN}-dev = "${bindir} ${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libdir}/pkgconfig"
index 2f896352db4221d521f513fad49e9b2b3ce02cd0..0be23df60b3ae4ca051b463906d64a62a8ec124e 100644 (file)
@@ -5,14 +5,10 @@ LICENSE = "LGPL"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.bz2"
 
-inherit autotools 
+inherit autotools_stage
 
 do_configure_append() {
        sed -i s:doc\ binary:binary:g Makefile
 }
 
 AUTOTOOLS_STAGE_PKGCONFIG = "1"
-
-do_stage() {
-       autotools_stage_all
-}
index 5fe2b4912197f6f144a548bb11d07601a4b1b04a..ccbb4b7066584d9434a4c7aa953f521ff3cfe2cb 100644 (file)
@@ -7,16 +7,12 @@ DEPENDS = "libgpg-error"
 SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz \
            file://add-pkgconfig-support.patch;patch=1"
 
-inherit autotools binconfig pkgconfig
+inherit autotools_stage binconfig pkgconfig
 
 EXTRA_OECONF = "--without-pth --disable-asm --with-capabilities"
 
 ARM_INSTRUCTION_SET = "arm"
 
-do_stage() {
-       autotools_stage_all
-}
-
 # move libgcrypt-config into -dev package
 FILES_${PN} = "${libdir}/lib*.so.*"
 FILES_${PN}-dev += "${bindir} ${libdir}/pkgconfig/*.pc"
index 30cffe39977b52752af26650960dee76d922e0f6..d29afa546c86b4d63f81b6ccbb1cb304178a2629 100644 (file)
@@ -7,8 +7,4 @@ S        = "${WORKDIR}/git"
 
 SRC_URI  = "git://moblin.org/repos/projects/libgdbus.git;protocol=http"
 
-inherit autotools pkgconfig
-
-do_stage() {
-    autotools_stage_all
-}
+inherit autotools_stage pkgconfig
index 85b533044d53141f4ee227d52391d9d9ad5ec610..14c3f6acc3ff37bc1fd81e6f3ff793b3d6960b09 100644 (file)
@@ -6,17 +6,13 @@ DEPENDS = "libxml2 sed-native expat"
 SRC_URI = "${SOURCEFORGE_MIRROR}/wbxmllib/${P}.tar.gz \
           file://no-doc-install.patch;patch=1"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 do_configure_append() {
        sed -i s:-I/usr/include::g Makefile
        sed -i s:-I/usr/include::g */Makefile
 }
 
-do_stage() {
-       autotools_stage_all
-}
-
 PACKAGES += "${PN}-tools"
 
 FILES_${PN}-tools = "${bindir}"
index 3dd7f130298e69719619d5807377c86107e72984..a5765e84b106a00b8f325d3ef72a0d1b4af2d345 100644 (file)
@@ -23,7 +23,7 @@ SRC_URI = "\
 
 S = "${WORKDIR}/"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 EXTRA_OECONF = "\
                 --enable-debug=no \
@@ -48,10 +48,6 @@ do_compile_prepend() {
        cd ${S}
 }
 
-do_stage() {
-       autotools_stage_all
-}
-
 PACKAGES =+ "${PN}launcher-dbg ${PN}launcher libjavascriptcore"
 FILES_${PN}launcher = "${bindir}/GtkLauncher"
 FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
index 7f06f587c4a317042b8b81a014a07c5733a19791..6fdb0fe8c697f2f9f466266cc27431ef2ca87efe 100644 (file)
@@ -7,12 +7,8 @@ PR = "r3"
 SRC_URI = "${SOURCEFORGE_MIRROR}/wvware/wv-${PV}.tar.gz \
            file://pkgconfig.patch;patch=1"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 S = "${WORKDIR}/${PN}-${PV}"
 
 EXTRA_OECONF = ""
-
-do_stage () {
-       autotools_stage_all
-}
index 211170a902d995bca8c44d006b3613c1e22bc2ae..826bff767824f379fa30db6a3f71335f3deb9dfb 100644 (file)
@@ -11,11 +11,7 @@ PARALLEL_MAKE = ""
 
 SRC_URI = "http://xcb.freedesktop.org/dist/libpthread-stubs-${PV}.tar.bz2"
 
-inherit autotools pkgconfig
-
-do_stage() {
-       autotools_stage_all
-}
+inherit autotools_stage pkgconfig
 
 RDEPENDS_${PN}-dev = ""
 RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${DEBPV})"
index bdce8a2e6bf50340a017b3318542951c5cf82257..ee46f598c025edb046976be1318f556467a77048 100644 (file)
@@ -40,7 +40,7 @@ FILES_libxcb-xtest = "${libdir}/libxcb-xtest.so.*"
 FILES_libxcb-xv = "${libdir}/libxcb-xv.so.*"
 FILES_libxcb-xvmc = "${libdir}/libxcb-xvmc.so.*"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 # XCBPROTO_XCBINCLUDEDIR is setup based on `pkg-config --variable=xcbincludedir xcb-proto`
 # but the xcbincludedir variable doesn't point into the staging area, so it needs some
@@ -49,7 +49,3 @@ do_configure_prepend () {
     sed -i "s|XCBPROTO_XCBINCLUDEDIR=|XCBPROTO_XCBINCLUDEDIR=${STAGING_DIR_HOST}/|" \
         ${S}/configure.ac
 }
-
-do_stage() {
-       autotools_stage_all
-}
index cb448be243c9dc2b3ae469bddabb54c1d928e32c..19a08d7a31810e4e91f77b133e3148696883a94b 100644 (file)
@@ -6,11 +6,7 @@ PR = "r2"
 
 SRC_URI = "http://xlibs.freedesktop.org/xkbdesc/xkeyboard-config-${PV}.tar.bz2"
 
-inherit autotools
-
-do_stage() {
-        autotools_stage_all
-}
+inherit autotools_stage
 
 do_install_append () {
     install -d ${D}/usr/share/X11/xkb/compiled
index cd7f654be21194c1b1b340cc2f90f8551c46cbfc..2dc659a0faeeafa3c7f0f2e5029955bd8eaed4c1 100644 (file)
@@ -10,10 +10,6 @@ SRC_URI = "${XORG_MIRROR}/individual/app/${XORG_PN}-${PV}.tar.bz2"
 
 S = "${WORKDIR}/${XORG_PN}-${PV}"
 
-inherit autotools pkgconfig
-
-do_stage() {
-        autotools_stage_all
-}
+inherit autotools_stage pkgconfig
 
 FILES_${PN} += "  /usr/lib/X11/${XORG_PN}"
index 308d06e0b15f317944f152dbdaefa889b2050869..3cb8cd021e575f4839f892c4e9676288df3213f3 100644 (file)
@@ -16,11 +16,7 @@ S = "${WORKDIR}/${XORG_PN}-${PV}"
 FILES_${PN} += " ${libdir}/xorg/modules/drivers/*.so"
 FILES_${PN}-dbg += " ${libdir}/xorg/modules/drivers/.debug"
 
-inherit autotools pkgconfig
-
-do_stage() {
-       autotools_stage_all
-}
+inherit autotools_stage pkgconfig
 
 # AC_CHECK_FILE doesn't work when cross compiling, so we create a replacement
 # macro that simply assumes the test succeeds. 
index eae0e92a8d5bd3fbe784a2253483227d419ce3c0..66b453f67f3981038014ffdd723abcf62041b2c1 100644 (file)
@@ -9,10 +9,6 @@ SRC_URI = "${XORG_MIRROR}/individual/lib/${XORG_PN}-${PV}.tar.bz2"
 
 S = "${WORKDIR}/${XORG_PN}-${PV}"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 EXTRA_OECONF = "--enable-malloc0returnsnull"
-
-do_stage() {
-        autotools_stage_all
-}
index c7188a766a412b9d4ce8235de5a5d5ee0ddeb2b5..e70afd02bff0caac569389d2712fe98236c31eb3 100644 (file)
@@ -9,12 +9,8 @@ SRC_URI = "${XORG_MIRROR}/individual/proto/${XORG_PN}-${PV}.tar.bz2"
 
 S = "${WORKDIR}/${XORG_PN}-${PV}"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 # ${PN} is empty so we need to tweak -dev and -dbg package dependencies
 RDEPENDS_${PN}-dev = ""
 RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${DEBPV})"
-
-do_stage() {
-        autotools_stage_all
-}
index 56aae30725d3ffcf2cf727e0ee7b291baa7b8332..e8a9d01d157a750f8e894bcc787527ac228cac8e 100644 (file)
@@ -8,8 +8,4 @@ SRC_URI = "${XORG_MIRROR}/individual/util/${XORG_PN}-${PV}.tar.gz"
 
 S = "${WORKDIR}/${XORG_PN}-${PV}"
 
-inherit autotools pkgconfig
-
-do_stage() {
-        autotools_stage_all
-}
+inherit autotools_stage pkgconfig
index d31e97a0e2a97db77c2f569255277e4a55ba4edc..5a10ecf994d5371e5f98948ad7cd8ada7bb7ac7c 100644 (file)
@@ -16,7 +16,7 @@ SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2 \
 
 S = "${WORKDIR}/${XORG_PN}-${PV}"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 PACKAGES =+ "${PN}-utils"
 
@@ -33,10 +33,6 @@ CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
 
 SRC_URI += "file://macro_tweak.patch;patch=1"
 
-do_stage() {
-       autotools_stage_all
-}
-
 do_install_append () {
        install -d ${D}/${sysconfdir}/X11
        install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/