]> code.ossystems Code Review - openembedded-core.git/commitdiff
guilt-native: eliminate hardcoded "/usr" in do_install
authorPhil Blundell <pb@pbcl.net>
Tue, 17 May 2011 10:34:14 +0000 (11:34 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 May 2011 14:00:38 +0000 (15:00 +0100)
For some reason guilt-native seems to have gone out of its way to refer explicitly to /usr, which breaks on micro.
Let's use ${prefix} instead.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/guilt/guilt-native_0.33.bb

index 62613306855a6c84b58d4e40c11c83defeb7208a..7d0246e33727e001e14b415fb2b16ffd0cb48d4f 100644 (file)
@@ -28,5 +28,5 @@ do_compile() {
 }
 
 do_install() {
-       oe_runmake PREFIX=${D}/${base_prefix}/usr install
+       oe_runmake PREFIX=${D}/${prefix} install
 }