]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg-utils: re-do find/ls code to not fail on filenames with spaces
authorDenys Dmytriyenko <denys@ti.com>
Fri, 8 Apr 2016 04:57:08 +0000 (00:57 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 8 Apr 2016 06:55:15 +0000 (07:55 +0100)
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-build-re-do-find-ls-code-to-not-fail-on-filenam.patch [new file with mode: 0644]
meta/recipes-devtools/opkg-utils/opkg-utils_git.bb

diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-build-re-do-find-ls-code-to-not-fail-on-filenam.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-build-re-do-find-ls-code-to-not-fail-on-filenam.patch
new file mode 100644 (file)
index 0000000..5cbb55a
--- /dev/null
@@ -0,0 +1,56 @@
+From 8e424296ce2af4a5a7392c38a31f8723f9b9fbda Mon Sep 17 00:00:00 2001
+From: Denys Dmytriyenko <denys@ti.com>
+Date: Thu, 7 Apr 2016 20:43:13 -0400
+Subject: [PATCH] opkg-build: re-do find/ls code to not fail on filenames with
+ spaces
+
+Signed-off-by: Denys Dmytriyenko <denys@ti.com>
+---
+ opkg-build | 9 ++++-----
+ 1 file changed, 4 insertions(+), 5 deletions(-)
+
+diff --git a/opkg-build b/opkg-build
+index a9ccad2..07305b2 100755
+--- a/opkg-build
++++ b/opkg-build
+@@ -6,7 +6,6 @@
+ # 2003-04-25 rea@sr.unh.edu
+ #   Updated to work on Familiar Pre0.7rc1, with busybox tar.
+ #   Note it Requires: binutils-ar (since the busybox ar can't create)
+-#   For UID debugging it needs a better "find".
+ set -e
+ version=1.0
+@@ -47,12 +46,12 @@ pkg_appears_sane() {
+       PKG_ERROR=0
+-      tilde_files=`find . -name '*~'`
++      tilde_files=`find . -name '*~' -ls -printf '\\\n'`
+       if [ -n "$tilde_files" ]; then
+           if [ "$noclean" = "1" ]; then
+               echo "*** Warning: The following files have names ending in '~'.
+ You probably want to remove them: " >&2
+-              ls -ld $tilde_files
++              echo -e $tilde_files
+               if [ $? -ne 0 ]; then
+                       echo "*** Error: Fail to list files have names ending in '~'."
+                       exit 1
+@@ -64,12 +63,12 @@ You probably want to remove them: " >&2
+           fi
+       fi
+-      large_uid_files=`find . -uid +99 || true`
++      large_uid_files=`find . -uid +99 -ls -printf '\\\n' || true`
+       if [ "$ogargs" = "" ]  && [ -n "$large_uid_files" ]; then
+               echo "*** Warning: The following files have a UID greater than 99.
+ You probably want to chown these to a system user: " >&2
+-              ls -ld $large_uid_files
++              echo -e $large_uid_files
+               if [ $? -ne 0 ]; then
+                       echo "*** Error: Fail to list files have a UID greater than 99."
+                       exit 1
+-- 
+2.2.0
+
index 22f45a1d8d8782d23a289cf25d6f598299f655d4..8873b28701e1faff78727481ef8fc44ca98cf22d 100644 (file)
@@ -11,7 +11,8 @@ SRCREV = "53274f087565fd45d8452c5367997ba6a682a37a"
 PV = "0.1.8+git${SRCPV}"
 
 SRC_URI = "git://git.yoctoproject.org/opkg-utils \
-           file://opkg-build-Exit-when-fail-to-list-files.patch"
+           file://opkg-build-Exit-when-fail-to-list-files.patch \
+           file://0001-opkg-build-re-do-find-ls-code-to-not-fail-on-filenam.patch"
 SRC_URI_append_class-native = " file://tar_ignore_error.patch"
 
 S = "${WORKDIR}/git"