]> code.ossystems Code Review - openembedded-core.git/commitdiff
libaio: refresh patches
authorRoss Burton <ross.burton@intel.com>
Wed, 15 Nov 2017 16:45:41 +0000 (16:45 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 7 Mar 2018 14:33:58 +0000 (06:33 -0800)
The patch tool will apply patches by default with "fuzz", which is where if the
hunk context isn't present but what is there is close enough, it will force the
patch in.

Whilst this is useful when there's just whitespace changes, when applied to
source it is possible for a patch applied with fuzz to produce broken code which
still compiles (see #10450).  This is obviously bad.

We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For
that to be realistic the existing patches with fuzz need to be rebased and
reviewed.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/libaio/libaio/destdir.patch

index dad9601c496b911cf84dc3afc79298a8ce2a670f..0f90406bee56fbc4d64f327ea462ece99416fafd 100644 (file)
@@ -2,16 +2,16 @@ Upstream-Status: Pending
 
 from openembedded, added by Qing He <qing.he@intel.com>
 
-Index: libaio-0.3.106/Makefile
+Index: libaio-0.3.110/Makefile
 ===================================================================
---- libaio-0.3.106.orig/Makefile       2004-02-26 07:25:10.000000000 -0800
-+++ libaio-0.3.106/Makefile    2006-10-14 09:19:07.000000000 -0700
-@@ -15,7 +15,7 @@
+--- libaio-0.3.110.orig/Makefile
++++ libaio-0.3.110/Makefile
+@@ -15,7 +15,7 @@ all:
        @$(MAKE) -C src
  
  install:
 -      @$(MAKE) -C src install prefix=$(prefix) includedir=$(includedir) libdir=$(libdir)
 +      @$(MAKE) -C src install prefix=$(DESTDIR)$(prefix) includedir=$(DESTDIR)$(includedir) libdir=$(DESTDIR)$(libdir)
  
- clean:
+ check:
+       @$(MAKE) -C harness check