]> code.ossystems Code Review - openembedded-core.git/commitdiff
at: use snapshot.debian.org for SRC_URI
authorTim Orling <timothy.t.orling@linux.intel.com>
Wed, 27 Jul 2016 18:04:36 +0000 (11:04 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 1 Aug 2016 11:14:11 +0000 (12:14 +0100)
[YOCTO #10005] Krogoth-next checkuri failures

Using ${DEBIAN_MIRROR} for SRC_URI doesn't work very well as that will only
contain releases that are currently in Debian, so currently doesn't contain
3.1.18 as unstable has moved on to 3.1.20.

So, move all of SRC_URI to the .bb so it can use snapshot.debian.org instead,
and set UPSTREAM_CHECK_URI to ${DEBIAN_MIRROR} so upstream release checking
continues to work.

Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-extended/at/at_3.1.18.bb

index 93044f53e20f3a848e5fce615f6565a05f4a34c3..f533f3c7802adf507d2b403d595bd141512df007 100644 (file)
@@ -15,7 +15,7 @@ PAM_DEPS = "libpam libpam-runtime pam-plugin-env pam-plugin-limits"
 RCONFLICTS_${PN} = "atd"
 RREPLACES_${PN} = "atd"
 
-SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz;subdir=${BP} \
+SRC_URI += "http://snapshot.debian.org/archive/debian/20160509T100042Z/pool/main/a/${BPN}/${BPN}_${PV}.orig.tar.gz;subdir=${BP} \
     file://fix_parallel_build_error.patch \
     file://posixtm.c \
     file://posixtm.h \
@@ -28,6 +28,8 @@ SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz;subdir=${BP} \
     file://configure-fix-with-without-selinux.patch \
     "
 
+UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/a/at/"
+
 PAM_SRC_URI = "file://pam.conf.patch \
                file://configure-add-enable-pam.patch"