]> code.ossystems Code Review - openembedded-core.git/commitdiff
intltool: Allow nativesdk variant to build
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 11 Jan 2017 01:08:11 +0000 (01:08 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 19 Jan 2017 22:45:54 +0000 (22:45 +0000)
This tool has been missing from the SDKs, the recipe specific sysroot
work highlighted the issues.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/intltool/intltool_0.51.0.bb

index a7ea3b727dc5eca2383963239d19dddf7a491b24..551bdf0619a24a87df950e59348dce9fffcdcb2d 100644 (file)
@@ -22,6 +22,7 @@ inherit autotools pkgconfig perlnative
 
 export PERL = "${bindir}/env perl"
 PERL_class-native = "/usr/bin/env nativeperl"
+PERL_class-nativesdk = "/usr/bin/env perl"
 
 # gettext is assumed to exist on the host
 RDEPENDS_${PN}_class-native = "libxml-parser-perl-native"
@@ -33,4 +34,4 @@ FILES_${PN} += "${datadir}/aclocal"
 
 INSANE_SKIP_${PN} += "dev-deps"
 
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"