]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: properly disable perl file dependency checking for rpmdeps
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Fri, 25 Jan 2013 11:28:57 +0000 (11:28 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 25 Jan 2013 12:35:24 +0000 (12:35 +0000)
We don't want the perl module dependencies being added to each package
by rpmdeps because it causes too many problems when the modules aren't
available at install time (since they get added in do_package which is
too late for the build system to ensure they are available), and it
appears that the perl dependency gathering isn't working reliably in any
case judging by how they are detected on some build hosts and not
others.

This was being disabled previously but it seems like the macros moved
to a different file at some point and nobody noticed; thus make sure we
disable the macros in all RPM macro files.

Should fix [YOCTO #3699].

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rpm/rpm_5.4.9.bb

index c916a42d5e41b747c886c4d03c264b2daf9c1b18..6977131a28392260695d181bb091edbc05033a96 100644 (file)
@@ -373,8 +373,8 @@ do_configure() {
 do_install_append() {
        sed -i -e 's,%__check_files,#%%__check_files,' ${D}/${libdir}/rpm/macros
        sed -i -e 's,%__scriptlet_requires,#%%__scriptlet_requires,' ${D}/${libdir}/rpm/macros
-       sed -i -e 's,%__perl_provides,#%%__perl_provides,' ${D}/${libdir}/rpm/macros
-       sed -i -e 's,%__perl_requires,#%%__perl_requires,' ${D}/${libdir}/rpm/macros
+       sed -i -e 's,%__perl_provides,#%%__perl_provides,' ${D}/${libdir}/rpm/macros ${D}/${libdir}/rpm/macros.d/*
+       sed -i -e 's,%__perl_requires,#%%__perl_requires,' ${D}/${libdir}/rpm/macros ${D}/${libdir}/rpm/macros.d/*
        sed -i -e 's,%_repackage_all_erasures[^_].*,%_repackage_all_erasures 0,' ${D}/${libdir}/rpm/macros
        sed -i -e 's,^#%_openall_before_chroot.*,%_openall_before_chroot\t1,' ${D}/${libdir}/rpm/macros