]> code.ossystems Code Review - openembedded-core.git/commitdiff
mtd-utils: update to version to 1.4.6
authorDenis Carikli <denis@eukrea.com>
Fri, 2 Sep 2011 14:07:32 +0000 (16:07 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 7 Sep 2011 21:28:33 +0000 (22:28 +0100)
mtd-utils 1.4.6 is the lastest release of mtd-utils
  at this time.

Signed-off-by: Denis Carikli <denis@eukrea.com>
meta/recipes-devtools/mtd/mtd-utils-1.4.6/add-exclusion-to-mkfs-jffs2-git-2.patch [moved from meta/recipes-devtools/mtd/mtd-utils-1.4.1/add-exclusion-to-mkfs-jffs2-git-2.patch with 100% similarity]
meta/recipes-devtools/mtd/mtd-utils-1.4.6/mtd-utils-1.4.1/add-exclusion-to-mkfs-jffs2-git-2.patch [new file with mode: 0644]
meta/recipes-devtools/mtd/mtd-utils_1.4.6.bb [moved from meta/recipes-devtools/mtd/mtd-utils_1.4.1.bb with 81% similarity]

diff --git a/meta/recipes-devtools/mtd/mtd-utils-1.4.6/mtd-utils-1.4.1/add-exclusion-to-mkfs-jffs2-git-2.patch b/meta/recipes-devtools/mtd/mtd-utils-1.4.6/mtd-utils-1.4.1/add-exclusion-to-mkfs-jffs2-git-2.patch
new file mode 100644 (file)
index 0000000..57d6a30
--- /dev/null
@@ -0,0 +1,103 @@
+Upstream-Status: Pending
+
+--- /tmp/mkfs.jffs2.c  2009-01-11 15:28:41.000000000 +0100
++++ git/mkfs.jffs2.c   2009-01-11 15:59:29.000000000 +0100
+@@ -100,6 +100,11 @@
+       struct rb_node hardlink_rb;
+ };
++struct ignorepath_entry {
++      struct ignorepath_entry* next;  /* Points to the next ignorepath element */
++      char name[PATH_MAX];        /* Name of the entry */
++};
++static struct ignorepath_entry* ignorepath = 0;
+ struct rb_root hardlinks;
+ static int out_fd = -1;
+ static int in_fd = -1;
+@@ -408,7 +413,7 @@
+       char *hpath, *tpath;
+       struct dirent *dp, **namelist;
+       struct filesystem_entry *entry;
+-
++      struct ignorepath_entry* element = ignorepath;
+       if (lstat(hostpath, &sb)) {
+               perror_msg_and_die("%s", hostpath);
+@@ -417,6 +422,15 @@
+       entry = add_host_filesystem_entry(targetpath, hostpath,
+                       sb.st_uid, sb.st_gid, sb.st_mode, 0, parent);
++      while ( element ) {
++              if ( strcmp( element->name, targetpath ) == 0 ) {
++                      printf( "Note: ignoring directories below '%s'\n", targetpath );
++                      return entry;
++                      break;
++              }
++              element = element->next;
++      }
++
+       n = scandir(hostpath, &namelist, 0, alphasort);
+       if (n < 0) {
+               perror_msg_and_die("opening directory %s", hostpath);
+@@ -1453,6 +1467,7 @@
+       {"root", 1, NULL, 'r'},
+       {"pagesize", 1, NULL, 's'},
+       {"eraseblock", 1, NULL, 'e'},
++      {"ignore", 1, NULL, 'I'},
+       {"output", 1, NULL, 'o'},
+       {"help", 0, NULL, 'h'},
+       {"verbose", 0, NULL, 'v'},
+@@ -1500,6 +1515,7 @@
+ "  -L, --list-compressors  Show the list of the avaiable compressors\n"
+ "  -t, --test-compression  Call decompress and compare with the original (for test)\n"
+ "  -n, --no-cleanmarkers   Don't add a cleanmarker to every eraseblock\n"
++"  -I, --ignore=PATH       Ignore sub directory and file tree below PATH when recursing over the file system\n"
+ "  -o, --output=FILE       Output to FILE (default: stdout)\n"
+ "  -l, --little-endian     Create a little-endian filesystem\n"
+ "  -b, --big-endian        Create a big-endian filesystem\n"
+@@ -1666,6 +1682,7 @@
+       char *compr_name = NULL;
+       int compr_prior  = -1;
+       int warn_page_size = 0;
++      struct ignorepath_entry* element = ignorepath;
+       page_size = sysconf(_SC_PAGESIZE);
+       if (page_size < 0) /* System doesn't know so ... */
+@@ -1676,7 +1693,7 @@
+       jffs2_compressors_init();
+       while ((opt = getopt_long(argc, argv,
+-                                      "D:d:r:s:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
++                                      "D:d:r:s:I:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
+       {
+               switch (opt) {
+                       case 'D':
+@@ -1700,6 +1717,28 @@
+                               warn_page_size = 0; /* set by user, so don't need to warn */
+                               break;
++                      case 'I':
++                              printf( "Note: Adding '%s' to ignore Path\n", optarg );
++                              element = ignorepath;
++                              if ( !ignorepath ) {
++                                      ignorepath = xmalloc( sizeof( struct ignorepath_entry ) );
++                                      ignorepath->next = 0;
++                                      strcpy( &ignorepath->name[0], optarg );
++                              } else {
++                                      while ( element->next ) element = element->next;
++                                      element->next = xmalloc( sizeof( struct ignorepath_entry ) );
++                                      element->next->next = 0;
++                                      strcpy( &element->next->name[0], optarg );
++                              }
++                              printf( "--------- Dumping ignore path list ----------------\n" );
++                              element = ignorepath;
++                              while ( element ) {
++                                      printf( "  * '%s'\n", &element->name[0] );
++                                      element = element->next;
++                              }
++                              printf( "---------------------------------------------------\n" );
++                              break;
++
+                       case 'o':
+                               if (out_fd != -1) {
+                                       error_msg_and_die("output filename specified more than once");
similarity index 81%
rename from meta/recipes-devtools/mtd/mtd-utils_1.4.1.bb
rename to meta/recipes-devtools/mtd/mtd-utils_1.4.6.bb
index c05149daf80f35c23893e93232d1c61ebf56b6da..79f4f155cb5943334d51aeb822c3150e2b0a354d 100644 (file)
@@ -6,12 +6,12 @@ LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
                     file://include/common.h;beginline=1;endline=17;md5=ba05b07912a44ea2bf81ce409380049c"
 
-SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=3c3674a6e1d3f59554b0ff68ca59be2fd4134e0c \
+SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=baafd8ace3301e9d2ba314a376bad008314b34ff \
                file://add-exclusion-to-mkfs-jffs2-git-2.patch"
 
 S = "${WORKDIR}/git/"
 
-PR = "r1"
+PR = "r0"
 
 EXTRA_OEMAKE = "'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'BUILDDIR=${S}'"
 
@@ -26,6 +26,3 @@ do_install () {
 PARALLEL_MAKE = ""
 
 BBCLASSEXTEND = "native"
-
-SRC_URI[md5sum] = "645519b753b364d52c4b941dcee3dd7e"
-SRC_URI[sha256sum] = "51d6a77c7e673219bb89c4b119f336d9f2f5a5e065a12ecf9636c5348d099a0e"