]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-xorg: Fix builds without glx 2021-04.2 2021-04.2-hardknott yocto-3.3.2
authorWadim Egorov <w.egorov@phytec.de>
Tue, 13 Jul 2021 12:29:30 +0000 (14:29 +0200)
committerAnuj Mittal <anuj.mittal@intel.com>
Tue, 13 Jul 2021 16:04:22 +0000 (00:04 +0800)
Signed-off-by: Wadim Egorov <w.egorov@phytec.de>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-graphics/xorg-xserver/xserver-xorg/0001-hw-xwayland-Makefile.am-fix-build-without-glx.patch [new file with mode: 0644]
meta/recipes-graphics/xorg-xserver/xserver-xorg_1.20.10.bb

diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xorg/0001-hw-xwayland-Makefile.am-fix-build-without-glx.patch b/meta/recipes-graphics/xorg-xserver/xserver-xorg/0001-hw-xwayland-Makefile.am-fix-build-without-glx.patch
new file mode 100644 (file)
index 0000000..4c9cb0e
--- /dev/null
@@ -0,0 +1,46 @@
+From 836f93de99b35050d78d61d3654f7c5655184144 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Fri, 19 Apr 2019 10:19:50 +0200
+Subject: [PATCH] hw/xwayland/Makefile.am: fix build without glx
+
+Commit d8ec33fe0542141aed1d9016d2ecaf52da944b4b added libglxvnd.la to
+Xwayland_LDFLAGS but GLX can be disabled through --disable-glx.
+In this case, build fails on:
+
+make[3]: *** No rule to make target '../../glx/libglxvnd.la', needed by 'Xwayland'.  Stop.
+make[3]: *** Waiting for unfinished jobs....
+
+Fixes:
+ - http://autobuild.buildroot.org/results/397f8098c57fc6c88aa12dc8d35ebb1b933d52ef
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+
+Upstream-Status: Backport [https://gitlab.freedesktop.org/xorg/xserver/-/commit/836f93de99b35050d78d61d3654f7c5655184144]
+Signed-off-by: Wadim Egorov <w.egorov@phytec.de>
+---
+ hw/xwayland/Makefile.am | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/hw/xwayland/Makefile.am b/hw/xwayland/Makefile.am
+index bc1cb8506..502879e2a 100644
+--- a/hw/xwayland/Makefile.am
++++ b/hw/xwayland/Makefile.am
+@@ -21,10 +21,14 @@ Xwayland_SOURCES =                         \
+       $(top_srcdir)/Xi/stubs.c                \
+       $(top_srcdir)/mi/miinitext.c
++if GLX
++GLXVND_LIB = $(top_builddir)/glx/libglxvnd.la
++endif
++
+ Xwayland_LDADD =                              \
+       $(glamor_lib)                           \
+       $(XWAYLAND_LIBS)                        \
+-      $(top_builddir)/glx/libglxvnd.la        \
++      $(GLXVND_LIB)                           \
+       $(XWAYLAND_SYS_LIBS)                    \
+       $(top_builddir)/Xext/libXvidmode.la     \
+       $(XSERVER_SYS_LIBS)
+-- 
+2.25.1
+
index 755a762a73f49893e318a15538dfd824728a638b..e0551fa99962cad7e370b77e3b4da38ddbdd4a4b 100644 (file)
@@ -8,6 +8,7 @@ SRC_URI += "file://0001-xf86pciBus.c-use-Intel-ddx-only-for-pre-gen4-hardwar.pat
            file://0001-Avoid-duplicate-definitions-of-IOPortBase.patch \
            file://0001-Fix-segfault-on-probing-a-non-PCI-platform-device-on.patch \
            file://CVE-2021-3472.patch \
+           file://0001-hw-xwayland-Makefile.am-fix-build-without-glx.patch \
            "
 SRC_URI[sha256sum] = "977420c082450dc808de301ef56af4856d653eea71519a973c3490a780cb7c99"