]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: add sysroot handling to subcmd
authorMartin Donnelly <martin.donnelly@ge.com>
Mon, 22 Feb 2016 17:32:34 +0000 (19:32 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 26 Feb 2016 17:15:07 +0000 (17:15 +0000)
v4.5-rc1 of the kernel splits the subcommand related files
from perf into a new library, this patch adds the modification
of the Makefile to preserve the --sysroot option as for
the other perf related Makefiles.

Signed-off-by: Martin Donnelly <martin.donnelly@ge.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index 33acb42712b9f38e7f07f88cac44c6de94c4a6e4..8b862902011d5e8731206c2723e445991cd51afd 100644 (file)
@@ -164,6 +164,10 @@ do_configure_prepend () {
         sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile
         sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile
     fi
+    if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then
+        sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile
+        sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile
+    fi
     if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
         sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
     fi