]> code.ossystems Code Review - openembedded-core.git/commitdiff
pseudo: backport a patch to fix xattr removal
authorJoshua Lock <joshua.g.lock@intel.com>
Thu, 24 Mar 2016 15:58:44 +0000 (15:58 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 25 Mar 2016 10:28:04 +0000 (10:28 +0000)
xattr removal doesn't work in pseudo 1.7.5, backport a patch from
pseudo master to fix this.

[YOCTO #9324]

Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/pseudo/files/handle-remove-xattr.patch [new file with mode: 0644]
meta/recipes-devtools/pseudo/pseudo_1.7.5.bb

diff --git a/meta/recipes-devtools/pseudo/files/handle-remove-xattr.patch b/meta/recipes-devtools/pseudo/files/handle-remove-xattr.patch
new file mode 100644 (file)
index 0000000..8b7f30c
--- /dev/null
@@ -0,0 +1,36 @@
+From a24cf102967a4966bfabe36c3542fb65f35bf539 Mon Sep 17 00:00:00 2001
+From: Peter Seebach <peter.seebach@windriver.com>
+Date: Wed, 23 Mar 2016 11:55:25 -0500
+Subject: actually handle remove_xattr correctly
+
+The path is required but wasn't being extracted from the client's message,
+resulting in xattr removal never working. This does not fully address some
+deeper problems with the xattr implementation, but at least the common
+removal case works.
+
+Upstream-Status: Backport
+
+Index: pseudo-1.7.5/ChangeLog.txt
+===================================================================
+--- pseudo-1.7.5.orig/ChangeLog.txt
++++ pseudo-1.7.5/ChangeLog.txt
+@@ -1,3 +1,7 @@
++2016-03-22:
++       * (seebs) extract path from message for remove_xattr so it
++         actually works.
++
+ 2016-02-09:
+         * (seebs) 1.7.5 release
+Index: pseudo-1.7.5/pseudo.c
+===================================================================
+--- pseudo-1.7.5.orig/pseudo.c
++++ pseudo-1.7.5/pseudo.c
+@@ -543,6 +543,7 @@ pseudo_op(pseudo_msg_t *msg, const char
+               case OP_GET_XATTR:
+               case OP_LIST_XATTR:
+               case OP_REPLACE_XATTR:
++              case OP_REMOVE_XATTR:
+               case OP_SET_XATTR:
+                       /* In a rename there are two paths, null separated in msg->path */
+                       initial_len = strlen(msg->path);
index 7af4d6506503ad70a5ee676337ce772f3898a8ea..d90e64445d4aa86457a1f8588b5111a6e5c83734 100644 (file)
@@ -6,6 +6,7 @@ SRC_URI = " \
     file://fallback-passwd \
     file://fallback-group \
     file://moreretries.patch \
+    file://handle-remove-xattr.patch \
 "
 
 SRC_URI[md5sum] = "c10209938f03128d0c193f041ff3596d"