]> code.ossystems Code Review - openembedded-core.git/commitdiff
sato-screenshot: improve .la removal
authorRoss Burton <ross@burtonini.com>
Tue, 15 Sep 2020 11:05:32 +0000 (12:05 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 15 Sep 2020 11:08:00 +0000 (12:08 +0100)
Don't assume that the .la files are installed, because some libtool
alternatives don't install these.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb

index f6dac2cf889b456bd88d875a85a1a46eb826c9aa..2b1f513f1c7e08744f36bd9693b10487d100343b 100644 (file)
@@ -21,7 +21,7 @@ inherit autotools pkgconfig features_check
 FILES_${PN} += "${libdir}/matchbox-panel/*.so"
 
 do_install_append () {
-       rm ${D}${libdir}/matchbox-panel/*.la
+       rm -f ${D}${libdir}/matchbox-panel/*.la
 }
 
 # The matchbox-panel-2 requires x11 in DISTRO_FEATURES