]> code.ossystems Code Review - openembedded-core.git/commitdiff
Fix liboil, revise GStreamer packages (still WIP)
authorChris Lord <chris@openedhand.com>
Mon, 18 Sep 2006 17:54:31 +0000 (17:54 +0000)
committerChris Lord <chris@openedhand.com>
Mon, 18 Sep 2006 17:54:31 +0000 (17:54 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@724 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gstreamer/gst-meta-audio_0.10.bb
meta/packages/gstreamer/gst-meta-base_0.10.bb
meta/packages/gstreamer/gst-meta-video_0.10.bb
meta/packages/gstreamer/gst-plugins-bad_0.10.3.bb
meta/packages/gstreamer/gst-plugins-base_0.10.9.bb
meta/packages/gstreamer/gstreamer_0.10.9.bb
meta/packages/liboil/liboil_0.3.9.bb

index ebbd202ce63a0ac54f2bab4ad5ba08b96908d48b..3e9a46680b35f344dc6d0b2949958a50c288ca15 100644 (file)
@@ -1,6 +1,5 @@
-DEPENDS = "gst-meta-base gst-fluendo-mp3 gst-fluendo-mpegdemux"
-RDEPENDS = "gst-meta-base gst-plugin-vorbis gst-plugin-ogg gst-fluendo-mp3 \
-            gst-fluendo-mpegdemux"
-PR = "r1"
+DEPENDS = "gst-meta-base gst-plugins-bad"
+RDEPENDS = "gst-meta-base gst-plugin-ivorbis gst-plugin-ogg"
+PR = "r3"
 
 ALLOW_EMPTY = "1"
index 263cf4b13d9f2f894d8938be8818a73522e9afdc..12d98ee5d214f0fbe48c1417ef1d542899e710de 100644 (file)
@@ -1,9 +1,9 @@
 DEPENDS = "gstreamer gst-plugins-base"
-RDEPENDS = "gstreamer gst-plugins-base gst-plugin-playbin \
+RDEPENDS = "gstreamer gst-plugin-playbin \
        gst-plugin-decodebin gst-plugin-gnomevfs gst-plugin-alsa \
        gst-plugin-volume gst-plugin-ximagesink gst-plugin-audioconvert \
        gst-plugin-audioresample gst-plugin-typefindfunctions \
-       gst-plugin-videoscale gst-plugin-ffmpegcolorspace"
-PR = "r1"
+       gst-plugin-videoscale gst-plugin-ffmpegcolorspace gst-plugin-autodetect"
+PR = "r2"
 
 ALLOW_EMPTY = "1"
index 5ff9b58bbb1441fdecd8802926585eb27eff868d..cd63d4ba2e281c8f63bc44d44f38ef914a1790f4 100644 (file)
@@ -1,9 +1,9 @@
 DEPENDS = "gst-meta-base gst-plugins-good gst-fluendo-mpegdemux \
            gst-plugins-ugly"
-RDEPENDS = "gst-meta-base gst-plugins-good gst-plugins-ugly gst-plugin-avi \
+RDEPENDS = "gst-meta-base gst-plugin-avi \
             gst-plugin-matroska gst-plugin-ogg \
            gst-fluendo-mpegdemux gst-plugin-mpeg2dec"
 RRECOMMENDS = "gst-meta-audio"
-PR = "r1"
+PR = "r2"
 
 ALLOW_EMPTY = "1"
index ecffc245ad479f88d7ba3c584540347d24bc956e..003fca8aa810567cffad6de18f5137c1b78ab961 100644 (file)
@@ -1,7 +1,7 @@
 require gst-plugins.inc
-DEPENDS += "gst-plugins-base libmusicbrainz"
-PR = "r2"
+DEPENDS += "gst-plugins-base libmusicbrainz tremor"
+PR = "r3"
 
 EXTRA_OECONF += "--disable-examples --disable-experimental --disable-sdl \
-               --with-plugins=musicbrainz,wavpack"
+               --with-plugins=musicbrainz,wavpack,ivorbis"
 
index 541b75f6a1055cf6886b93d70c8339c2b78ba97e..efddc375642b8a941df47de1f4cb052778e0b71f 100644 (file)
@@ -1,5 +1,5 @@
 require gst-plugins.inc
-DEPENDS += "libx11 alsa-lib freetype gnome-vfs liboil libogg libvorbis tremor"
+DEPENDS += "libx11 alsa-lib freetype gnome-vfs liboil libogg libvorbis"
 RDEPENDS += "gnome-vfs-plugin-file gnome-vfs-plugin-http gnome-vfs-plugin-ftp \
              gnome-vfs-plugin-sftp"
 PROVIDES_${PN} += "gst-plugins"
index 43d5e34df420443342ca0417f1f720d5bffbe389..6acaa3dd6c50ee3b4bab8a21b0215b35ae5c544b 100644 (file)
@@ -6,7 +6,7 @@ LICENSE = "LGPL"
 HOMEPAGE = "http://www.gstreamer.net/"
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
 DEPENDS = "glib-2.0 gettext-native libxml2"
-PR = "r2"
+PR = "r3"
 
 inherit autotools pkgconfig
 
@@ -15,7 +15,7 @@ SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz
 #           file://gstregistrybinary.c \
 #           file://gstregistrybinary.h \
 #           file://gstreamer-0.9-binary-registry.patch;patch=1"
-EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no"
+EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no --disable-examples --disable-tests --disable-valgrind --disable-debug"
 
 #do_compile_prepend () {
 #      mv ${WORKDIR}/gstregistrybinary.[ch] ${S}/gst/
index 04a83100b075ff649a73d7cafeb2165b00ed5006..65d2b149fccb17aa8736966470403f3f99e92973 100644 (file)
@@ -2,8 +2,10 @@ DESCRIPTION = "Liboil is a library of simple functions that are optimized for va
 HOMEPAGE = "http://liboil.freedesktop.org/"
 LICENSE = "various"
 MAINTAINER = "Koen Kooi <koen@on.kabel.utwente.nl>"
+PR = "r1"
 
-SRC_URI = "http://liboil.freedesktop.org/download/${P}.tar.gz"
+SRC_URI = "http://liboil.freedesktop.org/download/${P}.tar.gz \
+           file://no-tests.patch;patch=1"
 
 inherit autotools pkgconfig