]> code.ossystems Code Review - openembedded-core.git/commitdiff
coreutils: Switch to disabling gmp support
authorTom Rini <tom_rini@mentor.com>
Tue, 22 Mar 2011 16:46:27 +0000 (09:46 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 23 Mar 2011 16:20:54 +0000 (16:20 +0000)
Coreutils can optionally build with libgmp support and for our uses
it's fine to just not build it rather than add the dependency.

Signed-off-by: Tom Rini <tom_rini@mentor.com>
meta/recipes-core/coreutils/coreutils_8.9.bb

index 33422d1e1ee7c53c2fd082c1e6989b00fa8e2f5e..955aaf5c425ca1bd281098d8fd8f958b31d988cb 100644 (file)
@@ -7,9 +7,9 @@ BUGTRACKER = "http://debbugs.gnu.org/coreutils"
 LICENSE = "GPLv3+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
                     file://src/ls.c;startline=5;endline=16;md5=e1a509558876db58fb6667ba140137ad"
-PR = "r0"
+PR = "r1"
 DEPENDS = "perl-native gmp"
-DEPENDS_virtclass-native = "perl-native gmp-native"
+DEPENDS_virtclass-native = "perl-native"
 
 inherit autotools gettext
 
@@ -18,6 +18,8 @@ SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.gz"
 SRC_URI[md5sum] = "36909ae68840d73a800120cf74af794a"
 SRC_URI[sha256sum] = "aa991fa4296b22ff929a31a5cb5528bb783c84cdef4503c4ff311cfbeaebf50a"
 
+EXTRA_OECONF_virtclass-native = "--without-gmp"
+
 # [ gets a special treatment and is not included in this
 bindir_progs = "base64 basename chcon cksum comm csplit cut dir dircolors dirname du \
                 env expand expr factor fmt fold groups head hostid id install \