]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto: fix PV
authorBruce Ashfield <bruce.ashfield@gmail.com>
Fri, 21 Feb 2020 17:45:56 +0000 (12:45 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 22 Feb 2020 23:51:46 +0000 (23:51 +0000)
For whatever reason, the creation of the 5.4 recipes missed the
PV that we've always had in linux-yocto. PV follows the LINUX_VERSION
variable and clearly indicates that we have git commits in our tree
above the -stable releases.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
meta/recipes-kernel/linux/linux-yocto_5.4.bb

index fc31dc869afda143df66c951e4f5a71e0e4d64d8..ab93f1bf550347707554a6e2432b619c7641295a 100644 (file)
@@ -24,7 +24,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
 DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
 DEPENDS += "openssl-native util-linux-native"
 
-PV = "5.4.15"
+PV = "${LINUX_VERSION}+git${SRCPV}"
 
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
index cfecf986fb9dcd3157479730dd2c9079286cbcd5..097357d9c003181b2cbed876cd3f5aa8655ec75d 100644 (file)
@@ -19,7 +19,7 @@ SRCREV_machine_qemuarm ?= "3805e4f98313c4a4c64ffdb06b6401de8746fe45"
 SRCREV_machine ?= "2358d789229f8d80ebe4b3e35d3819c4f0e00926"
 SRCREV_meta ?= "c11911d4d1cf0d0b069dfd1922b41256f61442de"
 
-PV = "5.4.15"
+PV = "${LINUX_VERSION}+git${SRCPV}"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.4;destsuffix=${KMETA}"
index aa17380d0087108b784dcb198cf90fdf7de3cde1..0b2a2305f1b19298b71506749dc3f75e0abc7474 100644 (file)
@@ -35,7 +35,7 @@ LINUX_VERSION ?= "5.4.20"
 DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
 DEPENDS += "openssl-native util-linux-native"
 
-PV = "5.4.15"
+PV = "${LINUX_VERSION}+git${SRCPV}"
 
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"