]> code.ossystems Code Review - openembedded-core.git/commitdiff
serf: specify LIBDIR to avoid install issue
authorTing Liu <ting.liu@freescale.com>
Wed, 23 Jul 2014 03:58:57 +0000 (11:58 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 23 Jul 2014 20:56:07 +0000 (21:56 +0100)
LIBDIR defaults to ${prefix}/lib, use ${libdir} to avoid issue on
64bit platforms.

Signed-off-by: Ting Liu <ting.liu@freescale.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/serf/serf_1.3.6.bb

index 9893cb7212d8c74375cdeb4364f27a32c6168878..08b04d3ca6715c9073dbea8fc0e439e117d260bb 100644 (file)
@@ -21,7 +21,7 @@ do_compile() {
 }
 
 do_install() {
-       ${STAGING_BINDIR_NATIVE}/scons PREFIX=${D}${prefix} install
+       ${STAGING_BINDIR_NATIVE}/scons PREFIX=${D}${prefix} LIBDIR=${D}${libdir} install
 }
 
-BBCLASSEXTEND = "native"
\ No newline at end of file
+BBCLASSEXTEND = "native"