]> code.ossystems Code Review - openembedded-core.git/commitdiff
ncurses: 6.0+20160625 -> 6.0+20161126
authorHongxu Jia <hongxu.jia@windriver.com>
Tue, 14 Feb 2017 07:02:19 +0000 (02:02 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 23 Feb 2017 20:29:20 +0000 (12:29 -0800)
Add a patch to fix the CC/CFLAGS mangling that broke builds. [RB]

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/ncurses/files/fix-cflags-mangle.patch [new file with mode: 0644]
meta/recipes-core/ncurses/ncurses_6.0+20161126.bb [moved from meta/recipes-core/ncurses/ncurses_6.0+20160625.bb with 73% similarity]

diff --git a/meta/recipes-core/ncurses/files/fix-cflags-mangle.patch b/meta/recipes-core/ncurses/files/fix-cflags-mangle.patch
new file mode 100644 (file)
index 0000000..e9447c5
--- /dev/null
@@ -0,0 +1,18 @@
+configure has a piece of logic to detect users "abusing" CC to hold compiler
+flags (which we do).  It also has logic to "correct" this by moving the flags
+from CC to CFLAGS, but the sed only handles a single argument in CC.
+
+Replace the sed with awk to filter out all words that start with a hyphen.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/configure b/configure
+index 7f31208..1a29cfc 100755
+--- a/configure
++++ b/configure
+@@ -2191,2 +2191,2 @@ echo "$as_me: WARNING: your environment misuses the CC variable to hold CFLAGS/C
+-      cf_flags=`echo "$CC" | sed -e 's/^.*[   ]\(-[^  ]\)/\1/'`
+-      CC=`echo "$CC " | sed -e 's/[   ]-[^    ].*$//' -e 's/[         ]*$//'`
++      cf_flags=`echo "$CC" | awk  'BEGIN{ORS=" ";RS=" "} /^-.+/ {print $1}'`
++      CC=`echo "$CC " | awk  'BEGIN{ORS=" ";RS=" "} /^[^-].+/ {print $1}'`
similarity index 73%
rename from meta/recipes-core/ncurses/ncurses_6.0+20160625.bb
rename to meta/recipes-core/ncurses/ncurses_6.0+20161126.bb
index 6514613fe3261b03f51f419d7b019370e5c22524..e95741f4c32db752c94ee03ef0ed8faa4f0c071b 100644 (file)
@@ -1,10 +1,11 @@
 require ncurses.inc
 
 SRC_URI += "file://tic-hang.patch \
+            file://fix-cflags-mangle.patch \
             file://config.cache \
 "
 # commit id corresponds to the revision in package version
-SRCREV = "63dd558cb8e888d6fab5f00bbf7842736a2356b9"
+SRCREV = "3db0bd19cb50e3d9b4f2cf15b7a102fe11302068"
 S = "${WORKDIR}/git"
 EXTRA_OECONF += "--with-abi-version=5"
 UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+(\+\d+)*)"