]> code.ossystems Code Review - openembedded-core.git/commitdiff
gdb upgrade from 7.1 to 7.2
authorNitin A Kamble <nitin.a.kamble@intel.com>
Mon, 8 Nov 2010 17:12:33 +0000 (09:12 -0800)
committerSaul Wold <sgw@linux.intel.com>
Mon, 15 Nov 2010 05:08:26 +0000 (21:08 -0800)
Add new patch:
  gdb/fix_for_build_error_internal_error_call.patch : this avoids a
build error.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/recipes-devtools/gdb/gdb-cross-canadian_7.2.bb [moved from meta/recipes-devtools/gdb/gdb-cross-canadian_7.1.bb with 95% similarity]
meta/recipes-devtools/gdb/gdb-cross_7.2.bb [moved from meta/recipes-devtools/gdb/gdb-cross_7.1.bb with 90% similarity]
meta/recipes-devtools/gdb/gdb.inc
meta/recipes-devtools/gdb/gdb/fix_for_build_error_internal_error_call.patch [new file with mode: 0644]
meta/recipes-devtools/gdb/gdb_7.2.bb [moved from meta/recipes-devtools/gdb/gdb_7.1.bb with 62% similarity]

similarity index 95%
rename from meta/recipes-devtools/gdb/gdb-cross-canadian_7.1.bb
rename to meta/recipes-devtools/gdb/gdb-cross-canadian_7.2.bb
index 3adcdcc2844437c98f5a71fc80c33bdae10a0e50..5982c0568eae14924a567e60aa3cd9f0105740bf 100644 (file)
@@ -4,7 +4,7 @@ DEPENDS = "ncurses-nativesdk expat-nativesdk gettext-nativesdk"
 
 inherit cross-canadian
 
-PR = "r1"
+PR = "r0"
 
 GDBPROPREFIX = "--program-prefix='${TARGET_PREFIX}'"
 EXPAT = "--with-expat"
similarity index 90%
rename from meta/recipes-devtools/gdb/gdb-cross_7.1.bb
rename to meta/recipes-devtools/gdb/gdb-cross_7.2.bb
index ea1f0d8c7f980eef6f945bca851cb9f05fc008af..b5a8beae6deac5c5e59170c33ea9cc932b3d33d8 100644 (file)
@@ -3,4 +3,4 @@ require gdb-cross.inc
 SRC_URI += "file://sim-install-6.6.patch;patch=1"
 EXPAT = "--with-expat"
 
-PR = "r2"
+PR = "r0"
index 0ddd90b191729d1ba5637f7cbbf77afb2b71a79b..efa3cbffe4ac65ab150cd6632d5c4fb1961702aa 100644 (file)
@@ -3,7 +3,8 @@ require gdb-common.inc
 inherit gettext
 
 SRC_URI += "file://kill_arm_map_symbols.patch \
-            file://gdbserver-cflags-last.diff;striplevel=0 "
+            file://gdbserver-cflags-last.diff;striplevel=0 \
+            file://fix_for_build_error_internal_error_call.patch "
 #LDFLAGS_append = " -s"
 #export CFLAGS_append=" -L${STAGING_LIBDIR}"
 
diff --git a/meta/recipes-devtools/gdb/gdb/fix_for_build_error_internal_error_call.patch b/meta/recipes-devtools/gdb/gdb/fix_for_build_error_internal_error_call.patch
new file mode 100644 (file)
index 0000000..f39eaa9
--- /dev/null
@@ -0,0 +1,18 @@
+The prototype of function internall_error has changed. And one place in the code was not synced up with the new prototype, causing build error. This patche fixes that.
+
+Nitin A Kamble <nitin.a.kamble@intel.com>
+2010/11/12
+
+Index: gdb-7.2/gdb/gdbserver/linux-i386-ipa.c
+===================================================================
+--- gdb-7.2.orig/gdb/gdbserver/linux-i386-ipa.c
++++ gdb-7.2/gdb/gdbserver/linux-i386-ipa.c
+@@ -178,7 +178,7 @@ supply_static_tracepoint_registers (stru
+           }
+           break;
+         default:
+-          internal_error ("unhandled register size: %d",
++          internal_error (__FILE__, __LINE__, "unhandled register size: %d",
+                           i386_st_collect_regmap[i].size);
+         }
+       }
similarity index 62%
rename from meta/recipes-devtools/gdb/gdb_7.1.bb
rename to meta/recipes-devtools/gdb/gdb_7.2.bb
index be40f3f12be9d4ddfb03a541b150a9577ecb3e94..ec413a13977bbddfc73869e89abe72a329c298c8 100644 (file)
@@ -1,3 +1,3 @@
 require gdb.inc
 
-PR = "r2"
+PR = "r0"