]> code.ossystems Code Review - openembedded-core.git/commitdiff
recipes-extended: add x11 to REQUIRED_DISTRO_FEATURES
authorRobert Yang <liezhi.yang@windriver.com>
Mon, 11 May 2015 02:30:03 +0000 (19:30 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 14 May 2015 10:41:12 +0000 (11:41 +0100)
They can't be built withou x11 in DISTRO_FEATURES.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
meta/recipes-extended/xdg-utils/xdg-utils_1.1.0-rc1.bb

index a07a6adb689ecf19fb1828b6f1f7418483ef662f..3d5075e807f5505ab06c1d785629cb270a5d9ff6 100644 (file)
@@ -7,7 +7,10 @@ DESCRIPTION = "Packages required to satisfy the Linux Standard Base (LSB) specif
 PR = "r10"
 LICENSE = "MIT"
 
-inherit packagegroup
+inherit packagegroup distro_features_check
+
+# The libxt, libxtst and others require x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
 
 #
 # We will skip parsing this packagegeoup for non-glibc systems
index 2ac979b0b923b94e386c5b7d6ed4741e681a4037..46f1e3c6e39fafbff28da82f2086023b18a28c1f 100644 (file)
@@ -24,6 +24,9 @@ SRC_URI = "http://portland.freedesktop.org/download/${BPN}-${PV}.tar.gz \
 SRC_URI[md5sum] = "fadf5e7a08e0526fc60dbe3e5b7ef8d6"
 SRC_URI[sha256sum] = "7b05558ae4bb8ede356863cae8c42e3e012aa421bf9d45130a570fd209d79102"
 
-inherit autotools-brokensep
+inherit autotools-brokensep distro_features_check
+
+# The xprop requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
 
 RDEPENDS_${PN} += "xprop"