]> code.ossystems Code Review - openembedded-core.git/commitdiff
beecrypt: Add PACKAGECONFIG for cplusplus
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 26 Nov 2013 14:32:28 +0000 (14:32 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 26 Nov 2013 22:59:59 +0000 (22:59 +0000)
Add a PACKGECONFIG to control the building of the beecrypt C++
bindings. The only user of beecrypt in OE-Core is rpm and this doesn't
need the C++ bindings so default the option to be off. This means
we can lose the icu dependency by default which is a significant
performance win.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/beecrypt/beecrypt_4.2.1.bb

index 0a8ff4bc564e1d915999b4f2c30bce6e9b719a19..a91720102380a15f3962e0b628bb738c6c238c3f 100644 (file)
@@ -16,8 +16,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=9894370afd5dfe7d02b8d14319e729a1 \
                     file://COPYING.LIB;md5=dcf3c825659e82539645da41a7908589 \
                     file://include/beecrypt/beecrypt.h;endline=20;md5=47a93eef539aac237eef86297a4d71c1"
 
-DEPENDS = "icu"
-
 PR = "r3"
 
 inherit autotools multilib_header
@@ -29,6 +27,9 @@ do_install_append() {
 
 EXTRA_OECONF="--without-python --enable-shared --enable-static --disable-openmp --with-java=no"
 
+PACKAGECONFIG = ""
+PACKAGECONFIG[cplusplus] = "--with-cplusplus,--without-cplusplus,icu"
+
 FILES_${PN} = "${sysconfdir} ${libdir}/*.so.* ${libdir}/${BPN}/*.so.*"
 FILES_${PN}-dev += "${libdir}/${BPN}/*.so ${libdir}/${BPN}/*.la"
 FILES_${PN}-staticdev += "${libdir}/${BPN}/*.a"