]> code.ossystems Code Review - openembedded-core.git/commitdiff
mozilla-headless: Convert to hg and add mozilla-headless-services
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 14 May 2009 14:01:07 +0000 (15:01 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 14 May 2009 14:01:07 +0000 (15:01 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/mozilla-headless/mozilla-headless-services/confighack.patch [new file with mode: 0644]
meta/packages/mozilla-headless/mozilla-headless-services_git.bb [new file with mode: 0644]
meta/packages/mozilla-headless/mozilla-headless_hg.bb [moved from meta/packages/mozilla-headless/mozilla-headless_git.bb with 81% similarity]

diff --git a/meta/packages/mozilla-headless/mozilla-headless-services/confighack.patch b/meta/packages/mozilla-headless/mozilla-headless-services/confighack.patch
new file mode 100644 (file)
index 0000000..dcfe11e
--- /dev/null
@@ -0,0 +1,13 @@
+Index: places-glib/configure.ac
+===================================================================
+--- places-glib.orig/configure.ac      2009-04-17 10:29:15.000000000 +0100
++++ places-glib/configure.ac   2009-04-17 10:29:44.000000000 +0100
+@@ -99,6 +99,8 @@
+ PKG_CHECK_MODULES(GLIB, [glib-2.0])
+ PKG_CHECK_MODULES(DBUS, [dbus-glib-1])
++XUL_LIBS="$XUL_LIBS -lmozjs"
++
+ MOZHOME=`${PKG_CONFIG} --variable=prefix mozilla-headless`"/lib/xulrunner-"`${PKG_CONFIG} --modversion mozilla-headless`
+ AC_SUBST([MOZHOME])
diff --git a/meta/packages/mozilla-headless/mozilla-headless-services_git.bb b/meta/packages/mozilla-headless/mozilla-headless-services_git.bb
new file mode 100644 (file)
index 0000000..cb538ee
--- /dev/null
@@ -0,0 +1,12 @@
+SRC_URI = "git://git.moblin.org/mozilla-headless-services.git;protocol=git \
+           file://confighack.patch;patch=1"
+PV = "0.0+git${SRCREV}"
+PR = "r1"
+
+DEPENDS = "glib-2.0 dbus mozilla-headless"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} += "${datadir}/dbus-1/services"
+
+inherit autotools_stage
similarity index 81%
rename from meta/packages/mozilla-headless/mozilla-headless_git.bb
rename to meta/packages/mozilla-headless/mozilla-headless_hg.bb
index 7e59ed35f73175d25329bf11f1cccfacd3884d86..e3ef60b783e5547f44254f64299c4446f1bb5832 100644 (file)
@@ -1,9 +1,9 @@
 
-SRC_URI = "hg://hg.mozilla.org/incubator;protocol=http;rev=c6fe23d41598;module=offscreen \
+SRC_URI = "hg://hg.mozilla.org/incubator;protocol=http;rev=71b4ab01cbf2;module=offscreen \
            file://configurefix.patch;patch=1 \
            file://jsautocfg.h \
           file://mozconfig"
-PV = "0.0+hg-1.0+c6fe23d41598"
+PV = "0.0+hg-1.0+71b4ab01cbf2"
 PR = "r0"
 
 S = "${WORKDIR}/offscreen"
@@ -34,7 +34,7 @@ do_compile () {
        base_do_compile
 }
 
-EXTRA_OECONF =+ "--enable-application=xulrunner --disable-javaxpcom --enable-system-sqlite --enable-default-toolkit=cairo-headless --disable-printing --disable-crashreporter --disable-plugins --disable-accessibility --enable-pango --disable-tests"
+EXTRA_OECONF =+ "--enable-application=xulrunner --enable-default-toolkit=cairo-headless --enable-pango --disable-optimize --enable-debug --disable-tests --disable-printing --disable-crashreporter --disable-accessibility --disable-javaxpcom --enable-plugins --enable-system-sqlite --disable-necko-wifi"
 
 export LIBXUL_DIST="${S}/dist"