]> code.ossystems Code Review - openembedded-core.git/commitdiff
lttng-tools: Disable hanging tests and other ptest fixes
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 26 Feb 2019 22:49:39 +0000 (22:49 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Feb 2019 18:03:44 +0000 (18:03 +0000)
Disable some tests which hang, blocking many other ptests.

Also add missing test artefacts to improve test pass rate and
fix failures.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb

index 13bab9068eb169423d2886cb34e30e8651461cae..9d21fb00bfe91ac5ad7c3638aaf900719ec5cbba 100644 (file)
@@ -63,11 +63,11 @@ do_install_append () {
 }
 
 do_install_ptest () {
-    for f in Makefile tests/Makefile tests/utils/utils.sh ; do
+    for f in Makefile tests/Makefile tests/utils/utils.sh tests/regression/tools/save-load/load-42*.lttng tests/regression/tools/save-load/configuration/load-42*.lttng ; do
         install -D "${B}/$f" "${D}${PTEST_PATH}/$f"
     done
 
-    for f in config/tap-driver.sh config/test-driver ; do
+    for f in config/tap-driver.sh config/test-driver src/common/config/session.xsd src/common/mi-lttng-3.0.xsd; do
         install -D "${S}/$f" "${D}${PTEST_PATH}/$f"
     done
 
@@ -141,8 +141,17 @@ do_install_ptest () {
         -e 's#\(^test.*LDADD.=\)#disable\1#g' \
         -i ${D}${PTEST_PATH}/tests/unit/Makefile
 
+    #
+    # Disable notification tools tests as currently
+    # these hang and cause the rest of the ptests to timeout
+    #
+    sed -e 's#tools/notification/test_notification_ust##g' \
+        -e 's#tools/notification/test_notification_kernel##g' \
+        -e 's#tools/notification/test_notification_multi_app##g' \
+        -i ${D}${PTEST_PATH}/tests/regression/Makefile
+
     # Substitute links to installed binaries.
-    for prog in lttng lttng-relayd lttng-sessiond lttng-consumerd ; do
+    for prog in lttng lttng-relayd lttng-sessiond lttng-consumerd lttng-crash; do
         exedir="${D}${PTEST_PATH}/src/bin/${prog}"
         install -d "$exedir"
         case "$prog" in