]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta: remove redundant ${libdir}/cmake from FILES_${PN}-dev
authorRoss Burton <ross@burtonini.com>
Fri, 16 Jul 2021 15:09:05 +0000 (16:09 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 19 Jul 2021 12:33:28 +0000 (13:33 +0100)
Since oe-core 543e39ad "bitbake.conf: handle cmake -dev files packaging
with default rules" (June 2018) there's no need for recipes to add
${libdir}/cmake or ${datadir}/cmake to FILES_${PN}-dev themselves.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
meta/recipes-core/dbus/dbus_1.12.20.bb
meta/recipes-core/libxml/libxml2_2.9.12.bb
meta/recipes-gnome/gtk-doc/gtk-doc_1.33.2.bb
meta/recipes-graphics/libsdl2/libsdl2_2.0.14.bb
meta/recipes-multimedia/pulseaudio/pulseaudio.inc
meta/recipes-support/bash-completion/bash-completion_2.11.bb
meta/recipes-support/gpgme/gpgme_1.16.0.bb

index 32e7d9cfa38e78f5542128c5468c21469ed2aa84..2f6da675100dc362dc541e675f868cc2af02b2c2 100644 (file)
@@ -71,7 +71,7 @@ FILES_${PN}-tools = "${bindir}/dbus-uuidgen \
 "
 FILES_${PN}-lib = "${libdir}/lib*.so.*"
 RRECOMMENDS_${PN}-lib = "${PN}"
-FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${libdir}/cmake/DBus1 ${bindir}/dbus-test-tool ${datadir}/xml/dbus-1"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-test-tool ${datadir}/xml/dbus-1"
 
 PACKAGE_WRITE_DEPS += "${@bb.utils.contains('DISTRO_FEATURES','systemd sysvinit','systemd-systemctl-native','',d)}"
 pkg_postinst_dbus() {
index 955d934d7d2d97c82c63eef15e9edb730a1b7808..2d1e92966ff72f033aca74a2d32014cd6cc85cd4 100644 (file)
@@ -67,7 +67,7 @@ PACKAGE_BEFORE_PN += "${PN}-utils"
 PACKAGES += "${PN}-python"
 
 FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
-FILES_${PN}-dev += "${libdir}/xml2Conf.sh ${libdir}/cmake/*"
+FILES_${PN}-dev += "${libdir}/xml2Conf.sh"
 FILES_${PN}-utils = "${bindir}/*"
 FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
 
index 3b308318b2ddad16948d20b0fc4e47ef451bdf73..23cd25986e617339a61aa1410301bb20c00c15be 100644 (file)
@@ -48,7 +48,6 @@ do_install_append () {
 }
 
 FILES_${PN} += "${datadir}/sgml"
-FILES_${PN}-dev += "${libdir}/cmake"
 FILES_${PN}-doc = ""
 
 SYSROOT_PREPROCESS_FUNCS_append_class-native = " gtkdoc_makefiles_sysroot_preprocess"
index 54556abb2757588990c47af4e50fc29e612622e8..3aac32159ad92339f467e52ee409bad9bd8a0ee0 100644 (file)
@@ -76,6 +76,4 @@ do_configure_prepend() {
         export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
 }
 
-FILES_${PN}-dev += "${libdir}/cmake"
-
 BBCLASSEXTEND = "native nativesdk"
index 2c9e8167c4f637ab1d66cf2bc5ab65018eec4ce9..4e226c616daf99b0a77d2491c4b42d3ecca43486 100644 (file)
@@ -182,7 +182,7 @@ FILES_libpulse = "${libdir}/libpulse.so.* ${sysconfdir}/pulse/client.conf"
 FILES_libpulse-simple = "${libdir}/libpulse-simple.so.*"
 FILES_libpulse-mainloop-glib = "${libdir}/libpulse-mainloop-glib.so.*"
 
-FILES_${PN}-dev += "${libdir}/pulse-${PV}/modules/*.la ${datadir}/vala ${libdir}/cmake"   
+FILES_${PN}-dev += "${libdir}/pulse-${PV}/modules/*.la ${datadir}/vala"
 FILES_${PN}-bin += "${sysconfdir}/default/volatiles/04_pulse"
 FILES_${PN}-pa-info = "${bindir}/pa-info"
 FILES_${PN}-server = "${bindir}/pulseaudio ${bindir}/start-* ${sysconfdir} ${bindir}/pactl */udev/rules.d/*.rules */*/udev/rules.d/*.rules ${systemd_user_unitdir}/*"
index 40765359028268951524f8cd7ac3598eb9e0205a..67738c3c83ab50f9bd5262d510c29f81ad1d9993 100644 (file)
@@ -37,6 +37,4 @@ PACKAGES =+ "${PN}-extra"
 FILES_${PN}-extra = "${datadir}/${BPN}/completions/ \
     ${datadir}/${BPN}/helpers/"
 
-FILES_${PN}-dev += "${datadir}/cmake"
-
 BBCLASSEXTEND = "nativesdk"
index 86dd69f0a13771b097393252ae05fc55856cfb7c..13f456fcfc780797faea09a4d1a23b84f3bc4f81 100644 (file)
@@ -72,9 +72,7 @@ PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3-gpg ', ''
 FILES_${PN}-cpp = "${libdir}/libgpgmepp.so.*"
 FILES_python2-gpg = "${PYTHON_SITEPACKAGES_DIR}/*"
 FILES_python3-gpg = "${PYTHON_SITEPACKAGES_DIR}/*"
-FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/* \
-                    ${libdir}/cmake/* \
-"
+FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/*"
 
 CFLAGS_append_libc-musl = " -D__error_t_defined "
 do_configure_prepend () {